Commercial Design Using Autodesk® Revit® 2019
Includes video instruction
Visit the following websites to learn more about this book:
Lesson 3  
FLOOR PLAN (First Floor):

In this lesson you will draw the first floor plan of an office building. The office building will be further developed in subsequent chapters. It is recommended that you spend adequate time on this lesson as later lessons build on this one.

Exercise 3-1:  
Project Overview

A program statement is created in the pre-design phase of a project. Working with the client (or user group), the architect gathers as much information as possible about the project before starting to design.

The information gathered includes:

- **Rooms**: What rooms are required?
- **Size**: How big do the rooms need to be? (E.g., toilets for a convention center are much bigger than for a dentist’s office.)
- **Adjacencies**: This room needs to be next to that room. (E.g., the public toilets need to be accessible from the public lobby.)

With the project statement in hand, the architect can begin the design process. Although modifications may (and will) need to be made to the program statement, it is used as a goal to meet the client’s needs.

You will not have a program statement, per se, with this project. However, the same information will be provided via step-by-step instructions in this book.

Project Overview

You will model a three-story office building located in a rural setting. Just to the North of the building site is a medium-sized lake. For the sake of simplicity, the property is virtually flat.

The main entry and parking is from the south side of the building. You enter the building into a three-story atrium. Levels 2 and 3 have guard railings that look down into Level 1 in the atrium. The atrium is enclosed on three sides by full height curtain walls (glass walls). See the image on the front cover.
This building is not meant to meet any particular building code. It is strictly a tool to learn how to use Revit. Having said that, however, there are several general comments as to how codes may impact a particular part of the design.

The floor plans are mostly open office areas with a few smaller rooms for toilets, private offices, work and break rooms, etc. These areas have several “punched” window openings on the exterior walls (punched as opposed to ribbon windows).

**FIGURE 3-1.1** Level 1 floor plan sketch

**FIGURE 3-1.2** South elevation sketch
Exercise 3-2:
Exterior Walls

You will begin the first floor plan by drawing the exterior walls. Like many projects, early on you might not be certain what the exterior walls are going to be. So, we will start out using the generic wall styles. Then we will change them to a custom wall style (that you will create) once we have decided what the wall construction is.

Adjust Wall Settings

1. Start a new project using the Architectural Template. Warning: Be sure to select the correct template as this is the basis for the remainder of the book.

The previous chapter started with a more complete template. This chapter starts from the default template so you have the opportunity to learn how to create things such as the room finish schedule so you better understand how Revit works.

2. Select the Wall tool from the Ribbon and then make the following changes to the wall options (Figure 3-2.1):
   - Wall style: Basic Wall: Generic – 12"
   - Height: Unconnected
   - Height: 36’ 0”
   - Location Line: Finish Face: Exterior
   - Chain: Checked

Draw the Exterior Walls

3. Draw the walls shown in Figure 3-2.2. Make sure your dimensions are correct. Use the Measure tool to verify your dimensions. Do not add the dimensions.

   NOTE: If you draw in a clockwise fashion, your walls will have the exterior side of the wall correctly positioned. You can also use the spacebar to toggle which side the exterior face is on.
Create a Custom Wall Style

Revit provides several predefined wall styles, from metal studs with gypsum board to concrete block and brick cavity walls. However, you will occasionally need a wall style that has not yet been predefined by Revit. You will study this feature next.

First, you will take a quick look at a more complex wall type that Revit provides so you can see how they are set up.

4. With the Wall tool selected, pick the wall type Basic Wall: Exterior – Brick on CMU from the Type Selector drop-down list. (See image at right.)

5. Click the Edit Type button on the Properties Palette (Fig. 3-2.3).

6. You should be in the Type Properties dialog box. Click the Edit button next to the Structure parameter (Figure 3-2.4).
Finally, you are in the *Edit Assembly* dialog box. This is where you can modify existing wall types or create new ones. Click <<Preview>> to display a preview of the selected wall type (Figure 3-2.5).
Here, the *Edit Assembly* dialog box allows you to change the composition of an existing wall or to create a new wall.

Things to notice in the *Edit Assembly* dialog box (Figure 3-2.5):

- The exterior side is labeled at the top and interior side at the bottom.
- You will see horizontal rows (i.e., Core Boundary) identifying the core material. The core material can be used to place walls and dimension walls. For example, the *Wall* tool will let you draw a wall with the interior or exterior core face as the reference line. On an interior wall you would typically dimension to the face of CMU rather than to the finished face of gypsum board. This is to work out coursing and give the contractor the information needed for the part of the wall he will build first.
- Each row is called a layer. By clicking on a layer and picking the Up or Down buttons, you can reposition materials, or layer, within the wall assembly.

8. Click **Cancel** in each open dialog box to close them.

9. Set the wall style back to *Basic Wall: Generic – 12”* in the Type Selector.

10. Click the **Edit Type** button again on the Properties Palette.

11. Click **Duplicate**.

12. Enter **Brick & CMU cavity wall** for the new wall type name, and then click **OK** (Figure 3-2.6).

![Figure 3-2.6 New wall type name](image)

13. Click the **Edit** button next to the *Structure* parameter.
Using the **Insert** button and the **Up** and **Down** buttons, add the *layers* to your new wall style as shown below in **Figure 3-2.7**.

<table>
<thead>
<tr>
<th>Function</th>
<th>Material</th>
<th>Thickness</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finish 1 [4]</td>
<td>Brick, Common</td>
<td>4”</td>
</tr>
<tr>
<td>Thermal/Air Layer [3]</td>
<td>Air</td>
<td>2”</td>
</tr>
<tr>
<td>Thermal/Air Layer [3]</td>
<td>Rigid insulation</td>
<td>2”</td>
</tr>
<tr>
<td>Membrane Layer</td>
<td>Damp-proofing</td>
<td>0”</td>
</tr>
<tr>
<td>Core Boundary</td>
<td>Layers above wrap</td>
<td>0”</td>
</tr>
<tr>
<td>Structure [1]</td>
<td>Concrete Masonry Units</td>
<td>8”</td>
</tr>
<tr>
<td>Core Boundary</td>
<td>Layers below wrap</td>
<td>0”</td>
</tr>
<tr>
<td>Substrate [2]</td>
<td>Metal – Furring</td>
<td>2 1/2”</td>
</tr>
</tbody>
</table>

**Figure 3-2.7** New wall layers

Masonry is typically drawn nominally in plans and smaller scaled details. This helps to figure out coursing for both drawing and dimensioning. For example, 8” concrete block is actually 7 ⅝”.

Also, notice that the CMU, Rigid Insulation, Air Space and Brick add up to 16” in thickness. This portion of the wall would sit on a 16” concrete block (CMU) foundation wall directly below.

14. Your dialog should look like **Figure 3-2.8**. Click **OK** to close all dialog boxes.

**Figure 3-2.8** Edit Assembly for new wall type
The next step is to change the wall type for the walls previously drawn.

15. Select the Modify button on the Ribbon; this allows you to select elements in your drawing.

16. Zoom out so you can see the entire plan. Dragging your mouse from one corner to the other, make a window over the plan to select all the walls.

17. With the walls selected, pick Basic Wall: Brick & CMU cavity wall from the Type Selector drop down.

_TIP:_ If, after selecting all the walls, the Type Selector is not active and does not show any wall types, you probably have some other elements selected such as text or dimensions. Try to find those elements and delete them (except the elevation tags). You can also click on the Filter button (located on the Ribbon when objects are selected) and uncheck the types of elements to exclude from the current selection.

You should notice the wall thickness change, but the wall cavity lines and hatch are not showing yet. This is controlled by the Detail Level option for each view.

18. Click on Detail Level icon in the lower-left corner of the Drawing Window, on the View Control Bar.

19. Select Medium.

You should now see the brick and CMU thicknesses with hatching. If you did not pay attention when drawing the walls originally, some of your walls may show the brick to the inside of the building.

20. Select Modify (or press Esc); select a wall. You will see a symbol appear that allows you to flip the wall orientation by clicking on that symbol (Figure 3-2.9).
21. Whether you need to adjust walls or not, click on the flip symbol to experiment with its operation.

**TIP:** The Flip symbol is always on the exterior side (or what Revit thinks is the exterior side) of the wall.

22. If some walls do need to be adjusted so the brick is to the exterior, do it now. You will probably have to select the wall(s) and use the Move tool to reposition the walls to match the required dimensions.

**TIP:** If you set the “location line,” via the Properties Palette, to “Wall Centerline,” the wall will not move and mess up the overall dimensions when flipping it. You will want to set the “location line” back to Finish Face: Exterior when done.

23. Save your Project as ex3-2.rvt.

---

<table>
<thead>
<tr>
<th>TIP: You can use the MOVE tool on the Ribbon (when a wall is selected) to accurately move walls.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Follow these steps to move an object:</td>
</tr>
<tr>
<td>• Select the wall</td>
</tr>
<tr>
<td>• Click the Move tool</td>
</tr>
<tr>
<td>• Pick any point on the wall</td>
</tr>
<tr>
<td>• Start your cursor in the desired direction (don’t click)</td>
</tr>
<tr>
<td>• Start typing the distance you want to move the wall and press Enter.</td>
</tr>
</tbody>
</table>

---

Finally, you will change the three walls at the atrium to be curtain walls (full glass). This will let lots of light into the atrium and better identify the main entry of the building.

24. Drag a selection window (from left to right) to select the three walls around the atrium, or hold the Ctrl key on the keyboard and select them.

25. With the walls selected, select *Curtain Wall: Curtain Wall 1* from the *Type Selector* drop-down.

Your atrium is now surrounded by curtain walls (Figure 3-2.10). In a later lesson we will add horizontal and vertical mullions to the curtain wall.

You can see your progress nicely with a 3D view. Click the 3D View button on the QAT. Notice that Revit shows the curtain wall as transparent because it knows the curtain wall is glass. The other walls are shaded on the exterior side due to the brick pattern that is applied.

26. Save your project as *ex3-2.rvt*. 

---

3-9
Revit automatically sets the hatch intensity and line weights.

**FIGURE 3-2.10** Completed exercise

**FIGURE 3-2.11** Completed exercise
Exercise 3-3: Interior Walls

In this lesson you will draw the interior walls for the first floor.

Adjust Wall Settings

1. Select Architecture → Build → Wall from the Ribbon.

2. Make the following changes to the wall options on the Ribbon, Options Bar and Type Selector (Figure 3-2.1):
   - Wall style: Basic Wall: Interior – 4 7/8" partition (1-hr)
   - Height: Level 2
   - Location Line: Wall Centerline

Draw the Interior Walls

3. Draw a “vertical” wall approximately as shown in Figure 3-3.1. You will adjust its exact position in step #4.

4. Select Modify → Modify → Align tool to align it with the edge of the exterior wall in the atrium (Figure 3-3.1). When you are done, the wall should look like Figure 3-3.2.
5. Create the same wall for the West side of the atrium repeating the above steps.

Modify an Existing Wall Type

Next you will add some additional interior walls. You will be drawing 8” CMU walls. Revit does have an 8” Masonry wall type available in the default template file that you started your project from. However, the thickness for this wall type is 7⅜”, which is the actual size of a block. Floor plans are usually drawn nominally (i.e., 8”) not actual (7⅜”). This is done so you can figure out coursing so minimal cutting is required. Therefore, rather than creating a new wall type you can simply modify the existing wall type.

Note: some may disagree with this approach. However, these changes should still be made to this project so you learn more about how walls work and so all the tasks in this book work as expected or intended.

6. Select the wall type **Basic Wall: Generic – 8” Masonry**.

7. Select the **Edit Type** button on the **Properties Palette** to view the wall’s **Type Parameters**, and then click **Edit** next to the **Structure** parameter.

8. Change the masonry thickness from 7⅜” to 8” in the **Edit Assembly** dialog box, and then select **OK** to close each dialog (do not close the **Properties Palette**).

Occasionally Revit will not list dimensions, relative to the walls you want to draw new walls from, while in the create wall mode. One way to deal with this is to draw temporary **Detail Lines** to use as a reference. After using the temporary line as a reference you can delete it.

9. Select **Annotate → Detail → Detail Line** from the **Ribbon**; the line type does not really matter, but select a continuous one via the **Type Selector**.

10. Draw the “vertical” line shown in Figure 3-3.3; be sure to snap to the **Midpoint** of the atrium wall as your first point.

Next you will draw an elevator shaft, centered on the atrium and 35'-0” back (thus the temp. line).

The **inside** dimensions of the elevator are **7'-4” x 6'-10”**. Because you know the inside dimension you will want to adjust the location line to match the known info.

11. Use the **Wall** tool to draw **Basic Wall: Generic – 8” Masonry**.

---

**Figure 3-3.2**
First interior wall
12. Set the Location Line to **Finish Face: Interior**.

13. Draw the elevator shaft. Make sure the location line is to the **inside** so your shaft is the correct dimension. Draw the shaft anywhere in the Drawing Window; you will adjust the exact position next.

**FYI:** The inside dimensions are listed above.

14. Select the 4 walls that represent the elevator shaft, and then pick the **Move** tool.

**TIP:** Concrete blocks come in various widths, and most are 16" long and 8" high. When drawing plans there is a simple rule to keep in mind to make sure you are designing walls to coursing. This applies to wall lengths and openings within CMU walls.

*Dimension rules for CMU coursing in floor plans:*

- **e′0″ or e′8″** where e is any even number (e.g., 6′0″ or 24′8″)
- **o′4″** where o is any odd number (e.g., 5′4″)

15. Snap to the **Midpoint** of the shaft as your first point, and then snap to the **Middle Endpoint** of your temporary detail line (Figure 3-3.4). You should zoom in to verify your snaps. Do not draw the dimensions; they are for reference only.
The elevator shaft is now perfectly centered in the atrium and exactly 35'-0" back from the South curtain wall.

16. At this point you can delete the temporary line. Select the line and then right-click and select delete or press the Delete key on the keyboard.

**FYI:** When a wall is selected, you can see that wall’s properties via the Properties Palette (Type “PP” to open the Palette if it is not visible). Click one of the elevator shaft walls and verify that it is 36'-0" tall.

---

**Modify an Existing Wall**

Next we want to change the portion of wall between the building and the East and West stair shafts. To do this you will need to split the current wall, trim the corners and then draw an 8" masonry wall.

17. **Zoom** in on the West stair shaft and select the **Split Element** tool (Modify tab on the Ribbon).

18. Pick somewhere in the middle of the wall (Figure 3-3.5).

19. Select **Modify → Modify → Trim** to trim the corners so the exterior wall only occurs at exterior conditions (Figure 3-3.6).

**Tip:** Select the portion of wall you wish to retain.
Additional Custom Wall Types

We decide that the stair shafts are mostly utilitarian and do not require gypsum board on the walls. In the next steps you will create a new exterior wall type just like the one previously created less the gypsum board and metal studs. Also, you will create a custom wall type to close the open side we created in the previous steps. This wall type will have gypsum board and metal studs on one side.

20. Using wall type Basic Wall: Brick & CMU cavity wall as a starting point, create a new wall type named Brick & CMU cavity wall (no GWB). Remove the gypsum board and metal studs and save the new wall type. (Remember to click Duplicate.)

21. Change the three exterior walls around the west stair shaft to the new wall type created in the previous step.
22. Using wall type Basic Wall: Brick & CMU cavity wall as a starting point, create a new wall type named 8” Masonry with GWB 1S. Remove the brick, air space, rigid insulation and membrane layer and save the new wall type (Figure 3-3.7).

*FYI:* It will be useful to come up with a standard naming system for your custom wall types. If the names get too long they are hard to read. The example above has:
- GWB = Gypsum Wall Board (and would imply studs)
- 1S = finish only occurs on one side of the wall.

<table>
<thead>
<tr>
<th>Function</th>
<th>Material</th>
<th>Thickness</th>
</tr>
</thead>
<tbody>
<tr>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>Core Boundary</td>
<td>Layers above wrap</td>
<td>0”</td>
</tr>
<tr>
<td>Structure [1]</td>
<td>Concrete Masonry Units</td>
<td>8”</td>
</tr>
<tr>
<td>Core Boundary</td>
<td>Layers below wrap</td>
<td>0”</td>
</tr>
</tbody>
</table>

*Figure 3-3.7 New wall layers*

23. Draw a wall so the gypsum finish continues on the office side, using the *Align* tool if necessary (Figure 3-3.8).

*Use the Measure tool to make sure the stair shaft is the correct size; don’t draw the dimensions.*

Next you will use the *Mirror* tool to update the east stair, but first you will draw a *Reference Plane* to use as the *Axis of Reflection* (more on this later while using the Mirror tool).

24. Select *Architecture → Work Plane → Ref Plane* from the *Ribbon*.

25. Draw a Reference Plane snapped to the vertical, centered on the South atrium wall (See Figure 3-3.9).

26. Erase the four walls of the East stair shaft; this will include the main east wall of the office building (Figure 3-3.9).

27. Select the six walls at the West stair (Figure 3-3.9).

*TIP:* Make sure the count is correct on the Status Bar.
28. Select the **Mirror - Draw Axis** tool (on the *Ribbon*) and then select the Reference Plane (Figure 3-3.9).

![Figure 3-3.9 Mirror west stair](image)

29. Use the **Measure** tool to verify the overall length of the building is 140'-0". Adjust as necessary (see Fig. 3-2.2).

![Figure 3-3.10 Mirrored west stair](image)

Finally, you will draw a few more interior walls to complete the first floor plan. **Do not delete the Reference Plane** (note: the reference line may not show up in every image in this text).
30. Using the *Wall* tool, set the wall type to *Basic Wall: Interior – 4 7/8″ partition* (1-hr).

31. Draw the additional walls shown in Figure 3-3.11. Make sure to position the walls per the dimensions shown. Use the *Measure* tool to verify accuracy. Also, modify the *Location Line* as required.

**DRAWING TIPS:** Copy the existing atrium wall 6' 47/8″ over (6' 0″ plus one wall thickness), draw a wall from the midpoint of the elevator shaft with centerline reference (Location Line), and use the Trim and Mirror tools. Do not draw the dimensions. **SAVE YOUR PROJECT as ex3-3.rvt.**

**FIGURE 3-3.11** Remaining interior walls
Exercise 3-4: Elevator

This lesson will show you how to insert an elevator into your elevator shaft.

Insert Elevator

Revit provides many Families, which are predefined elements ready to insert into your project. However, many elements are not readily available, like elevators for example. You will get an elevator family online in this exercise. The online library is where you will acquire an elevator family for use in your project.

1. Open project ex3-3.rvt and Save As ex3-4.rvt.

You will have to download the elevator from the web. Of course you will need to be connected to the Internet.

2. Click on the Insert tab on the Ribbon.

3. Select Load from Library → Load Family from the Ribbon.

4. Load Elevator-Electric.rfa from the downloaded ‘Required Families’ folder; see the inside front cover for information about downloading the provided electronic content for this textbook.

5. In the Project Browser, click the plus next to Families to expand the list (Figure 3-4.1).

6. Expand the Specialty Equipment list, and then Elevator-Electric.

As you can see, four elevator types were loaded into your project. Similar to wall types, you can add one of these types as-is, or you can modify or create a new type. Next, you will add information in the Type Properties dialog to better document the elevator specified.

7. Right-click on the elevator type 2000 lbs, and then select Type Properties from the pop-up menu.

You will now see a listing of the type properties for the selected elevator type.

8. Click the Preview button (if necessary) to see the

FIGURE 3-4.1 Elevator family: Project Browser
graphical review of the elevator type. Set the View to 3D View: View 1.

9. Add the following information (Figure 3-4.2):
   - **Model:** MadeUp 8864
   - **Manufacturer:** ThyssenKrupp Elevator
   - **URL:** www.thyssenelevator.com

   This data just entered represents the I in BIM (Building Information Modeling).

10. Click OK to close the open dialog box.
11. Drag the **2000 lbs** elevator type from the *Project Browser* into the first floor plan. 

*FYI:* You can also use the Component tool from the Architecture tab to place the elevator.

The elevator type will be attached to your cursor, ready for insertion.

12. Move your cursor within the elevator shaft and adjust it until the elevator “snaps” in place, then click (Figure 3-4.10).

13. Press **Esc** twice to tell Revit you are finished placing elevators.

Now you have to add an elevator door in the shaft walls at each level; this is similar to a regular door in a wall.

14. Similar to the steps previously covered, load the **Elevator Door – Center** family from the provided online content.

15. Drag the **36” x 84”** elevator door type from the project browser into the first floor plan (Figure 3-4.3).

16. Place the elevator door at the center of the wall, aligned with the elevator door on the cab (Figure 3-4.4).

*TIP:* If the door is inserted on the wrong side of the wall, select the door and click the Control Arrows to flip it within the wall.
Notice when the elevator is selected, the flip icon (control arrow) is displayed. Similar to the doors and walls, you can click this icon to flip the orientation of the elevator within the shaft.

17. Save your project as ex3-4.rvt.
Exercise 3-5: 
Doors and Windows

This lesson will take a closer look at inserting doors and windows.

Insert Doors

Revit has done an excellent job providing several different door families. This makes sense seeing as doors are an important part of an architectural project. Some of the provided families include bi-fold, double, pocket, sectional (garage), and vertical rolling, to name a few. In addition to the families found on your local hard drive, many more are available via other internet sites (some free, some not).

The default template you started with only provides the Sgl Flush (Single Flush) group in the Doors category. If you want to insert other styles you will need to load them from the library. The reason for this step is that, when you load a family, Revit actually copies the data into your project file. If every possible family was loaded into your project at the beginning, not only would it be hard to find what you want in a large list of doors, but also the files would be several megabytes in size before you even drew the first wall.

You will begin this section by loading a few additional families into your project.

1. Open project ex3-4.rvt and Save-As ex3-5.rvt.

2. From the Insert tab, select the Load Family button on the Ribbon (Figure 3-5.1).

3. Browse through the US Imperial library folder for a moment.

![Figure 3-5.1 Load Family](image-url)
Each file represents a *Family*; next you will load four door *Families* into your project.

4. Open the **Doors** folder and then select **Curtain Wall Dbl Glass.rfa**, and then click **Open** (Figure 3-5.2).

5. Repeat steps 2 – 4 to load the following provided (online) door families:
   a. **Double-Glass 1**
   b. **Sidelights 1**
   c. **Single-Glass 1**

6. In the **Project Browser**, expand **Families** and **Doors** to see the loaded door families (Figure 3-5.3).

If you expand a door family itself in the **Project Browser** you see the predefined door sizes associated with that family. Right-clicking on a door size allows you to rename, delete or duplicate it. To add a door size you duplicate and then modify properties for the new item.

Next you will insert the doors into the stair shafts.
7. Select the Door tool from the Architecture tab and then pick Sgl Flush: 36" x 84" from the Type Selector on the Properties Palette.

8. Insert two doors in the West stair shaft as shown in Figure 3-5.4. Remember you are inserting a door into a masonry wall so your door position and size need to work with coursing. Thus the 8" dimension (however, you would also need to include the door frame into the equation).

9. Repeat the previous step to insert doors into the East stair shaft.

10. Finish inserting doors for the first floor (Figure 3-5.5). Use the following guidelines:
   a. All doors should be 36" wide and 7'-0" tall.
   b. You will not insert doors into the curtain wall for now. You will do that in a later lesson when you design the curtain wall.
   c. Use the style and approximate location shown in Figure 3-5.5.
   d. Doors across from each other in the two atrium walls should align with each other.
   
   **TIP:** While inserting the second set of doors, watch/wait for the reference line to show up, indicating alignment.

   e. Place doors approximately as shown, exact location not given.

---

**Figure 3-5.4** Doors in West stair shaft
Door Type Properties:
If you select *Edit Type* while the Door tool is active (selected), you can modify various properties related to the door.

You can easily add another standard door size to the *Family* as required. Click “Duplicate,” and type a name (Figure 3-5.6).

Standard doors sizes (and *Families*) can be added to your template file, so you don’t have to load them for every new project.
Insert Windows

Adding windows to your project is very similar to adding doors. Like the doors, the template file you started from has one family preloaded into your project, the FIXED family. Looking at the Type Selector drop-down you will see the various sizes available for insertion. At this point you should also see the SIDELIGHT family that you loaded in the previous exercise. First, you will add a few interior borrowed lights using the sidelight family.

Interior Windows (Borrowed Lights)

11. With the Window tool selected, pick Sidelights 1: 18" x 84" from the Type Selector.

12. On the West side of the atrium, insert the borrowed lights as shown in Figure 3-5.7; do not add the dimensions.

Make sure the borrowed light frames are flush with the atrium side of the wall. You can control that option by moving your cursor to the side of the wall you want the frame flush with before clicking to insert. After drawing the window, you can select the frame and use the flip icon (similar to doors and walls).

13. Repeat the previous steps to insert the borrowed lights on the East side of the atrium.

Figure 3-5.7 Sidelights added
Exterior Windows

14. Using the methods previously covered in this book, create a new window size in the FIXED family. Create Fixed: 32" x 48". You are creating this new size to fit coursing in the plan view. The largest window (preloaded) that fits coursing in the plan view is 24".

15. Adjust the sill height for your new window size to fit within coursing as well. Set the sill height for Fixed: 32" x 48" to be 3'-4" (Figure 3-5.8).

![Type Properties](image)

**Figure 3-5.8** New window size with modified window sill height

16. Insert the window as shown in Figure 3-5.9. The window should be inserted with masonry coursing in mind.

**Note:** The dimensions displayed while inserting the window will not work as displayed for coursing because Revit is measuring from the center of the adjacent exterior wall. Thus, you will have to insert the window as close as possible and adjust its location, verifying with the Measure tool.
Array Window

The _Array_ tool allows you to quickly copy several objects that have the same distance between them. You will use _Array_ to copy the windows:

17. Click the _Modify_ tool and then select your window.

18. With the window selected, pick the _Array_ tool from the _Modify_ tab.

19. In the _Options Bar_, type 6 for the _Number_ field.

20. Click the left mouse button at the midpoint of the window and move your mouse to the East until the dimension displayed is 8'-6".

21. You should now see the windows arrayed in the wall. 8'-6" is not coursing, so select the _Activate Dimensions_ button on the _Options Bar_ and then enter 8'-8" in the displayed dimension to adjust the window openings. This allows you to more accurately adjust the dimensions.

**FIGURE 3-5.9** Exterior window

**FIGURE 3-5.10** Window to be arrayed

**FIGURE 3-5.11** Window after array
22. Set the windows up on the three remaining walls of the first floor (Figure 3-5.12). Consider the following:
   
   a. This would be a good use for the Mirror tool.
   
   b. If you need to create a temporary wall for a mirror reflection axis, make sure the temporary wall is set to centerline.
   
   c. You can use the Reference Plane to mirror the windows in the East West direction.
   
   d. Use the Measure tool to verify accuracy.
   
   e. Use the Ctrl key to select multiple windows.

![Completed window layout](image)

**FIGURE 3-5.12 Completed window layout**

---

**Cleaning House:**

As previously mentioned, you can view the various Families and types loaded into your project. The more Families and Types you have loaded the larger your project file is, whether or not you are using them in your project. Therefore, it is a good idea to get rid of any door, window, etc., that you know you will not need in the current project.

23. In the *Project Browser*, navigate to Families ➔ Windows ➔ Fixed. Right click on 36" x 48" and select **Delete**.

![Project Browser](image)

**FIGURE 3-5.13 Project Browser**
Self-Exam:
The following questions can be used as a way to check your knowledge of this lesson. The answers can be found at the bottom of this page.

1. The *Options Bar* allows you to set the height of a wall when first drawing it. (T/F)

2. It is not possible to draw a wall with the interior or exterior face of the core as the reference point. (T/F)

3. Elements cannot be moved accurately with the *Move* tool. (T/F)

4. The _________ tool, in the *Ribbon*, has to be selected in order to select an element in your project.

5. A wall has to be _____________ to see its flip icons.

Review Questions:
The following questions may be assigned by your instructor as a way to assess your knowledge of this section. Your instructor has the answers to the review questions.

1. Revit comes with many predefined doors and windows. (T/F)

2. The length 3′-8″ is a masonry dimension. (T/F)

3. You can delete unused families and types in the *Project Browser*. (T/F)

4. It is not possible to load families and types from the internet. (T/F)

5. It is not possible to select which side of the wall a window should be on while you are inserting it. (T/F)

6. What tool will break a wall into two smaller pieces? ________________

7. The ____________ tool allows you to match the surface of two adjacent walls.

8. Occasionally you use the Split Element command to turn one wall into two walls. (T/F)

9. You can use the ______________ tool to copy an element multiple times in one step.

10. The template file has a few doors, windows and walls preloaded in it. (T/F)

Self-Exam Answers:
1 = T, 2 = F, 3 = F, 4 = Modify, 5 = Selected
Notes: