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Module 1: 

The Basics of Revit Structure 

This module contains: 

 Section 1: Introduction to Revit Structure 
What is Revit Structure? 
Revit Structure Projects 
The Revit Structure 2010 Interface 

 Section 2: Setting up Levels and Working with Views 
Creating and Using Levels 
Creating Elevations 
Creating Sections 
Creating Callouts 
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Section 1: 
Introduction to Revit Structure 

In this section you will learn: 

 About Revit Structure and what it can do 

 An overview of the interface 

 How to start Revit projects 

 About general drawing and editing tools 
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What Is Revit Structure? 

Revit Structure is a modeling program. This means that everything placed 
into a model simulates a true building material. It is important to note that 
there is a distinct difference between the term modeling and the term 3D. 
While Revit Structure has many advanced 3D capabilities, it is foremost a 
modeling program. Most of your modeling occurs in a 2D environment, 
with 3D views easily accessible at any time. 

BIM and Structural Engineering 
BIM stands for Building Information Modeling. BIM is the process of 
creating a single, database-driven model by placing actual building 
components and materials. 

Therefore, for the structural engineer and designer the BIM model does 
not stop at the actual building. Since the components used in the model 
represent real-life members, you can design for stresses as you draft and 
vice-versa. Additionally, in a Revit/BIM environment when beams are 
attached to columns, and columns to grids, the application understands 
that these elements belong together. In plan, if a gridline moves, so do the 
columns and subsequently the beams. In elevation, if a level moves, the 
columns increase in length and any framing on that floor moves with it. 
Revit also automatically updates the column schedule to reflect the 
change. 

Drawings are now based on a model that is as close to an actual building 
as possible. A design change can influence the building in another area. 
This is known as parametric design. The move to this kind of modeling is 
becoming the industry standard. As BIM applications become smarter, so 
does the industry. 
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Revit Structure Projects 

A project is a complete description of a building and the information 
associated with it for displaying 2D and 3D views, as well as schedules. 
When you open a Revit Structure project file, it opens the entire project or 
building model. You can then work in different views, such as plan, 
section, elevation, and 3D model, all within the same project file. 

 All of the views are associative. Changes to the model in one view 
are automatically updated in all other views. For example, if you 
add an opening to a wall in a plan view, it also appears in the 
related elevation view and any related schedules (such as a lintel 
schedule). 

 You can place the views on sheets in a Revit Structure project to 
create construction drawings. Callouts of details and elevations can 
be automated with tags and titles on the sheets. 

File Types 
The following explains each Revit file type: 

.RVT The file format of a Revit model. There are three separate Revit 
applications: Revit Structure, Revit Architecture, and Revit MEP. Each 
of these applications saves a standard project file as the RVT format. 
Each file can be opened directly in any of the three applications. RVT 
files can also be inserted and linked into one another. This is crucial for 
coordination between disciplines. If groups of objects are created and 
saved out separately, they are also in the RVT format. 

.RFA The file format of a Revit Family. These files can be opened directly, 
inserted, or loaded into an RVT file. 

.RTE The Revit project template file. When a new model is started, an RTE 
file is used to create the model. When you save the file, it is saved as a 
new RVT model. This file contains all of your company’s standards and 
settings. Views, sheets, and families should be set up and ready to use in 
the project template. 

.RFT The Revit family template file. When a new family is started, an RFT 
file is used to create the family. You can use a default or custom 
template. When saved, the file becomes a new RFA family. You can 
customize the family template to include commonly used reference 
planes, parameters, etc. 
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Types of Elements 
There are five main types of elements in a Revit Structure project, as 
explained below: 

Host Host elements are the built-in-place construction objects, such as 
floors, walls, roofs, ceilings, stairs, and ramps. They can stand 
alone in the project. 

Component Component elements are objects that need to be attached to host 
elements, such as openings, reinforcing, and footings, as well as 
stand-alone elements, such as columns, beams and equipment. 

View Views enable you to see and manipulate the project. For 
example, you can view and work in floor plans, ceiling plans, 
elevations, sections, schedules, and 3D views. You can change a 
design from any view. All views are stored in the project. 

Datum Datum elements define the project context. These include levels 
for the floors, column grids, and reference planes that help you 
draw. 

Annotation Annotation elements are 2D objects that you place on views to 
define the information drawn in the project. These include 
dimensions, text, tags, and symbols. The view scale controls 
their size. 

     

MODEL  
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Families 
You create a Revit model by adding pre-defined elements (e.g., columns, 
beams, joists, trusses, footings, pile caps, doors, windows, openings, brace 
plates, detail components, and annotation). These elements are called 
Component Families and they are a single file (RFA file extension) that 
can contain hundreds of choices when being added to the model. For 
example, one type of column family file is called W-Wide Flange-
Column.rfa, as shown below. This file is broken down into multiple sizes 
for wide flange columns. When creating a Revit model family, members 
are selected and loaded as needed to create the model. 

 

 Revit Structure includes many out-of-the-box component families 
in its Library. You can also create your own family types or 
download them from various websites. 

Elements such as walls, floors, and roofs are called system families. This 
type of family is not loaded as a separate entity but is inherent to the 
project. To create a new system family, an existing element is copied and 
re-defined to fit the project’s specific needs. System families can also be 
copied to the Windows clipboard and pasted into another project. 
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The Revit Structure 2010 Interface 

Revit Structure models are entirely driven by placing components; 
therefore, the interface is different from the AutoCAD interface. There is 
no command prompt, no layers, and fewer icons. Revit Structure is an 
application designed solely for structural design.  

The Revit Structure interface is designed for intuitive and efficient access 
to commands and views. It includes the Ribbon, Quick Access Toolbar, 
Application Menu, and Status Bar, which are common to newer versions 
of all Autodesk software. It also includes tools that are specific to Revit 
Structure, including the Project Browser and View Control Bar. The 
interface is shown below. 

 
1. Quick Access Toolbar 
The Quick Access Toolbar provides access to commonly used commands, 
such as Open, Save, Undo and Redo, Modify, and 3D View, as shown 
below. You can also customize this toolbar by adding commands from any 
of the Ribbon tabs. 
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2. InfoCenter 
The InfoCenter enables you to quickly search for help on the web, as 
shown below. You can specify which Help documents to search, and 
collapse or expand the Search field to save screen space. 

 
 

3. Application Menu 
The Application Menu provides access to file commands, settings, and 
documents, as shown below. 

 Hover your cursor over a command to see a list of additional tools. 

 
 If you click the primary icon rather than the arrow, it starts the default 

command. 
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Recent and Open Drawings 

To see a list of recently used documents, click  (Recent Documents) in 
the Application menu. The documents can be reordered, as shown in the 
image below. 

 

 Click  (Pin) next to a document name to keep it available and to 
prevent it from dropping off the bottom of the list as more recent 
documents appear on the list. When a file has been pinned, it will 
display with the push pin tacked in ( ). 

To see a list of open documents and views, click  (Open Documents). 
The list displays the open documents and each view that is open, as shown 
in the image below. 
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4. Ribbon 
The Ribbon contains Revit Structure tools in a series of tabs and panels, as 
shown in the image below. Selecting a tab displays a group of related 
panels. The panels contain a variety of tools, grouped by function. 

 

Contextual Tabs 
 When you select a command that creates new elements, the Ribbon 

switches to a contextual tab. The tab includes Element Properties, the 
 pull-down menu, and general commands for 

creating the element, as shown in the image below. 

 

 When you select an existing element in Revit Structure, the Ribbon 
switches to a contextual tab that includes general editing commands as 
well as commands directly related to the element type, as shown 
below. 

 

5. Options Bar 
The Options Bar changes according to the selected command or element. 
For example, when the Beam command is active, it displays options for 
placing the beam, as shown below. 

 

 You are always in a command in Revit Structure. To end a command, 

use one of the following methods: start another command, click  
(Modify) in the Quick Access Toolbar or contextual tab, press <Esc> 
twice to revert to the Modify command, or right-click and select 
Cancel. 
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6. Tooltips 
Tooltips display the element’s name, a short description, and sometimes a 
graphic, as shown below. They provide information about tools, 
commands, and how to create specific elements. 

 Many commands have shortcut keys. For example, type BM for Beam 
or CL for Structural Column. They are listed next to the name of the 
command in the tooltips. 

 NOTE: You do not need to press <Enter> to execute two-letter 
shortcuts. 

 

Hint: Menu Shortcuts 

Revit has a file called Keyboardshortcuts.txt, located in C:\Program 
Files\Revit Structure 2009\Program\. This file is similar to the 
Acad.pgp file in that you can create shortcuts to your favorite 
commands or modify pre-existing ones. 

For example, if you wanted a shortcut to the Copy to clipboard 
command, open the Keyboardshortcuts.txt file and scroll down to the 
following line: 

; ""  menu:"Edit-Copy to Clipboard" 

Replace the ; "" with “CL” so the string appears as follows: 

"CL"  menu:"Edit-Copy to Clipboard" 
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7. Project Browser 
The Project Browser lists the views of each project that can be opened in 
Revit Structure as shown in the image below. This includes all views of 
the model that you are working in and any additional views you create 
(such as floor plans, 3D views, elevations, sections, etc.). It also includes 
views of schedules, legends, sheets (for plotting), families (such as beams 
and walls), and groups and links. 

 

 Double-click on an element in the list to open the associated view. 

 To see the views associated with a view type, click 
 (Expand) next to the category name. To hide the views in the 

category, click  (Contract). 

 If you no longer need a view, you can remove it. Right-click on its 
name in the Project Browser and select Delete. 

 The Project Browser can be floated, resized, and customized. 

 Right-click or press <F2> to rename a view in the Project Browser. 
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8. View Windows 
Each view of a project opens in its own window, as shown below. The 
views display a Navigation Bar for quick access to viewing tools and a 
View Control Bar that controls aspects of that view (such as the scale, 
detail level, and shading). 

You can use the Project Browser, or press <Ctrl> + <Tab> to switch 
between windows. Additional window tools (such as Cascade and Tile) 
are found in the View tab>Windows panel in the Ribbon, as shown below. 

 

Window Panel 
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Each model that is open can have multiple view windows open, which can 
affect the speed at which Revit performs. It is recommended that only the 
necessary windows remain open. To control this and reduce memory 

usage, click  (Close Hidden) in the View tab>Windows panel. To 
switch between windows within the project, click Switch Windows, as 
shown below. If multiple projects are open, these will also be displayed. 

 

The remaining options in the Window panel enable you to configure the 
window display (Cascade, Tile, and Replicate), control the toolbars that 
are displayed, and navigate between active windows (remember you can 
also use <Ctrl> + <Tab>). 

View Control Bar 

 

The View Control Bar is at the bottom of the view window. This toolbar is 
mainly responsible for the display of the model for a particular view. 
These settings are permanent, and will affect the plotted results of your 
model when the individual view is placed on a sheet. Select these settings 
with careful consideration. 

Scale: Sets the scale of the view for plotting purposes, and controls the 
size of annotations and symbols at the specified scale. Click this button to 
select from a list. If you change the scale, you need to inspect the view. 
You might need to rearrange some elements based on the new scale value. 
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Detail Level: Determines the level in which the graphics of an element are 
displayed. There are three detail levels: Coarse, Medium, and Fine. 
Viewing a model at a Fine detail level shows the most amount of detail, 
but affects the speed at which you can pan and zoom the model. Coarse, 
however, shows the least amount of detail within the elements of that 
view. For example, walls are shown without any interior details, and 
columns and beams are shown single-line. 

   

Model Graphics Style: Determines the display style of the model. There 
are four model graphics styles to select from: Wireframe, Hidden Line, 
Shading, and Shading with Edges. 

 

 Wireframe: All edges and lines are shown, and all surfaces are 
transparent. Use this for plan views unless you want objects below 
to appear with hidden lines. This display is not often used in 3D 
views as the wireframe display can make it hard to understand the 
model. 



Revit Structure 2010 Fundamentals 

1 - 16                                                                                                                             © 2009 - Do not duplicate. 

 Hidden: Typically the first choice for plans and elevations. Most 
views are set to Hidden line by default. Any obscured objects show 
as hidden line, while objects that are not obscured show as 
continuous lines. This can sometimes be controlled with the view 
range. Different displays in a typical foundation plan view are 
shown below.  

  
Wireframe     Hidden 

 Shading: Shown for 3D illustrations. It shades the model but does 
not show the lines defining the objects being shaded. It can also be 
shown in elevation and plan, but becomes cumbersome when it 
comes time to plot the model. Shading with this graphical style is 
not recommended. 

  

        Shading    Shading with Edges 

 Shading with Edges: The natural choice for 3D. It shades the 
model and leaves the outlined edges. This mode is not 
recommended for plan or elevation, especially when plotting. 
Typically, views placed on sheets use a simple hidden line 
graphics style. 
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 Shadows: Used for presentations. Showing a shadowed model 
slows the system dramatically. 

 

 Do Not Crop and Hide Crop Region  are designed to 
behave similarly to viewports in AutoCAD. Cropping a view 
involves showing the crop region and moving the boundary to the 
desired location. Column grid lines and bubbles will display 
regardless of the crop boundary. 
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 Temporary Hide/Isolate  (the sunglasses icon) is used in 
cases where, in order to work on the model more efficiently, you 
need to temporarily hide or isolate specific elements in a view. 
First, select the elements you want to hide or isolate. Then, click 

 and select one of the four hide/isolate choices, as shown 
below. This function only hides elements in a view; it does not 
remove them from the actual model nor does it hide them 
permanently.  

 

When an object is temporarily hidden from view, the  turns 
cyan and a cyan box surrounds the perimeter of the view, 
indicating that some elements are temporarily turned off. Elements 
that have been temporarily hidden in a view will still print. 

To reset the view, click  and select Reset Temporary 
Hide/Isolate. You can also change the temporarily hidden objects 
to be permanently hidden by selecting Apply Hide/Isolate to 
View. 

 The other method for permanently hiding objects is to select them 

and then click  (Hide) in the View Graphics panel on the 
contextual tab. Elements that are permanently hidden will not 
print. 
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 Reveal Hidden Elements  is used to reveal hidden elements. 
The icon turns magenta and a magenta box surrounds the perimeter 
of the view. Normally visible elements are grayed out, and the  
permanently hidden elements appear in magenta. If you want to 
show these objects again, you can select them in this mode and 

click  (Unhide Elements) on the contextual tab>Reveal 
Hidden Elements panel. 

View Properties 
Each view has independent properties, enabling different graphical 
representations based on that view’s function. Views can also be 
duplicated, enabling different sets of information to be displayed on a 
sheet. For example, a foundation plan can be copied to show slab 
reinforcing next to a dimensional plan on a sheet. 

There are two ways to access the properties of a view: 

 One way to access view properties is to right-click anywhere in the 
view window and select View Properties…, as shown below. 
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The properties of the view are displayed. (Some of these view properties 
are also accessible through the View Control Bar.) 

 

 The second way to access view properties is to select a view (not 
just a floor plan) in the Project browser, right-click, and select 
Properties. This is the same as right-clicking in the view window. 

The right-click menu has three options available for duplicating views. 
After duplicating a view, you can modify it with annotations or visibility 
settings to differentiate that view from others (unless Duplicate as a 
Dependent is used). 

 

Duplicating Types: 

Duplicate: Creates a copy of the view with only the building elements. 
Building model objects change in all views automatically, but view-
specific changes made to the new view would not be reflected in the 
original view. 

Duplicate with Detailing: Creates a copy of the view and includes all 
annotation and 2D elements. Like a standard duplicate, any new 
annotation or view-specific changes made to the new view would not be 
reflected in the original view. 
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Duplicating as a Dependent: Creates a copy of the view and links it to 
the original view. This creates a dependent relationship, which is 
represented in the Project Browser. View-specific changes made to the 
original view would also be made in the dependent view and vice-versa. 
Use dependent views when the floor plan is so large that you need to 
split the building up onto separate sheets with a matchline. Create a 
standard duplicate before duplicating dependent views at different 
scales. You may also want to use dependent views when the same detail 
needs to appear on more than one sheet, or when back-referencing views 
on sheets. 

9. Status Bar 
The Status Bar provides information about the current process, such as the 
next step for a command, as shown below. 

 

Right-click Menus 
Right-click menus help you work smoothly and efficiently by placing the 
commands you need at your fingertips. These menus always provide 
access to basic viewing commands. The other options vary depending on 
the selected element or the command you are using. 
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   Practice - Introduction to Revit Structure 
In this practice you will open an RVT file from the class directory and 
explore the tools used to navigate a Revit Structure project. This practice 
is designed for you to explore the functionality of the Project Browser and 
the command interface. 

 

Task 1 - Navigate through Revit Structure 
1. Open the project file Syracuse Suites.rvt from the Module1 folder in 

the class directory. The project opens to the 1 FIRST FLOOR 
structural plan. 

2. If the Project Browser is not displayed, in the View tab>Windows 
panel, expand User Interface and select Project Browser. 
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3. In the Project Browser, double-click on the 00 GROUND FLOOR 
structural plan. It opens a plan showing footings and foundation walls. 

4. In the View Control toolbar, locate the Model Graphics Style icon and 
change the model graphics to Hidden Line, as shown below. 

 

  

5. In the Project Browser, double-click on the 00 T.O. FOOTING 
structural plan. Zoom in and notice that the foundation walls are in-
filled with the appropriate concrete hatch. The strip footings and 
spread footings also show as continuous lines because there is no slab 
to obscure them. 
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6. Type ZE. This zooms the extents of the view. (ZA zooms to the extent 
of all visible view windows). Find the section marker that extends 
vertically along the model. 

 

7. Double-click on the bubble. This opens the LATITUDINAL 
SECTION. 

8. In the Project Browser, navigate to the Sections (Building Section) 
category and notice that LATITUDINAL SECTION is bold. You can 
navigate through your Revit model by either double-clicking on the 
element in the Project Browser, or by using the graphical annotation 
elements in the model. 

9. Zoom in on the area where the callout has been placed. 

 

10. Double-click on the bubble. This opens the TYPICAL EDGE 
DETAIL. 
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11. Select the reinforcing. It is not just a 2D representation. 

12. Click  (Element Properties) in the contextual tab. Remember that 
when an element is selected, the Options Bar changes to aid you in the 
design of that specific element. 

 

13. Scroll down to the Instance Parameters of the area reinforcing. The 
choices made here will drive the model. When it comes time to label 
the sections and details, these values become annotations. If these 
values change, they only need to be changed in one place. The new 
values are then propagated to all the views. Any change made here is 
only applied to the element that is selected. In this case, only the first 
floor area reinforcement changes. 

 

14. Click  to access the Type Parameters. Any change 
made to these parameters changes all area reinforcing in the entire 
model. In this case, the area reinforcing is changed for all floors. 
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15. Click  twice to close both Properties dialog boxes. 

16. Press <Esc> or click in blank space to clear the selection. 

17. Select one of the bolted connections. This is a detail component. 

18. Look in the contextual tab. It has automatically updated with the 
modifying options specific to this element. 

19. Press <Esc> to clear the selection. 

20. Double-click on the first floor datum mark. This opens the 1 FIRST 
FLOOR structural plan. 

 

21. In the View tab>Windows panel, click Switch Window. There is a 
growing list of opened windows. This can quickly become a 
management issue once the model starts growing in size. You can 
click Close Hidden in the Windows panel so that only the current 
window remains open. 

 

22. Click  from the View tab in the Create panel or  from the 
Quick Access toolbar. Type WT to tile the windows. You now have 
two visible windows. This view configuration is useful when placing 
elements in a model. 

23. Click inside of the 3D view window. 
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24. Press and hold <Shift> and press the wheel button on your mouse. 
Move the mouse to dynamically view the 3D model. You can also 
navigate in 3D using the View Cube in the upper right corner of the 
view. 

25. Click  (Close) to exit the 3D view (this also works when many 
views are open). 

 

26. Click Application Menu   and then click  to exit 
the project. Do not save changes. 

Task 2 - Create a Project 

1. Click   (New) and then  (Save) on the Quick Access Toolbar. 

2. Browse to your class directory. 

3. Click  (New Folder). Label the new folder with your name and then 
access the folder. 

4. In the lower right corner, click . 



Revit Structure 2010 Fundamentals 

1 - 28                                                                                                                             © 2009 - Do not duplicate.  

5. In the File Save Options dialog box, set the Maximum number of 
backup(s) to 1, as shown below. 

 

6. Click . 

7. Name the file Class Model. 

8. Click . 
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Self Check: 
Introduction to Revit Structure 

1. What is the name of the series of tabs and panels in the Revit Structure 
interface? 

2. What is the name of the part of the interface that enables you to access 
the project and its views? 

3. What is the name of the toolbar that changes according to the current 
command? 

4. Can you change how Revit controls the display of a view? How? 

5. When a component is brought into a Revit model, what is this 
dynamic component called? 
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Section 2: 
Setting Up Levels and Working with 
Views 

In this section you will learn how to: 

 Create and use levels 

 Create elevations 

 Create a section view 

 Create callouts 
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Creating and Using Levels 

One of the greatest benefits to using Revit is the ability to control datum 
elevations in real-time by using levels. Having this functionality in a single 
model without the need for external referencing systems is also 
advantageous. From a simple tool shed to a skyscraper, Revit is designed 
to manage an entire project, not just parts of a building. By adding and 
managing all of the building’s levels in a single file, Revit increases 
efficiency in the typical workflow of a project. More time can be spent 
designing and less time spent managing files and folders. 

 

To Create a Level 
1. Create a new model in Revit Structure. 
2. Double-click on one of the Elevation Views under the Building 

Elevations category. Two elevations are present. This is typical of a 
default Revit template.  

3. In the Home tab>Datum panel, click  (Level). The Ribbon 
changes to the Place Level contextual tab and displays the options and 
tools you can use to create levels. 

4. In the Draw panel click  (Pick Lines). 
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5. Type 12 in the Offset field in the Options Bar. 

 

6. Move your cursor over the Level 2 elevation line. A blue dashed 
alignment line appears. If you move your cursor to either side of the 
existing elevation line, the alignment line moves with it. When you see 
the alignment line appear above Level 2, select it. Level 3 appears. 

 

7. Notice a new floor plan has been created for this level. In the 

contextual tab> Selection panel, click  (Modify) and select Level 
3. Notice the Ribbon has changed to the Modify Levels contextual tab.  

 

The following elements that appear enable you to do the following: 

 The Checkmark icon that appears on either side of the bubble is 
a toggle that controls whether the bubble and level information is 
shown at that end of the level line. 

  The 3D icon controls whether any movement or adjustment is 
reflec ted in other elevations. If you select this icon, it displays as 
2D, which means changes to that level would only affect the 
current view. 
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  The Padlock icon controls whether the level is locked in 
alignment with the other levels. If it is locked, you will see the blue 
dashed alignment line. If level object is stretched, all other levels 
will stretch with it. This helps maintain conventional drafting 
standards. If it is unlocked, the level will stretch independently of 
the other levels. 

  The Blue open circle icon at the base of both sides of the datum 
enables you to drag the level head to a new location. 

 The blue dimension that appears between the levels can be edited. 
This is called a temporary dimension. Remember that any blue 
element is editable or active. 

 

 The Dimension icon makes the temporary dimension 
permanent. If this occurs, you can still modify the increment by 
selecting the level. The permanent dimension temporarily turns 
blue enabling you to edit the value. 

 Additionally, the actual datum elevation can be selected and 
modified. Note that doing so affects the entire model. Be careful if 
you have to change the distance of an elevation. If it is late in the 
project, non-parametric drafting elements might exist. Changes 
might leave these elements in undesirable locations. Be sure to do 
a review of the project to ensure that all is as required. 
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  The Add Elbow icon enables you to add a jog to the level line. 
In tight spaces, this becomes crucial. Keep in mind that this is a 
view-specific change. 

8. Select the 12’-0” dimension and change it to 10’-0” (You can just type 
10). The level and anything associated with that level moves. 

9. Rename Level 3 as Roof. 
10. A message appears, asking if you want to rename the corresponding 

views. Click . 

 

The Level 3 view under Structural Plans located in the Project Browser 
has also been renamed as Roof. 

11. Select the Level 1 level line. 

12. In the Modify Levels contextual tab click  (Copy) and select a 
point anywhere along the Level 1 line. Move your cursor straight 
down. 

13. Select the Constrain and Copy options in the Options Bar. Clear the 
Multiple option. 

 

14. Type 10’-0” at the cursor. 
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15. Once the level is copied, rename it as T.O. Footing. 
16. No additional floor plan has been added to the Project Browser. This is 

because you only copied a level. You did not create it using the 
conventional Level command. Therefore, you need to create a floor 
plan based on the new level. 

17. In the View tab>Create panel, expand Plan Views and select 
Structural Plan. 
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18. Select the T.O. Footing level in the New Plan dialog box. 

 

19. Click . A new floor plan now appears in the Project 
Browser. 

20. Close the project without saving. 
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Creating Elevations 

Two kinds of elevations can be created in Revit: Building elevations and 
Framing elevations. They are similar but serve different purposes. A 
building elevation can be placed freely, whereas a framing elevation 
requires you to select a specific framing bay. 

To Create Building Elevations 
1. Open the file Bracing.rvt from the Module1 folder in the class 

directory. 
2. Select Level 1 in the Project Browser. 

3. In the View tab>Create panel, expand Elevation and click  
(Building Elevation). 
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4. Select a location west of the building to place the elevation. The arrow 
points toward the building. 

 

5. A building elevation now appears in the Project browser. Right-click 
on the new building elevation and select Rename… (or press <F2>). 
Rename it to West Elevation. 
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6. Select the elevation you just added in the Level 1 floor plan. The 
section consists of two different parts. One is the bubble. The bubble 
holds the sheet information when the view is added to a sheet. 

 

 

 

The second is the target. The target holds the physical properties of the 
view that it is representing. The elevation markers are not just symbols. 
They hold the information for the corresponding view. If an elevation 
marker is deleted, so is the view. Additionally, if the target is moved, it 
should be selected using a pick window. Both the bubble and the target 
should move together, or else unexpected results occur. 

7. Press <Esc>. This time, only select the bubble. The familiar blue 
checkboxes appear. If you turn on the other three targets, you create 
three additional views. 

8. Clear the West Elevation target. 
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9. A Warning dialog box opens indicating that you are deleting a view. 

Click . 

 

10. If you accidentally delete the view, click  (Undo). 
11. Select the bubble again. The Rotate  icon appears. Use it to rotate 

the position in which the view is being taken from. 

Be careful when using this functionality. This determines the exact 
rotational value of the elevation. If this is not accurately perpendicular to 
the structure, the view is off. If an elevation on an angled or radial surface 
is required, click Building Elevation and hover your cursor over the side 
of the building on which you want the elevation. It automatically positions 
itself perpendicular to the geometry of the building. 

12. Press <Esc>. 
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13. Select the target. Notice the blue line with the blue grips on the end. A 
dotted line forms a box around a portion of the model. These are your 
view extents, which indicate exactly where the perimeter and depth of 
your elevation are going to land. The resulting elevation is cropped at 
these extents. 

 

14. Select the blue grip ( ) at the top of the line. 
15. Move it down closer to the area on the west side of the building. 
16. A Drag icon ( ) appears in the middle of the line to indicate the view 

depth. By default, this lands directly on a framing member. It 
determines the depth in which the elevation is clipped. You can adjust 
it as needed. Press <Esc>. 

17. Double-click on West Elevation in the Project Browser or double-click 
directly on the elevation target in the floor plan to open that view. 
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18. In this elevation view, the default detail level is Coarse. At the bottom 
of the view, change the Detail Level to . 

 

19. Notice a line at the perimeter of the view. This is called a crop region. 
The rectangle directly relates to the grips at the end of the elevation 
target in the plan view. By moving the crop region in elevation, you 
are moving the extents in plan. 

20. Type WT to tile the elevation and the plan. 
21. In elevation, select the crop region. 
22. Click in the plan view. The elevation and elevation boundary lines are 

selected. Remember that changes in one view have a direct effect on 
many other views. 

 

23. Maximize the west elevation ( ). 
24. You can control the crop region using the following tools on the View 

Control toolbar: 

 (Crop / Do Not Crop View): Turns cropping on or off. If you 
select an elevation marker in plan when cropping has been turned 
off in the elevation view itself, you do not see the blue grips. 
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 (Hide/Show Crop Region): This hides or shows the crop region 
box, without changing the cropping status.. 

25. Click (Show Crop Region) to show the crop region. 
26. Right-click anywhere in the view and select View Properties… 

 

27. Additional Instance Parameters pertaining to the extents of the view 
appear in the View Properties dialog box. Crop View and Crop 
Region Visible are both controlled by the icons in the View Control 
toolbar. 

28. The Annotation Crop enables the designer to retain text and symbols 
outside of the area that shows the lines of the building. Toggle this 

parameter on and click . 
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29. Select the crop region. There is an additional region. Only annotative 
elements appear in the area between the annotative region and the crop 
region. 

 

30. Right-click and select View Properties again. 
31. Click  to open the Far Clipping dialog 

box. 
32. Select the No Clip option. 
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33. Click  twice to exit both dialog boxes. The elevation 
now looks at the entire structure. 

 

To Create Framing Elevations 
A framing elevation is set up to capture the framing elements in an 
elevation of a single area in a building, behind other model objects (such 
as walls). The most common use for a framing elevation is to generate 
bracing elevations and schematics. The output is similar to that of a 
building elevation. Both are views generated from a plan and both have 
the same properties. 

1. Select Level 1 under Structural Plans in the Project Browser. 
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2. Zoom the area along column line 6 between column lines 2 and 3. 

 

3. In the View tab>Create panel, click Framing Elevation. 

 

4. Hover your cursor over column line 6 between 2 and 3. An elevation 
object appears. 

5. Once the elevation marker appears, select the line (you can adjust it 
after placement if needed). 
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6. Press <Esc> twice to exit the command or click Modify in the 
contextual tab. 

7. Select the target. The extents focus only on the bracing bay. 
8. A new framing elevation appears in the Project Browser under 

Elevations (Interior Elevation). Right-click on it and rename it to 
Bracing Bay A. 

9. Double-click on Bracing Bay A to open it. 

 

10. The crop region is too tall in the default view. Select it and stretch it 
down to a reasonable area. The grid bubbles move with it, keeping 
them visible. 

11. Change the Detail Level to . 
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12. Drag ( ) the crop region to the left to show both bays. 

    

13. The framing elevation has been created. Remember that you can drag 
the Level lines out of the way for a more organized view. The level 
objects automatically come in as 2D so that they do not affect the other 
elevations. 
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Creating Sections 

Creating sections is similar to creating elevations. The same concept of 
creating a new view still applies. Sections are controlled by the crop 
region, as well as depth clipping. A section is simply an elevation taken 
through the middle of a building. 

To Create a Section 
1. Open the first floor plan. 

2. In the View tab>Create panel, click  (Section). Notice the 
Section contextual tab displays. 

3. Select a point to the right of column line 1 and above column line 8. 
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4. Select a second point parallel with column line 1 and below column 
line 6, as shown below. 

 

 

5. After placing the section, the Modify Views contextual tab displays. 
This allows you to modify the section to the desired parameters. 

 

6. The extents of the section are probably outside a reasonable range. 
Select the drag ( ) icon to the right of the far clip window and drag it 
back to between column lines 1 and 2. 

7. With the section selected, you see the following blue icons: 

  The Cycle icon enables you to toggle through the head, tail, or 
blank options. The cycle icon appears on both sides of the section 
line. 
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  The Flip arrow changes the direction of the section. 

  The Break icon enables you to break section lines to avoid 
clutter and multiple annotation lines in the model. Once the Break 
icon is selected, you can slide the section lines to clear the building 
using the newly formed grips. 

 

8. Click the  (Break) icon again, or drag the grips back together to 
change the section line back to continuous.  

9. With the section selected, click  (Split Segment) in the Modify 
Views tab>Section panel. 
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10. Your cursor turns into the  symbol. Select the section line 
anywhere along its length. The segment of the section now follows the 
movement of your cursor. 

 

11. Exit the command. If the line was split, you can drag the split section 
and realign it, or use the control grips to decide on the section 
placement. 

12. A new building section has appeared in the Project Browser. Rename 
it to Col A Section. 
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13. Double-click on Col A Section to open it. 

 

14. Change the Detail Level to . 

 

15. Zoom in on any area. The 1/8” line weight seems heavy. 

16. In the View tab>Graphics panel, click  (Thin Lines). 
17. Close the section. 
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Creating Callouts 

Another way to generate a view is to create a callout. This command clips 
a region, copies it to a new view, and increases the scale. When creating 
callouts, there are several types. Depending on if you create these callouts 
in a Plan, Section, or Elevation view, you have the choice of Structural 
Plan, Detail, Building Section, or Wall Section callouts. 

To Create a Callout 
1. Open the Bracing Bay A elevation. 

2. In the View tab>Create panel, click  (Callout). 
3. Draw a window around a single bracing occurrence, as shown below. 

 

4. Place the callout bubble in an appropriate location. Notice the blue 
grips. This indicates that you can control the size and positioning of 
the bubble after placement. 

5. Select the Callout of Brace Bay A elevation in the Project Browser. 
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6. Select the crop region and adjust it so that only the pertinent framing 
displays. You can also drag the elevation and grid lines out of the way. 
When you select them, you will notice that the default is automatically 
2D for these callout views. 

 

Callouts and sections contain text and dimensions that are unique to these 
views only, while the physical geometry is shared throughout the model. 
Any modification to the actual model requires an investigation of these 
views to determine if the text and/or dimensions still apply, and if the text 
is still appended to the model. 
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  Practice - Creating Levels, Sections, and Callouts 
In this practice you will add levels to your model. Levels can be linked 
from a Revit architectural model, or they can be added one by one in the 
structural model. Care should be taken either way in regards to that 
level’s actual height. Copying the architectural levels would put you at a 
finish floor system rather than a top of steel elevation. 

Task 1 - Create Levels 
1. Open the file Syracuse Suites - Structural-01.rvt from the Module1 

folder in the class directory. 

2. Activate the South Elevation. 

3. Right-click and select View Properties. For the Discipline Parameter, 
select Coordination. This will show the architectural along with the 
structural elements. 

Note: For this practice there are no structural elements. These will be 
modeled in later practices. 

4 Zoom in on the 1st Floor elevation. This has been brought in from the 
architectural model. 

5. In the Home tab>Datum panel, click  (Level). 

6. In the Place Level contextual tab, click  (Element 

Properties)>  (Type Properties), as shown below. 

 

7. Toggle on the Symbol at End 1 Default option. 

8. Click  once to exit the Type Properties dialog box. 
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9. In the Place Level contextual tab>Draw panel, click  (Pick Lines) 
in the Options Bar. Type 6” for the Offset. 

 

10. Point the mouse at the architectural 1st Floor level. Your structural 
level is the top of steel. 

11. Select the level line once the blue dashed alignment line appears below 
the level. 

 

12. Rename the new level as 1ST FLOOR. 

13. Repeat the process for all of the floors. You can skip the parapet level. 
Do not forget the 00 GROUND FLOOR and the T.O. FOOTING 
levels. These levels do not require an offset. 

14. Delete the existing Level 1 and Level 2. You have replaced them with 
new levels. 

 

15. Save the model. 
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Task 2 - Create Sections 
1. Select the 00 GROUND FLOOR in the Project Browser. 

2. Right-click and select View Properties. For the Discipline parameter, 
select Coordination. This will show both the architectural and 
structural elements. 

3. In the View tab>Create panel, click  (Section). 

4. Place a horizontal section through the middle of the building from left 
to right. 

5. Select the section and break ( ) it in the middle. 

6. Select the blue grips ( ) and drag the lines to an appropriate position. 

7. On the right side of the section, click the Cycle icon ( ) to turn the 
right grid bubble on. 

8. Right-click on the new section in the Project Browser and name it 
Longitudinal Section. 
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9. Add another section from top to bottom through the middle of the 
building. 

10. Break the line ( ). 

11. Drag the grips ( ) to an appropriate position. 

12. Cycle ( ) through the bottom tail until you see the target. 

13 Rename the section to Latitudinal Section in the Project Browser. 

14. Open the Longitudinal Section. 

15. Right-click and select View Properties. For the Discipline parameter, 
select Coordination. This will show both the architectural and 
structural elements. 

16.  Set the Detail Level to . 
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17. Select the crop region, and stretch it up so that all of the levels and 
grids are visible. 

18. Stretch it to the left and right, as needed. 

19. Stretch the grid bubbles to the top of the view by selecting them and 
moving the blue grip. 

20. Open the Latitudinal Section. You can double-click it on the section 
marker or in the Project Browser. 

21. Right-click and select View Properties. For the Discipline Parameter, 
select Coordination. This will show both the architectural and 
structural elements. 

22. Repeat the previous steps to clean up the view. 

23. In the View tab>Create panel, click  (Callout). 

24. Insert a callout from Grid A & B and from T.O. Footing level to 00 
Ground Floor Level, as shown in the image below. 

 

25. Save the model. 
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Self Check: 
Setting up Levels and Working with 
Views 

1. Levels can be created in a plan view. True or False? 

2. If an elevation symbol is deleted from the plan, what happens to the 
elevation view it corresponds to? 

3. How do you break a section line after you have placed it in the model? 

4. How do you create a framing elevation?




