Chapter 2

Basic Drawing and Editing Tools

In this chapter you learn how to use the basic drawing and editing tools that apply to almost all types of elements. These tools also include alignment lines, temporary dimensions, snaps, and the Properties palette. You learn how to select elements for editing. You also learn how to move, copy, rotate, mirror, and array elements and how to align elements, split walls, trim, extend, and offset elements.

This chapter contains the following topics:

✓ General Drawing Tools
✓ Editing Elements
✓ Basic Modifying Tools
✓ Helpful Editing Tools
Learning Objectives

This chapter provides instruction to enable you to do the following:

2.1 General Drawing Tools

- Use contextual Ribbon tabs, the Options Bar, and the Properties palette as you draw and modify.
- Draw elements using draw and pick tools.
- Use drawing aids including alignment lines, temporary dimensions, and snaps.

2.2 Editing Elements

- Select elements to modify.
- Modify elements using the Ribbon, Properties, temporary dimensions, and controls.
- Filter selection sets.

2.3 Basic Modifying Tools

- Move and copy elements.
- Rotate elements around the center or an origin.
- Mirror elements by picking an axis or drawing an axis.
- Create Linear and Radial Arrays of elements.

2.4 Helpful Editing Tools

- Align, split, trim, and offset elements by using the modify tools.
2.1 General Drawing Tools

Use contextual Ribbon tabs, the Options Bar, and the Properties palette as you draw and modify.

Draw elements using draw and pick tools.

Use drawing aids including alignment lines, temporary dimensions, and snaps.

When you start a drawing command, the contextual Ribbon, Options Bar, and Properties palette enable you to set up features for each element you are placing in the drawing. As you are drawing, several features called drawing aids display, as shown in Figure 2–1. They help create designs quickly and accurately.

The Contextual Ribbon

When you select a command, the Ribbon displays the Modify tab with the contextual tools. For example, when you click (Duct), the Modify | Place Duct tab opens, as shown in Figure 2–1.

- The Modify tools are always displayed to the left of the Ribbon and the contextual tools to the right with a green panel title.

In the Select panel, click (Modify) to finish the command and return to the main tab at any time.
The Options Bar

The Options Bar displays the most used options for an element, as shown in Figure 2–2. These options are also typically found in the Properties palette.

![Figure 2–2](image)

**The Properties Palette**

The Properties palette displays the current element type in the Type Selector. You can select other types and modify some of the related parameters for the selected object, as shown in Figure 2–3.

![Figure 2–3](image)

Some of the properties parameters are only available when you are editing an element. They are grayed out when you are creating an element.

The Properties palette can be floated and moved around the screen. If it is turned off, you can turn it on in the Modify tab by clicking the Properties button or by typing PP. This is an on/off toggle.

Changes in the palette do not take effect until you click or move your cursor off the palette. If you click in the window, it applies the change but clears the elements.
Drawing Aids

As soon as you start drawing in the software, three drawing aids display on the screen: *alignment lines*, *temporary dimensions*, and *snaps*. These are available with most drawing and many modification commands.

**Alignment Lines**

Dashed *alignment lines* display as soon as you select your first point, as shown in Figure 2–4. They help keep lines horizontal, vertical, or at a specified angle. They also line up with the implied intersections of other elements.

![Figure 2–4](image)

- Hold down <Shift> to force the alignments to be orthogonal.

**Temporary Dimensions**

Along with alignment lines, *temporary dimensions* display as you draw to help place linear elements at the proper length and location, as shown in Figure 2–5.

![Figure 2–5](image)
The increments displayed for dimensions change as you zoom in closer to the elements. These *dimension snap* increments are for both linear and angular dimensions, and can be set in the Snaps dialog box.

For Imperial measurements (feet and inches), the software understands a default of feet. For example, when you type 4, it assumes 4'-0". To indicate inches, type the inch mark (") after the distance. For a distance such as 4'-6", you can type any of the following: 4'-6", 4'6, 4-6, or 4 6 (the numbers separated by a space).

Temporary dimensions disappear as soon as you finish drawing linear elements. If you want to make them permanent, select the control shown in Figure 2–6.

**Dimensions are a powerful tool to help create and annotate the model.**

**Figure 2–6**

The size of the temporary dimensions, in pixels, can be set in the Options dialog box on the *Graphics* tab.

**Snaps**

Snaps are key points that help you reference existing elements to exact points when drawing, as shown in Figure 2–7.

**Figure 2–7**

They include *Endpoints*, *Midpoints*, *Nearest*, *Work Plane Grid*, *Quadrants*, *Intersections*, *Centers*, *Perpendicular*, *Tangents*, and *Points*. When you move your cursor over an element, the Snap symbol displays. Each snap location type displays with a different symbol.

To modify the snap settings, in the *Manage* tab>Settings panel, click (Snaps). This opens the Snaps dialog box, where you can set which snap points are active, as well as the snap distances (for dimension and angular increments). It also displays the keyboard shortcuts for each snap, which you can use to override the automatic snapping.
Reference Planes

As you develop designs in Autodesk® Revit® MEP, there are times when you need additional temporary lines to help you define certain locations. You can draw reference planes (the dashed lines) to host the height of sinks or to help you define centerlines and paths for ductwork, as shown in Figure 2–8. You can snap to reference planes and they display in associated views.

How to: Sketch with Reference Planes

1. In the Systems tab>Work Plane panel, click  (Ref Plane) or type RP.
2. In the Modify | Place Reference Plane tab>Draw panel, click (Line) or (Pick Lines).
   - For (Line) select two points that define the reference plane.
   - For (Pick Lines), select any linear element and a reference plane is created that matches the length of that element.
3. Click (Modify) when you have created all of the required reference planes.

Hint: Temporarily Overriding Snap Settings

You can use the shortcut key combinations (displayed in the Snaps dialog box) or right-click and select Snap Overrides to temporarily override snap settings. Temporary overrides affect a single pick only but can be very helpful when there are nearby snaps other than the one you want.
In the Options Bar, the Offset field enables you to enter values to draw the reference plane at a specified distance from the selected points. For example, set Offset to 10'-0" and select the end points of an existing wall to create a reference plane 10'-0" away. You can also use Offset with Pick Lines.

To change the length of a reference plane, drag the circle at either end.

You can name reference planes. Select the reference plane and in the Identity Data area in Properties, type a name.

The MEP tools (such as ducts, pipes, and conduit), are strictly straight linear elements that are automatically connected with the appropriate elbows or tees. However, if you are working with walls as shown in Figure 2–9, or lines used in details, legends, and schematic drawings, more tools are available. They display in the contextual Ribbon and the tools vary according to the element being drawn.

**Draw Tools**

Linear elements include walls, lines, detail lines, and sketches for floors, roofs, stairs, and railings.

Two styles of tools are available: one where you draw the element using a geometric form, and another where you pick an existing element (such as a line, face, or wall) as the basis for the new element’s geometry.
## Draw Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Draws a straight linear element defined by the first and last points. If <strong>Chain</strong> is enabled, you can continue selecting end points for multiple segments.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Draws four linear elements defined from two opposing corner points. You can adjust the dimensions after selecting both points.</td>
</tr>
<tr>
<td><strong>Inscribed</strong> Polygon</td>
<td>Draws a polygon inscribed in a hypothetical circle with the number of sides specified in the Options Bar.</td>
</tr>
<tr>
<td><strong>Circumscribed</strong> Polygon</td>
<td>Draws a polygon circumscribed around a hypothetical circle with the number of sides specified in the Options Bar.</td>
</tr>
<tr>
<td>Circle</td>
<td>Draws a circular linear element defined by a center point and radius.</td>
</tr>
<tr>
<td><strong>Start-End-</strong> Radius Arc</td>
<td>Draws a curved linear element defined by a start, end, and radius of the arc. The outside dimension shown is the included angle of the arc. The inside dimension is the radius.</td>
</tr>
<tr>
<td><strong>Center-ends</strong> Arc</td>
<td>Draws a curved linear element defined by a center, radius, and included angle. The selected point of the radius also defines the start point of the arc.</td>
</tr>
<tr>
<td><strong>Tangent End</strong> Arc</td>
<td>Draws a curved linear element tangent to another element. Select an end point for the first point, but do not select the intersection of two or more elements. Then select a second point based on the included angle of the arc.</td>
</tr>
<tr>
<td>Fillet Arc</td>
<td>Draws a curved linear element defined by two other linear elements and a radius. Because it is difficult to select the correct radius by clicking, this command automatically moves to edit mode. Select the dimension and then modify the radius of the fillet.</td>
</tr>
<tr>
<td>Spline</td>
<td>Draws a curved linear element based on selected points. The curve does not actually touch the points (Model and Detail Lines only).</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Draws an ellipse from a primary and secondary axis (Model and Detail Lines only).</td>
</tr>
<tr>
<td><strong>Partial</strong> Ellipse</td>
<td>Draws only one side of the ellipse, like an arc. A partial ellipse also has a primary and secondary axis (Model and Detail Lines only).</td>
</tr>
</tbody>
</table>
Pick Tools

<table>
<thead>
<tr>
<th>Pick Lines</th>
<th>Use this option to select existing linear elements in the project. This is useful when you start the project from an imported 2D drawing.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pick Face</td>
<td>Use this option to select the face of a 3D massing element (walls and 3D views only).</td>
</tr>
<tr>
<td>Pick Walls</td>
<td>Use this option to select an existing wall in the project to be the basis for a new sketch line (floors, ceilings, etc.).</td>
</tr>
</tbody>
</table>

Draw Options

When you are in Drawing mode, several options display in the Options Bar, as shown in Figure 2–10.

- The Chain option controls how many segments are drawn in one process. If it is not selected, the Line and Arc tools only draw one segment at a time. If it is selected, you can continue drawing segments until you select the command again.

- The Offset field enables you to enter values to draw the linear elements at a specified distance from the selected points. For example, set Offset to 10'-0" and select the end points of an existing wall to create a new wall 10'-0" away.

- When using a radial draw tool, you can select the Radius option and add a radius in the edit field.

- To draw angled lines, move your cursor to the desired angle indicated by the temporary dimensions, and type the distance value. The angle increments shown vary depending on how far in or out the view is zoomed.
2.2 Editing Elements

- Select elements to modify.
- Modify elements using the Ribbon, Properties, temporary dimensions, and controls.
- Filter selection sets.

Building design projects typically involve extensive changes to the positions of equipment, ducting, piping, and other elements. Autodesk® Revit® software was designed to make such changes easy. (Modify) works with all of the different element types.

- When you select an element during an active command, there are a number of ways to change it, as shown in Figure 2–11:
  - Modify commands and element-specific tools display in the contextual tab in the Ribbon.
  - The Properties palette displays the Type Selector and associated parameters.
  - Temporary dimensions enable you to change the element's dimensions.
  - Controls enable you to drag, flip, lock, and rotate the element.
- When you hover your cursor over an element, a tooltip displays information about it.

Connectors are frequently linked to controls. Therefore, when the control is moved the connector is as well. Be careful not to disconnect systems when moving these controls.

The Type Selector can also be found in the Modify tab in the Ribbon or in the Quick Access Toolbar.
To delete an element, select it and press <Delete>, right-click and select **Delete**, or click **(Delete)** in the Modify panel.

When working with temporary dimensions, the default location of the dimension line might not be where you need it. For example, as shown on the left in Figure 2–12, instead of setting the distance of the selected wall from the center of the left wall, you might want to modify the distance from the grid line. Drag the control (also called the witness line) to the grid line, as shown on the right in Figure 2–12.

![Figure 2–12](image)

You can click on the square control to move the witness line from one part of the selected wall to another or drag it to a new location.

The new location of a temporary dimension is remembered as long as you are in the same session of the software.

**Hint: Press & Drag**

You can move elements by dragging them to a new location. To do this without selecting them first, verify that the **Press & Drag** option is selected in the Status Bar, as shown in Figure 2–13.

![Figure 2–13](image)

You can select elements in several ways:

- To select a single element, place your cursor on the edge of the element and click to select it.
- To add another element to a selection set, hold down <Ctrl> and select another item.
To remove an element from a selection set, hold down <Shift> and select the element.

If you click and drag the cursor to window around elements, you have two selection options, as shown in Figure 2–14. If you drag from left to right, you only select the elements completely inside the window. If you drag from right to left, you select elements both inside and crossing the window.

If several elements are on or near each other, press <Tab> to cycle through them before you click. If there are elements that might be linked to each other, such as walls that are connected, pressing <Tab> selects the chain of elements.

Press <Ctrl>+<Left Arrow> to reselect the previous selection set. You can also right-click in the drawing window with nothing selected and select Select Previous.

To select all elements of a specific type, right-click on an element and select Select All Instances>Visible in View or In Entire Project, as shown in Figure 2–15.

**Hint: Nudge**

Nudge is a feature that is often overlooked. It enables you to move an element in short increments using the arrow keys on the keyboard. The snap increments specified in the Snap dialog box determine the distance that is applied each time the arrow keys are pressed, depending how far in or out you are zoomed. This is very useful with annotation elements.
Modifying Multiple Elements

When multiple element types are selected, the *Multi-Select* contextual tab opens on the Ribbon, as shown in Figure 2–16. This gives you access to all the Modify tools, as well as the *Filter* command and tools to create and use selection sets.

![Figure 2–16](image)

The Properties palette displays tools that are common to all element types if they are available. You can also select just one type and make modifications, as shown in Figure 2–17.

![Figure 2–17](image)

**Filtering Selection Sets**

The *Filter* command enables you to specify the types of elements to select. For example, you might only want to select lighting fixtures, as shown in Figure 2–18.

![Figure 2–18](image)
How to: Filter a Selection Set

1. Select everything in the desired area.

2. Click \(|\text{Filter}\) in the Modify | Multi-Select tab or in the Status Bar. The Filter dialog box opens, as shown in Figure 2–19.

![Figure 2–19](image)

3. Click \(|\text{Check None}\) to clear all options and then select the element types you want included in the selection.

4. Click \(|\text{OK}\). The selection set is now limited to the elements you specified.

- In the Status Bar, \(|\text{Filter}\) displays how many elements you selected.
Reusing Selection Sets

When multiple elements types are selected, you can save the selection set for reuse later. For example, you might want to select a system of ductwork and not have to select each element separately. You can create a selection set that you can access quickly, as shown in Figure 2–20. You can also edit selection sets to add or remove elements from the set.

How to: Save Selection Sets

1. Select the elements you want to include in the selection set.
2. In the Modify | Multi-Select tab>Selection panel, click (Save).
3. In the Save Selection dialog box, type a name for the set as shown in Figure 2–21, and click .

How to: Retrieve Selection Sets

1. Select the elements that you want to use along with the selection set. In the Modify | Multi-Select tab>Selection panel, click (Load).
   Or, without any other selection, in the Manage tab>Selection panel, click (Load).
2. In the Retrieve Filters dialog box, as shown in Figure 2–22, select the set you want to use and click OK.

![Figure 2–22](image22.png)

3. The elements are selected and you can continue to select other elements or use the selection.

How to: Edit Selection Sets

1. If elements are selected, in the Modify | Multi-Select tab> Selection panel, click (Edit).
Or, without any selection, in the Manage tab>Selection panel click (Edit).

2. In the Filters dialog box, as shown in Figure 2–23, select the set you want to edit and click .

![Figure 2–23](image23.png)

- If you want to modify the name of the filter, click .

Some filters in this dialog box are not selection sets but apply to categories of elements, such as the various system categories shown in Figure 2–23.
3. The selection set elements stay black while the rest of the elements are grayed out. The *Edit Selection Set* tab also displays, as shown in Figure 2–24.

![Figure 2–24](image)

Figure 2–24

4. Use ![Add to Selection](image) (Add to Selection) to select additional elements for the set and ![Remove from Selection](image) (Remove from Selection) to delete elements from the set.

5. When you are finished editing, click ![Finish Selection](image) (Finish Selection).

6. In the Filters dialog box, click ![OK](image) to finish.
2.3 Basic Modifying Tools

- Move and copy elements.
- Rotate elements around the center or an origin.
- Mirror elements by picking an axis or drawing an axis.
- Create Linear and Radial Arrays of elements.

The Autodesk Revit software contains controls and temporary dimensions that enable you to edit elements. Additional modifying tools can be used with individual elements or any selection of elements. They are found in the Modify tab > Modify panel, as shown in Figure 2–25, and in contextual tabs.

You can either select the elements and start the command or start the command, select the elements, and press <Enter> to finish the selection set.

Moving and Copying Elements

- The Move, Copy, Rotate, Mirror, and Array commands are covered in this topic. Other tools are covered later.

The Move and Copy commands enable you to select the element(s) and move or copy them from one place to another. You can use alignment lines, temporary dimensions, and snaps to help place the elements, as shown in Figure 2–26.
### Move or Copy Elements

1. Select the elements you want to move or copy.

2. In the Modify panel, click (Move) or (Copy). A boundary box displays around the selected elements.

3. Select a move start point on or near the element.

4. Select a second point. Use alignment lines and temporary dimensions to help place the elements.

5. The elements remain highlighted, enabling you to start another command, or press <Esc> to finish.

### Move/Copy Elements

The Move and Copy commands have several options that display in the Options Bar, as shown in Figure 2–27.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constrain</td>
<td>Restricts the movement of the cursor to horizontal or vertical, or along the axis of an item that is at an angle. This keeps you from selecting a point at an angle by mistake. Constrain is off by default.</td>
</tr>
<tr>
<td>Disjoin (Move only)</td>
<td>Breaks any connections between the elements being moved and other elements. If Disjoin is on, the elements move separately. If it is off, the connected elements also move or stretch. Disjoin is off by default.</td>
</tr>
<tr>
<td>Multiple (Copy only)</td>
<td>Enables you to make multiple copies of one selection. Multiple is off by default.</td>
</tr>
</tbody>
</table>

- These commands only work within the current view, not between views or projects. To copy between views or projects, use (Copy to Clipboard) and (Paste).

### Hint: Pinning Elements

If you do not want elements to be moved, you can (Pin) them in place, as shown in Figure 2–28. They can be copied.

Select the element and click (Unpin) to free it.
### Rotating Elements

**How to:**

The **Rotate** command enables you to rotate selected elements around a center point or origin. You can use alignment lines, temporary dimensions, and snaps to help specify the center of rotation and angle. You can also create copies of the element as it is being rotated.

1. Select the element(s) you want to rotate.
2. In the Modify panel, click \( \text{Rotate} \) (Rotate) or type **RO**.
3. The center of rotation is automatically set to the center of the element or group of elements, as shown on the left in Figure 2–29. To change the center of rotation, as shown on the right in Figure 2–29, use one of the following:
   - Drag \( \text{Center of Rotation} \) to a new point.
   - In the Options Bar, next to **Center of rotation**, click \( \text{Place} \) and use snaps to move it to a new location.
   - Press the **Spacebar** to select the center of rotation and click to move it to a new location.

![Figure 2–29](image)

4. In the Options Bar, specify if you want to make a Copy (select **Copy** option), type an angle in the **Angle** field, as shown in Figure 2–30, and press <Enter>. You can also specify the angle on screen.

![Figure 2–30](image)

5. The rotated element(s) remain highlighted, enabling you to start another command, or press <Esc> to finish.

---

To specify the angle on screen, select a point for the **rotate start ray**—the reference line for the rotation angle. Then select a second point, using the temporary dimension to help you set the angle.
The Disjoin option breaks any connections between the elements being rotated and other elements. If Disjoin is on (selected), the elements rotate separately. If it is off (cleared), the connected elements also move or stretch. Disjoin is off by default.

The Mirror command enables you to mirror elements about an axis defined by a selected element or by selected points as shown in Figure 2–31.

**How to:**

**Mirror Elements**

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:
   - Click (Mirror - Pick Axis) or type MM. This prompts you to select an element as the Axis of Reflection (mirror line).
   - Click (Mirror - Draw Axis) or type DM. This prompts you to select two points to define the axis about which the elements mirror.
3. The new mirrored element(s) remain highlighted, enabling you to start another command, or press <Esc> to finish.
4. To mirror the elements without keeping the original, clear the Copy option in the Options Bar before mirroring.
Creating Linear and Radial Arrays

The **Array** command creates multiple copies of selected elements in a linear or radial pattern, as shown in Figure 2–32. For example, you can array a row of columns to create a row of evenly spaced columns on a grid, or array a row of air terminals. The arrayed elements can be grouped or placed as separate elements.

- A linear array creates a straight line pattern of elements, while a radial array creates a circular pattern around a center point.

How to: Create a Linear Array

1. Select the element(s) to array.
2. In the Modify panel, click (Array).
3. In the Options Bar, click (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and direction of the array. The array is displayed.

Hint: Scale

The Autodesk Revit software is designed with full-size elements. Therefore, not much can be scaled. However, you can use (Scale) in reference planes, images, lines, walls, and imported files from other software. Scaled walls are made longer or shorter, but retain the original width and height.
If you have the **Group and Associate** option toggled on, you are prompted again for the number of items, as shown in Figure 2–33.

If you have the **Group and Associate** option toggled on, you are prompted again for the number of items, as shown in Figure 2–33.

![Figure 2–33](image)

To make a linear array in two directions, you need to array one direction first, select the arrayed elements, and then array them again in the other direction.

### Array Options

In the Options Bar, set up the Array options for **Linear Array** (top) or **Radial Array** (bottom), as shown in Figure 2–34.

![Figure 2–34](image)

<table>
<thead>
<tr>
<th><strong>Group and Associate</strong></th>
<th>Creates a group element out of all arrayed elements. Groups can be selected by selecting any elements in the group.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number</strong></td>
<td>Specifies how many instances you want in the array.</td>
</tr>
<tr>
<td><strong>Move To:</strong></td>
<td>2nd specifies the distance or angle between the center points of the two elements.</td>
</tr>
<tr>
<td></td>
<td>Last specifies the overall distance or angle of the entire array.</td>
</tr>
<tr>
<td><strong>Constrain</strong></td>
<td>Restricts the direction of the array to only vertical or horizontal (Linear only).</td>
</tr>
<tr>
<td><strong>Angle</strong></td>
<td>Specifies the angle (Radial only).</td>
</tr>
<tr>
<td><strong>Center of rotation</strong></td>
<td>Specifies a location for the origin about which the elements rotate (Radial only).</td>
</tr>
</tbody>
</table>
How to: Create a Radial Array

1. Select the element(s) to array.
2. In the Modify panel, click (Array).
3. In the Options Bar, click (Radial).
4. Drag the (Center of Rotation) control or use (Place), to move the center of rotation to the appropriate location, as shown in Figure 2–35.

Remember to set the Center of Rotation control first, because it is easy to forget to move it before specifying the angle.

5. In the Options Bar, type an angle and press <Enter>, or specify the rotation angle by selecting points on the screen.

Modifying Arrays

When you select an element in an array that is created as a group, the associated shape controls and dimensions display, as shown in Figure 2–36. You can modify the number of instances and for radial arrays you can modify the distance to the center.
To remove just the array constraint on the group, select one of the elements in the group and in the Modify contextual tab>Group panel, click [Ungroup]. This only ungroups the array but not the groups created when the array was created. To ungroup all of the elements, select the elements and use [Filter] to select just groups. Then click [Ungroup].
2.4 Helpful Editing Tools

Align, split, trim, and offset walls and other elements by using the modify tools.

As you work on a project, some additional tools on the Modify tab>Modify panel, as shown in Figure 2–37, can help you with placing, modifying, and constraining elements. **Align, Split, Trim, and Offset** can be used with a variety of elements.

**Figure 2–37**

The **Align** command enables you to line up one element with another. Most Autodesk Revit elements can be aligned. For example, you can line up an air terminal with ceiling grids as shown in Figure 2–38.

**Figure 2–38**

**How to:** **Align Elements**

1. In the **Modify** tab>Modify panel, click (Align) or type the shortcut **AL**.
2. Select a line or point on the element that is going to remain stationary.

---

*Do not duplicate.*
3. Select a line or point on the element to be aligned. The second element moves into alignment with the first one.

- The **Align** command works in both plan and elevation views.

- The **Align** command also works in 3D views. Make sure you select the correct component of the elements to align. Zoom in if needed.

- You can lock alignments so that the elements move together if either one is moved. Once you have created the alignment, a padlock is displayed. Click on the padlock to lock it, as shown in Figure 2–39.

  ![Figure 2–39](image)

- Locking elements enlarges the size of the project file, so use this option carefully.

- Select the **Multiple Alignment** option to select multiple elements to align with the first element, as shown in Figure 2–40. You can also hold down <Ctrl> to make multiple alignments.

- For walls, you can specify if you want the command to prefer **Wall centerlines**, **Wall faces**, **Center of core**, or **Faces of core**, as shown in Figure 2–40. The core refers to the structural members of a wall as opposed to facing materials, such as sheetrock.

  ![Figure 2–40](image)
Splitting Linear Elements

The Split command enables you to break elements, such as ducting, piping, cable tray and conduit, as well as walls and lines, at a specific point. You can use alignment lines, snaps, and temporary dimensions to help place the split point. After you have split the element, you can use other editing commands to modify it. Splitting duct and pipe provides Autodesk Revit’s sizing tools with greater flexibility to reduce size where needed as shown in Figure 2–41.

![Figure 2–41](image)

There are two commands: (Split Element) and (Split with Gap).

How to: Split Linear Elements

1. In the Modify tab>Modify panel, click (Split Element) or type the shortcut SL.
2. In the Options Bar, select or clear the Delete Inner Segment option, as needed.
3. Move the cursor to the point you want to split and select the point.
4. Repeat for any additional split locations.
5. Modify the items that were split, as needed.

(Split with Gap) splits the element at the point you select, as shown in Figure 2–42, but also creates a Joint Gap specified in the Options Bar.

![Figure 2–42](image)
Trimming and Extending

The Trim command enables you to either trim or extend walls, lines, beams, and braces. There are three trim methods: Trim/Extend to Corner, Trim/Extend Single Element, and Trim/Extend Multiple Elements.

- When selecting elements to trim, click the part of the element that you want to keep. The opposite part of the line is then trimmed.

How to: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click \( \text{\text{Trim/Extend to Corner}} \) or type the shortcut TR.
2. Select the first wall or line on the side you want to keep.
3. Select the second wall or line on the side you want to keep, as shown in Figure 2–43.

\[ \text{Figure 2–43} \]

How to: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click \( \text{\text{Trim/Extend Single Element}} \).
2. Select the cutting or boundary edge.
3. Select the wall or line to be trimmed or extended, as shown in Figure 2–44.

\[ \text{Figure 2–44} \]

How to: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click \( \text{\text{Trim/Extend Multiple Elements}} \).
2. Select the cutting or boundary edge.
3. Select the walls or lines that you want to trim or extend. For trimming, select the side you want to keep, as shown in Figure 2–45.

You can click in a blank space to clear the selection and select another cutting edge or boundary.

The Offset command is an easy way of creating parallel copies of linear elements at a specified distance, as shown in Figure 2–46. Ducts, Pipes, Cable Tray, and Conduit can all be offset.

The offset distance can be set by typing the distance (Numerical method shown in Figure 2–47) or by selecting points on the screen (Graphical method).
How to: Offset using the Numerical Method

1. In the Modify tab>Modify panel, click Offset (Offset) or type the shortcut OF.
2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the required distance in the Offset field.
4. Move the cursor over the element you want to offset. A dashed line previews the offset location. Move the cursor to flip the sides, as needed.
5. Click to create the offset.
6. Repeat steps 4 and 5 to offset other elements by the same distance, or to change the distance for another offset.
7. Press <Esc> or start another command to finish.

With the Numerical option, you can select multiple connected elements for offsetting. Hover your cursor over one and press <Tab> until the required elements are highlighted, as shown in Figure 2–48. Select the elements to offset them. This enables you to offset all of them at once.

Figure 2–48

How to: Offset using the Graphical Method

1. Start the Offset command.
2. In the Options Bar, select the Graphical option.
3. Select the element to offset.
4. Select two points that define the distance of the offset and which side to apply it. You can type an override for the temporary dimension for the second point.
When working with MEP elements (such as ducts) the offset element might not automatically connect to other nearby elements, as shown on the left in Figure 2–49. Drag the end of the new element away from the other element and then back again. It should connect as shown on the right in Figure 2–49.
Hiding Elements in Views

As you are working, you can hide individual elements or entire categories of elements to clarify the display. They remain hidden until you display them again.

- Select the element(s) you want to hide, right-click, and select **Hide in view>Elements** or **Category**.

- The **Elements** option hides only the elements you selected, while the **Category** option hides all elements in that category. For example, you can select one grid line and use **Hide in view>Category** to hide all of the grid lines.

- To see the elements or category again, in the View Control Bar, click (Reveal Hidden Elements). The border and any hidden elements are displayed in magenta, while visible elements in the view are grayed out, as shown in Figure 2–50. Select the hidden elements you want to restore, right-click, and select **Unhide in View>Elements** or **Category**, or in the Reveal Hidden Elements contextual panel, click (Unhide Element) or (Unhide Category).

![Figure 2–50](image-url)
Estimated time for completion: 10 minutes

In this practice you will use temporary dimensions, controls, and snaps to modify the location of elements. You will then copy and move elements as well as rotate and align elements. The final version of the project is shown in Figure 2–51.

Task 1 - Use temporary dimensions and controls to modify elements.

1. Open the project file Simple-Building.rvt, found in the Chapter 2 folder of your class folder.

2. Select the AHU-1 unit in the hall of the building.

3. Zoom in to the connectors/controls. Select the temporary dimension above the unit and change the distance to 2'-0" as shown in Figure 2–52.
The temporary dimensions work with the walls in this project because they are part of the project, not linked in.

4. The unit moves and the ducts move with it because the connectors control the location of the duct fittings and ducts.

5. Pan over to the lower left room in the building. Select the tag that overlaps the ductwork as shown on the left in Figure 2–53.

6. In the Options Bar, select Leader.

7. Use the Move control to move the tag outside the room to a position in which it is not overlapping anything as shown on the right in Figure 2–53.

8. Zoom out to display the entire building. (Hint: Double-click the mouse wheel.)

9. Select the blue horizontal duct and use the Drag control to lengthen the duct so that it reaches into the room on the far right.

10. Click in empty space to clear the duct selection.
11. The endcap of the duct did not move, as shown in Figure 2–54. Select and drag it to the endpoint of the duct.

![Figure 2–54](image)

12. Undo the change in duct length.

13. Select the duct endcap.

14. In the Modify | Duct Fittings tab>Modify panel, click (Move).

15. For the base point, select the duct endpoint.

16. Move it into the other room again. This time the endcap moves and the duct, which has a connector to the endcap, resizes as well.

**Task 2 - Copy elements.**

1. Select the **Air Terminals** and associated ductwork as shown in Figure 2–55.

![Figure 2–55](image)

*Because there is only one type of element selected, the specific type of element is displayed in the contextual tab.*
Because there is more than one type of element selected the contextual tab displays as Multi-Select.

2. In the Modify | Multi-Select tab>Modify panel, click (Copy).

3. In the Options Bar, select the Multiple option.

4. For the base point, select the endpoint of one of the vertical ducts as shown in Figure 2–56.

5. Copy the elements into the last room, as shown in Figure 2–56.

6. Press <Esc> twice to end the command.

**Task 3 - Align and rotate elements.**

1. In the Project Browser, open the view Mechanical>HVAC> Ceiling Plans: 1- Ceiling Mech.

2. The air terminal locations do not match the ceiling grids as shown in Figure 2–57.
3. Zoom in on the room to the left.

4. In the Modify tab>Modify panel, click \( \text{\textbullet} \) (Align).

5. Select a vertical grid line and then the edge of the air terminal as shown in Figure 2–58. The air terminal now lines up with the vertical pattern of the ceiling grid.

6. Repeat the process with the air terminal and the horizontal grid location. Select the edge of the grid line first and then the air terminal.

7. Repeat the process in both rooms so that the air terminals line up with the grids shown in Figure 2–59.

8. In the last room the ceiling grid is rotated. In this case you need to rotate the air terminals as well.
9. Select one of the air terminals in the room with the rotated ceiling grid.

10. In the Modify | Air Terminals tab>Modify panel, click (Rotate).

11. In the Options Bar, set the angle to 45.

12. Use the Align command to move the air terminal to match the ceiling grid location. First you will select the ceiling grid line and then the edge of the air terminal.

13. The flex duct moves with the air terminal as shown Figure 2–60.

14. Without rotating the air terminal, click (Align).

15. Select a grid line close to one of the other air terminals and then select the edge of the air terminal. The air terminal moves to touch the grid line and also rotates to match the angle of the grid line.

16. Finish aligning all of the air terminals in this room. The exact location is up to you.

17. Zoom out to display the entire building.
18. Switch to the **Mechanical>HVAC>Floor Plans: 1 - Mech** view. The rotated terminals and flex duct display correctly in this view as well as shown in Figure 2–61.

![Figure 2–61](image)

19. Zoom out to display the entire building.

20. Save and close the model.
Chapter Review Questions

1. Which of the following explain alignment lines? Select all that apply.
   a. They help keep the lines horizontal, vertical, or at a specified angle.
   b. They snap to points along a line.
   c. They line up with the implied intersections of walls or other elements.
   d. They are part of temporary dimensions that touch the dimensioned elements.

2. Which editing command would you use to break part of a duct so you can change the duct type?
   a. Align
   b. Split
   c. Trim
   d. Offset

3. All of the Trim commands can also be used to extend elements.
   a. True
   b. False

4. Which of the following commands enable you to select only Light Fixtures in a view?
   a. Filter
   b. Group
   c. Quick Select
   d. Design Options

5. In the Mirror command, how do you remove the original element(s) if you do not want to keep them?
   a. You must delete them separately from the command.
   b. Use the Demolish tool.
   c. Clear the Copy option in the Options Bar.
   d. Select the Delete Original option in the Options Bar.
# Command Summary

<table>
<thead>
<tr>
<th>Button</th>
<th>Command</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add to Selection" /></td>
<td>Add to Selection</td>
<td><strong>Ribbon:</strong> Edit Selection Set tab&gt; Edit Selection panel</td>
</tr>
</tbody>
</table>
| ![Align](image) | Align | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** AL |
| ![Array](image) | Array | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** AR |
| ![Copy](image) | Copy | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** CO |
| ![Copy to Clipboard](image) | Copy to Clipboard | **Ribbon:** Modify tab>Clipboard panel> Copy to Clipboard  
**Shortcut:** <Ctrl>+C |
| ![Delete](image) | Delete | **Ribbon:** Modify tab> Modify panel> Delete  
**Shortcut:** DE |
| ![Edit (Selection)](image) | Edit (Selection) | **Ribbon:** Modify | Multi-Select tab> Selection panel or Manage tab> Selection panel |
| ![Edit Type/Type Properties](image) | Edit Type/Type Properties | **Ribbon:** Modify tab> Properties panel> Type Properties  
**Properties palette:** Edit Type |
| ![Filter](image) | Filter | **Ribbon:** Modify | Multi-Select tab>Filter panel> Filter  
**Status Bar** |
| ![Load (Selection)](image) | Load (Selection) | **Ribbon:** Modify | Multi-Select tab> Selection panel or Manage tab> Selection panel |
| ![Mirror - Draw Axis](image) | Mirror - Draw Axis | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** DM |
| ![Mirror - Pick Axis](image) | Mirror - Pick Axis | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** MM |
| ![Move](image) | Move | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** MV |
| ![Offset](image) | Offset | **Ribbon:** Modify tab> Modify Panel  
**Shortcut:** OF |
| ![Pin](image) | Pin | **Ribbon:** Modify tab> Modify panel> Pin  
**Shortcut:** PN |
<table>
<thead>
<tr>
<th>Tool</th>
<th>Ribbon: Modify tab or Systems tab</th>
<th>Shortcut: PP or RP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Element panel or Work Plane Panel</td>
<td>Properties</td>
</tr>
<tr>
<td>Ref Plane</td>
<td>Element panel or Work Plane Panel</td>
<td>Modify</td>
</tr>
<tr>
<td>Remove from Selection</td>
<td>Edit Selection Set tab</td>
<td>Modify Selection</td>
</tr>
<tr>
<td>Rotate</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Save (Selection)</td>
<td>Modify</td>
<td>Multi-Select tab</td>
</tr>
<tr>
<td>Scale</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Split Element</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Split with Gap</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Trim/Extend Multiple Elements</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Trim/Extend Single Element</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Trim/Extend to Corner</td>
<td>Modify tab</td>
<td>Modify Panel</td>
</tr>
<tr>
<td>Type Selector</td>
<td>Properties palette</td>
<td>Modify tab (Optional)</td>
</tr>
<tr>
<td></td>
<td>Quick Access Toolbar (Optional)</td>
<td></td>
</tr>
</tbody>
</table>