Visit our website to learn more about this and other books:
Section 2: Profiles

In this section you learn how to:

- Create and manage Profile Views
- Create a Profile from a surface and by layout
- Work with Profile Transparent Commands
- Display existing and proposed Elevations correctly in Profile Bands
Profiles Overview

A profile is the second plane of a roadway design. It is a view of the alignment from one side of the centerline showing elevations along the alignment. An AutoCAD Civil 3D profile is a combination of a profile view and any number of profiles displayed in the view.

- A profile view consists of a profile grid and its annotation. The view’s vertical lines represent alignment stationing and the horizontal lines represent elevations.

- A profile represents a surface or roadway vertical design. A typical road design profile view contains two profiles: the existing ground and a proposed vertical design. The existing ground profile represents elevations along the path of the alignment, usually from a sampled surface. The proposed vertical defines elevations along the path of the proposed roadway. You can have any number of existing and proposed vertical alignments displayed in the same profile view at the same time.

AutoCAD Civil 3D Profiles are managed by:

- **Profile View Properties**: Settings specific to individual profiles, such as datum elevation and maximum height.

- **Profile View Styles**: Affect how the grid and its annotation are displayed.

- **Profile Styles**: Control how the profile linework is displayed.
- **Bands:** Control optional, additional annotation that can be displayed across the top or bottom of a profile view. Bands are grouped into Band Sets to make it easier to apply multiple, related bands at once. An example of a profile band is the elevation and station data shown in the profile below.

![Profile Bands Example](image)

**Repositioning and Deleting Profile Views**

AutoCAD Civil 3D Profile Views are safe to reposition as needed with the AutoCAD **Move** command, and copy with the AutoCAD **Copy** command. They can also be erased with the AutoCAD **Erase** command. Erasing a profile view also erases the profiles inside it if there are no other views showing that profile.
Create Profiles from Surface

Most profile views display at least one profile based on a surface, such as from an existing ground terrain model. To do so, go to the Home tab, Create Design panel, and select Profile>Create Surface Profile. In the Create Profile from Surface dialog box select the desired Alignment and Surface (or Surfaces if you want to sample more than one). Then enter a desired station range. Click Add to sample each surface based on these settings.

The above creates a profile along the alignment itself. If you want to sample at an offset from the alignment, select the Sample Offsets option and enter an offset value (negative for left), and click Add. You can sample multiple offsets by entering values one at a time and clicking Add after each.

There are two ways to exit this dialog box (other than clicking Cancel):

- If you do not have a profile view of this alignment in the drawing, click Draw in Profile View. This launches the Create Profile View dialog box.

- If you already have a profile view of this alignment click OK and any new profiles are added to the existing view. If you clicked OK accidentally without having a view in which to display the profile, go to the Home tab, Profile and Section Views panel, and select Profile View>Create Profile View.
Create Profile View Wizard

You can create a profile view at any time using the **Profile View>Create Profile View** command. Clicking **Draw in Profile View** in the Create Profile from Surface dialog box takes you to the same wizard. All of the settings selected in the wizard can be reassigned later through Profile View Properties (except for the alignment they are based on).

The General page in the Create Profile View Wizard enables you to select the alignment you want to work with and assign the profile view a name, description, view style, and layer. The **Show offset profiles by vertically stacking profile views** option enables you to display offset profiles in the same view as the centerline profile without overlapping.
The *Station Range* second page enables you to select the station range you want to work with. Automatic includes the entire alignment’s length.

- The **Automatic** option creates a profile view that is sized to avoid having to be split.

- The **User Specified** option enables you to assign specific minimum and maximum heights to the profile view. If a profile in one of these views had an elevation below or above the specified values the profile view is split to accommodate it. If a profile needs to be split you can assign different styles to control the different portions of the split profile.
Below is a profile view that has been split.

The *Stacked Profile* page enables you to set the number of stacked views, the gap between those views, and the styles for each one.

The *Profile Display Options* page enables you to apply specific controls to profiles that are displayed in the views. Some of the most important options include:

- **Draw option**: Disabling this prevents the profile from being displayed in the view.
- **Style**: The profile style to show in the profile.
- **Labels**: Which profile label set should be displayed on the profile.
The Pipe Network Display page is considered later in the Student Guide.

The Data Bands page in the wizard enables you to select the bands you want to include. Bands are additional profile information that can be included along the top or bottom of a profile. Bands are applied in this dialog box through selecting a Band Set.

New to Civil 3D 2010 is the option to hatch the profile according to the Cut Area, Fill Area, using Multiple boundaries, or From criteria that you
import. If you select one of these options, the software will allow you to specify the upper and lower boundaries for the hatch area.

When satisfied, click **Create Profile View** to create the profile view. After the profile view is created these settings can be reviewed and adjusted through Profile View Properties. One way to open this dialog box is to select the profile view, right-click and select **Profile View Properties**.

### Practice - Working with Profiles, Part I

#### Task 1 – Create Surface Profiles

1. Continue working with the drawing from the previous practice or open **Site Design - Mod 4.2.dwg** from the following folder:

   \C:\Installation Files\Backup

   If used, after opening this file save it as **Site Design.dwg** in folder listed below. Overwrite a previous drawing of the same name as needed.

   \C:\Installation Files

2. **Zoom Extents** and **Pan** the drawing so that you have some open drawing area to the right in which to create profiles.

3. In the **Home** tab, on the Create Design panel, select **Profile – Create Surface Profile**.
4. In the dialog box, select the **Jeffries Ranch Rd** alignment, highlight the EG surface and click **Add**. This samples an existing ground profile along the centerline, the entire length of Jeffries Ranch Rd. Select the **Sample offsets** option and type **33** in the **Sample offsets** field. Click **Add>>** and set the style to **Right Sample Profile** for the right ROW. In the **Sample offsets** field, type **-33**, click **Add>>**, and set the style to **Left Sample Profile** for the left ROW.

![Create Surface Profile](image)

**Note:** You can also check **Sample offsets** and enter all three profile offsets at once, as shown below. Then set the **Profile Style** as required.

![Profile offsets](image)

5. Click **Draw in Profile View**. (If you clicked **OK** instead, select **Profile View-Create Profile View** in the **Home** tab, on the Profile & Section Views panel).
6. In the Create Profile View wizard, General page, confirm Jeffries Ranch Rd as the alignment and set the Profile view style to Full Grid. Leave the Show offset profiles by vertically stacking profile views option cleared and click Next.

7. Accept the defaults on the Station Range page.

8. Accept the defaults on the Profile View Height page.

9. Accept the defaults on the Profile Display Options page.

10. On the Data Bands page, accept the default EG-FG Elevations and Stations and click Next.
11. On the Profile Hatch Options page, accept the default of no hatching and click Create Profile View.
12. When prompted, click a point to the right of the plan view to define the lower left corner of the Profile View.

13. In the Home tab, on the Create Design panel, select Profile – Create Surface Profile.

14. In the Create Profile from Surface dialog box, select Michelle’s Way and EG. Click Add>> to transfer your choices to the Profile List and click Draw in profile view.

15. In the Create Profile View Wizard, General page, confirm Michelle’s Way as the alignment and Major Grids as the Profile View Style. Click Next.
16. Accept the defaults on the Station Range page.

17. Accept the defaults on the Profile View Height page.

18. Accept the defaults on the Profile Display Options page.

19. On the Data Bands page, accept the default EG-FG Elevations and Stations and click Next.

20. On the Profile Hatch Options page, accept the default of no hatching and click Create Profile View.

21. When prompted, click a point to the right of the plan view and above the Jeffries Ranch Rd Profile View to define the lower left corner of the Profile View.
22. Locate the two centerline profiles in the *Prospector* tab under their respective alignments. To help tell these profiles apart, rename them to something more obvious.

23. Right-click on the Jeffries Ranch Rd Existing Ground profile and select *Properties*. In the *Profile Properties Information* tab, rename it to *EGCL – Jeffries Ranch Rd* and click *OK*.

24. Right-click on the Michelle’s Way Existing Ground profile and select *Properties*. In the *Profile Properties Information* tab, rename it to *EGCL – Michelle’s Way* and click *OK*.
25. Save the drawing.

**Task 2 – Adjust the Profile View**

1. On occasion, you may be required to modify some of the choices you made in the Create Profile View Wizard – in particular, the datum elevation or grid height. Select the Michelle’s Way centerline profile view, right-click, and select **Profile View Properties**.

2. In the *Elevations* tab, select the **User specified height** option. Enter a **Minimum** of 30 and a **Maximum** of 100, as shown below. Click **OK**.

3. Save the drawing.
Finished Ground Profiles

Finished ground profiles (also referred to as proposed profiles or proposed vertical alignments) often are created interactively through the Profile Layout toolbar, similar to how alignments are created by layout. The toolbar can be opened going to the Home tab, Create Design panel, selecting Profile>Profile Creation Tools.

- Vertical curves transition a vehicle from one tangent grade to another and occur in two situations: Crest (top of a hill) and Sag (valley).

- There are four types of vertical curves to transition between changing the tangent grades of a crest or sag: Circular, Parabolic, Asymmetric Parabolic, and Best Fit. Roadways almost always use parabolic (equal length) curves. Asymmetric parabolic curves are usually only used if layout constraints do not permit an equal-length curve. True circular curves are used in some parts of the world for low-speed rail design and generally should never be used for roadways (which otherwise could lead to vehicle vaulting or bottoming out). Best fit curves follow the most likely path through a series of points.

- In the Settings tab, in the Profile heading, the Edit Features Settings sets the default curve type, styles, and command settings.

Most vertical designs have regulations affecting the minimum and maximum values for tangent slopes, distances along tangents between vertical curves, and safety design parameters for passing sight and stopping sight distances. Refer to local design manuals for more information on these design constraints.

The points connecting tangents in a finished ground profile are referred to as a Point of Vertical Intersection (PVI).
Creating and Editing Profiles

Similar to the Alignments Layout toolbar, the Profile Layout toolbar contains an overall vista (Profile Grid View) and Profile Layout Parameters (segment data viewer). These vistas enable you to review and edit the vertical design. The settings used when creating a finished ground profile can be selected through the Draw Tangents flyout menu in the toolbar. This toolbar is used to edit any kind of profile, including profiles created from surfaces.

Other toolbar commands Add, Delete, or Move individual tangent, PVIs, or vertical curve segments.

- When editing a profile in the layout parameters or grid view, editable parameters appear in black.
- You can graphically edit a design profile using grips. As soon as you select the profile, a new tab appears in the Ribbon that is specific to that profile.

When graphically editing a vertical alignment, the tangents, PVIs, and vertical curves display grips that represent specific editing functions.

- The red triangular grip moves the PVI to a new station and/or elevation.
- The cyan triangles extend the selected tangent, hold its grade, and modify the grade of the opposite tangent to relocate the PVI.

- The middle or end circular grips lengthen or shorten the vertical curve without affecting the location of the PVI.

- When you move the cursor to the original location of the grip, the cursor snaps to that location.

**Transparent Commands**

AutoCAD Civil 3D has several transparent commands that can be extremely helpful when creating or editing a finished ground profile. They are listed below in the order shown in the Transparent Commands toolbar (from left to right):

- **Profile Station from Plan**: When creating or adjusting a PVI, this transparent command enables you to pick a point in plan view next to the base alignment. AutoCAD Civil 3D then calculates the station value automatically and prompts you for the elevation to use at that station.

- **Profile Station and (surface) Elevation from Plan**: This command is similar except that it enables you to determine elevation from a surface.

- **Profile Station and Elevation from COGO Point**: Enables you to determine station and elevation values for a PVI based on the location of a point object.

- **Profile Station Elevation**: By default, when adding a PVI you are prompted for a drawing X-,Y-location. If you would rather enter a station value and elevation, use this transparent command.

- **Profile Grade Station**: Enables you to locate a PVI based on a grade and an ending station value.

- **Profile Grade Length**: Enables you to locate a PVI based on a grade and tangent length.
Assigning Profile Band Elevations

Profile band elevations, such as those shown in a previous example, are assigned through Profile View Properties, Bands tab. When you create a profile view you should review the band settings and make sure each is assigned the correct profile in the Profile1 and Profile2 fields. AutoCAD Civil 3D does not make any assumptions about which profile to use in either field.

Using the styles supplied with the AutoCAD Civil 3D templates, the existing ground surface would be assigned the Profile1 field, and the finished ground profile would be assigned the Profile2 field.

Profile Segment Types

Profile segments created by layout (tangent lines, parabolas, and circular curves) can be created as fixed, free, or floating.

Profile Labels

Profiles have dynamic labels that are organized into two categories:

- Profile labels include labels for Major and Minor Stations, Horizontal Geometry Points, Profile Grade Breaks, Lines, Crest and Sag curves. These can be selected when the profile is created and managed later through right-clicking on a profile and selecting Edit Labels.
Profile View labels include a Station & Elevation label type, and a Depth label type. These are created through Annotate>Add Labels>Profile View>Add Profile View Labels and can be removed with the AutoCAD Erase command.

Practice - Working with Profiles, Part II

Task 1 – Create the FG Profile

1. Continue working with the drawing from the previous practice or open Site Design - Mod 4.3.dwg from the following folder:

   C:\<Installation Files>\Backup

   If used, after opening this file save it as Site Design.dwg in the folder listed below. Overwrite a previous drawing of the same name as needed.

   C:\<Installation Files>

2. Zoom to the Jeffries Ranch Rd profile view. In the Home tab, on the Create Design panel, select Profile – Profile Creation Tools. When prompted to select a profile view, select the Jeffries Ranch Rd profile view.

3. In the Create Profile dialog box that follows, enter the following and click OK.
4. Locate the Transparent Commands toolbar.

5. In the drop-down menu in the Layout toolbar, select **Draw Tangents**. AutoCAD Civil 3D prompts you for a start point – the location of the road’s first PVI.

6. In the Transparent Commands toolbar, click (Profile Station Elevation).

7. When prompted select any part of the Jeffries Ranch Rd profile view, enter the starting station of **10267.72** and starting elevation of **63.654**.
8. The routine then prompts you for another station and elevation value. If you would rather use another means of layout, such as setting a grade over a certain distance, press <Esc> once, then click 📊 (Profile Grade Station).

9. When prompted, enter -1.81 for slope (for -1.81%) and 10315 for station. Press <Esc> twice to end the layout command. Close the Profile Layout Tools.

10. At any time, you can continue to edit a profile by selecting it, right-clicking, and selecting Edit Profile Geometry. Select the FGCL - Jeffries Ranch Rd profile, right-click, and select Edit Profile Geometry to edit it now.

11. To continue adding PVIs, return to the Profile Layout toolbar and again select Draw Tangents. Start by snapping to the endpoint of the last segment you drew.

12. Once again, click 📊 (Profile Grade Station), select the Jeffries Ranch Rd profile view, and enter -0.29 for slope and 10450 for station. Press <Esc> to exit the Profile Station Grade option.
13. Sketch in two more PVIs by left clicking in the approximate locations as shown by circles below.

14. For the final PVI, click (Profile Station Elevation) and enter a station of 11299 and an elevation of 81.4. When done, press Esc> and <Enter> to finish the command.

15. Save the drawing.
Task 3 – Adjust the FG Profile

1. Select the profile you just drew and notice the grips that appear. Experiment with repositioning the PVI through the grips.

2. The PVIs do not yet have any vertical curves. In the Profile Layout Toolbar Draw Curves drop-down list, select **Free Vertical Curve (Parameter)**.

3. When prompted, pick the **first** and then **second** tangent in the profile, enter a **curve length** of **50**', and press <Enter>.

4. Continue adding vertical curves per the chart below.
5. Finish the command by pressing <Enter>.

6. Select the grips of the Grade Break and Curve label at the start of the profile and reposition them as shown below.

7. In the Profile Layout toolbar, click (Profile Grid View) and the Profile Entities Vista should appear in the Panorama.

8. In Profile Entities Vista, edit the PVI stations, elevations, and curve lengths to match those shown below. (Tip: Fix PVI stations first, set Grades Out to match, and set final PVI elevations and curve lengths.)

<table>
<thead>
<tr>
<th>Curve</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>50</td>
</tr>
<tr>
<td>2</td>
<td>125</td>
</tr>
<tr>
<td>3</td>
<td>200</td>
</tr>
<tr>
<td>4</td>
<td>150</td>
</tr>
</tbody>
</table>
9. Pan to the curve at station 106+30. Work with *Entity Based* data in the Profile Layout toolbar by selecting the following:

10. Click (Select Entity) and select the curve at station 106+30. The Profile Layout Parameters dialog box should be open and the curve’s current length should be 200.
11. In the Profile Layout Parameters dialog box, assign the curve to have a 
*K Value* of 28. The curve length might not update automatically in the 
parameters dialog box. Select the curve again to see the new 
parameters based on the K value. (You can design curves based on 
sight distances through this dialog box as well). Close this dialog box 
and Panorama.

12. Change the Profile Layout toolbar to PVI Based mode, as shown 
below, Close the toolbar and save your drawing.

![Profile Layout toolbar](image)

**Task 4 – Key in a Finished Ground Profile**

*Often profiles are defined on paper by other team members. The following 
is a simple and quick way to key one in from known PVI information.*

1. You will next create a finished ground profile for Michelle’s Way. 
   **Zoom** to Michelle’s Way Profile View. In the *Home* tab, on the Create 
   Design panel, select **Profile – Profile Creation Tools**.

2. When prompted for a profile view, select the Michelle’s Way profile 
   view.

3. In the Create Profile dialog box enter the following and click **OK**.
4. In the Profile Layout toolbar, click (Insert PVIs Tabular). For this command to be active you must be in PVI-based data mode ( ).

5. In the Insert PVIs dialog box, select the Parabolic curve type.

6. Enter the following values. You can press <Enter> to move between cells.
7. When done, click **OK** and close the toolbar. The profile should resemble the following:

![Profile Diagram]

**Note:** If you press <Enter> after giving the final Curve Length of 0, you will get an Invalid Input warning. This is because you started another row and provided no data. Click **OK**.

8. Save your drawing.

**Task 5 – Update Profile Bands**

1. The profile views are showing existing ground elevations in both the existing and proposed slots in the profile bands.
2. To update, select the Michelle’s Way profile view, right-click, and select **Profile View Properties**. In the **Bands** tab, assign **Profile2** to reference _FGCL – Michelle’s Way_. Click **OK** to close.

3. Repeat for the Jeffries Ranch Rd profile view.

4. Save your drawing.
Self Check: Profiles

1. Can you safely relocate profile views in AutoCAD Civil 3D using the AutoCAD Move command?

2. Name the three types of vertical curves.

3. Which grip do you use to move the PVI to a new station and/or elevation?

4. What do Profiles 1 and 2 annotate in profile bands?