CATIA V5 Workbook
Release 16

By:

Richard Cozzens

Southern Utah University

SDC

PUBLICATIONS

Schroff Development Corporation
www.schroff.com

www.schroff-europe.com

Visit the following websites to learn more about this book:

Lesson 2

Copyrighted
Material

Navigating the CATIA V5 Environment
Introduction

In this lesson the user will not complete any one project but will be
introduced to a lot of CATIA V5 tools and concepts. These tools and
concepts are the ones that are required to successfully navigate around
the CATIAV5 environment. Gaining a firm understanding of these tools
and concepts will be critical for successfully completing all the other
lessons in this workbook.
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Figure 2.1

Objectives

The main objective of this lesson is to present the necessary tools and concepts for the
user to successfully navigate the CATIA V5 environment. Some things in this lesson are
covered in general terms while others are covered in detail. The user is expected to learn
and understand each item as presented in the lesson. Tools and concepts that are briefly
introduced in this lesson lay the foundation for gaining deeper knowledge in later lessons.
Another purpose of the general introduction is to present the user with enough
information to promote self-discovery of CATIA V5. The following is a guide to what
the Review Questions and Practice Exercises will be testing for. You should know the
following:
-
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How to select any workbench.
How to tell which CATIA V5 document is current/active.
How the Specification Tree is linked to the geometry.
How to modify the Specification Tree.
What the compass is and how to use it.
The five different methods of selecting entities.
How to customize the Welcome to CATIA V5 window.
How to modify the CATIA V5 screens (maximize & minimize).
How to modify the plane and axis representation.
How to toggle the workbench toolbars on and off.
How to tear away toolbars and relocate them on the screen.
How to recognize when some workbench toolbars are hidden.
How to recognize when additional tools are available in a toolbar.
How to expand the toolbars with additional tools.
How and where the view manipulation tools are.
How to use the CATIA V5 Standard Toolbar and its tools.
Where the Power Input Mode is and how to use it.
Where and how to use CATIA V5s Prompt Zone.
The different areas of the CATIA V5 Screen.
Gain a general understanding of what CATIA V5 tools are available.
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CATIA V5 Standard Screen Layout

The following standard screen layout shows you where different tools and toolbars are
located. The numbers coordinate with the following pages where the tool label is bolded.
The tool label is followed by a brief explanation and in some cases, steps on how to use
and/or access the tool.

Figure 2.2
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The following list of menus is not meant to be a comprehensive definition of every tool
on the standard CATIA V5 screen. The purpose is to provide a quick reference and
explanation. If more detailed information is needed and/or required, refer to the CATIA
V5 Help menu and/or internet homepage.
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The Start Menu

The Start pull down menu gives you access to all of the CATIA V5 Workbenches. The
availability of the workbenches will depend on the CATIA V5 licenses configuration, the
one shown in Figure 2.3 is the Educational Package (ED2) offered through the HEAT
Program. The workbenches used in this workbook will be found under Mechanical
Design, Shape, and Digital Mockup Workbench Categories. If you select the arrow to
the right of the Workbench Category the workbenches organized within that category will
be displayed, reference Figure 2.3. Figure 2.3 shows the workbenches organized under
the Mechanical Design Category, the Part Design Workbench is the highlighted
workbench.
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The second section of the Start menu displays the active (open) CATIA V5 documents.
Figure 2.3 shows that Part1 and Part2 documents are open, Part2 is the active document.
The third section of the Start menu is the most recent active CATIA V5 documents. This
allows you to quickly open recently active documents. For example, with the options
shown in Figure 2.3 the Analysis1.CATAnalysis document could be opened by selecting
it from this menu rather than opening the browser window and browsing for it.
Figure 2.3
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The Current Active CATIA V5 Document

This area of the screen displays the name of the current active CATIA V5 document.
The active CATIA V5 document shown in Figure 2.2 is the default name
(Part1.CATPart) for a CATPart document. For a close up view with document circled
reference Figure 2.4. Displaying the name of the current
Figure 2.4
document is quite typical of MS Windows compatible software.

3

The Standard Windows Toolbar
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The Standard Windows toolbar contains your standard MS Windows pull down menus,
reference Figure 2.5. There are specific CATIA V5 tools found in the different pull
down menus. The tools you
Figure 2.5
will be required to use in this
workbook will be defined in the
lesson that they are used in.
File Menu
As shown in Figure 2.6, the
options under the File pull down
menu are very similar to most
other MS Windows programs.

Figure 2.6

Figure 2.7
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Edit Menu
As shown in Figure 2.7 the first
few options under the Edit pull
down menu is very similar to
most other MS Windows
programs. The first options are
also available on the Standard
Toolbar (reference item 16 in
Figure 2.2), such as the Undo
[Ctrl+Z], Repeat [Ctrl+Y],
Cut [Ctrl+X], Copy [Ctrl+C]
and Paste [Ctrl+V].
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Delete [Del]: This is one of
the numerous methods
CATIA V5 allows for you
to delete selected items.

Update [Ctrl+U]: The Update tool allows you to force the document to be updated.
There is a toggle in Tools>Options that allows CATIA V5 to update automatically.
When the Update tool is dimmed there is no update to be performed.
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Search [Crtl+F]: The Search tool allows you to search the document for almost any
type of variable. Selecting this tool brings up a Search window that allows you to
input specific parameters to help narrow the search.
Links: The Links tool allows you to view all documents that are linked to the current
document. This is a very useful tool when dealing with a multitude of linked
documents such as assemblies.
Properties [Alt+Enter]: The Properties tool allows you to view and/or modify the
properties of the selected element. This tool is also available contextually (selecting
the element and then selecting the right mouse button).
Scan or Define In Work Object: This tool allows you to review how the part in the
document was created, step-by-step. This is a powerful design and review tool that is
covered in depth in the Part Design Lesson.
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View Menu
Most of the tools in this pull down menu have to
functions dealing with the visualization of the CATIA V5
document. Many of the tools can be accessed from the
bottom toolbar, quick keys and contextually (right mouse
click). Figure 2.8 displays the tools available in the View
pull down menu. The following is a brief description of
each tool found in the View Pull Down Menu.

Figure 2.8

Toolbars: Toolbars allows you to toggle additional
toolbars on and off. If a particular tool gets closed
you can use this tool to turn it back on. This is
covered in more detail later in this lesson.
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Command List…: This tool brings up the Command
List window that lists all the CATIA V5 commands.
For example if you wanted to create a Point and could
not find the Point tool, you could go to View >
Command List and browse for the Point, select
Point and enter the appropriate values for X, Y and Z.
Geometry: This is a toggle tool that places the
geometry into hide/show (visible/not visible).
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Specification: This is a toggle tool that places the Specification Tree into hide/show.
Notice that there is also a quick key for this, F3.
Compass: This is a toggle tool that places the compass into hide/show. The compass
is area 5 in Figure 2.2.
Reset Compass: This tool allows you to reset the compass back to its original
location and orientation. For details, reference area 5 in Figure 2.2.
Tree Expansion: This tool allows you to expand the
Specification Tree automatically, at specified levels, or
contract the Specification Tree. Selecting this option
will bring up a window similar to what is shown in
Figure 2.9.

Figure 2.9
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Specification Overview: This tool allows you to zoom
in or out quickly on the Specification Tree.
Geometry Overview: This tool allows
you to zoom in or out quickly on the
geometry in the workspace. Selecting
this tool brings up the Overview on
geometry window as shown in Figure
2.10. Notice that the part showing in the
workspace is the same as what is shown
in the resizable window. As you change
the size and/or location of the resizable
window the geometry in the workspace
changes accordingly.

Figure 2.10

Resizable window
defining the
viewable geometry
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Fit All In: This tool allows you to
quickly zoom out so that all the geometry
is viewable on the screen. This tool is
also located on the bottom View Toolbar,
area 15 in Figure 2.2.

Zoom Area: This tool allows you to
quickly zoom in on a particular area of
geometry. Select the tool and then using
the mouse select the first corner of a
rectangle that encompasses the area you want to zoom in on. Drag the cursor to the
second point of the rectangle and release the mouse button. The workspace window
will update to the area you just defined.
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Zoom In Out: This tool allows you to quickly zoom out. This tool is also located on
the bottom View Toolbar. This is covered in detail in Lesson 4.
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Pan: This tool allows you to move the geometry around on the screen. It does not
change the location relative to the origin, just your view of the workspace. This tool
is also located on the bottom View Toolbar. This is covered in detail in Lesson 4.
Rotate: This tool allows you to rotate the part. This tool is also located on the
bottom View Toolbar. This is covered in detail in Lesson 4.
Modify: This tool provides some additional ways to
modify your views, some are duplicate methods, reference
Figure 2.11. Selecting the Modify option brings up a
window similar to the one shown in Figure 2.11. The first
four options will be covered in later lessons. Previous
View and Next View allow you to step back and forth
through the all the views still in memory. The Look At tool
allows you to create a rectangle around the area you want to
look at, similar to the Zoom Area tool. The Turn Head
tool allows you to pivot your view from the center of
rotation. This tool is hard to control and it is easy to loose
sight of your geometry, if you experience this select the Fit
All In. The Zoom In and Zoom Out tools are duplicates of
the tools already discussed. The Normal View tool allows
you to select a planner surface and CATIA V5 will rotate
your view normal (perpendicular) to the selected planner
surface.

Figure 2.11
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Named Views: Selecting this tool
will bring up a window similar to the
one shown in Figure 2.12. All the
default views are duplicates of views
provided in the View toolbar, area 15
in Figure 2.2. The real power of this
tool is the capability to create and save
your own custom view as shown in
Figure 2.12. To create your own
custom view zoom and orient the
geometry the way you want to save
the view. Select View > Named
Views, this will bring up the Named
Views Window. Select the Add
button. In the input window type the
name of your customized view. Select
the Apply button. Now any time you
want to jump to this view select View
> Named Views and select the view
you just created and named. CATIA
V5 will update to that view.

Copyrighted
Material
Figure 2.12

Copyrighted
Material

2.8

CATIA V5 Workbook

Figure 2.13

Copyrighted
Material
Figure 2.14

Copyrighted
Material

Render Style: Selecting the Render Style tool will
bring up a window similar to the one shown in Figure
2.13. The tools located in the first section of this
window are duplicates of the tools found in the View
toolbar, reference area 15 in Figure 2.2. Selecting the
Customize View will bring up a window similar to the
one shown in Figure 2.14. This particular tool allows
you to mix and match different view properties.
Review the options; apply them to some geometry so
you are comfortable with the different options. To
apply your customized view, select the OK button.
The geometry in the workspace can be represented using the Perspective view or the
Parallel view. The Perspective view shows the geometry as the human eye would
see it. The depth of the geometry reseeds back to a vanishing point. The Parallel
view shows the depth of the geometry true length.
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Navigation Mode: Selecting the Navigation Mode will
bring up a menu similar to the one shown in Figure 2.15.
These options will be covered in detail in later lessons.

Figure 2.15

Lighting: This tool allows you to modify the light
effect on the workspace. This tool will be covered in
more detail in the DMU Workbench Lessons.
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Depth Effect: This tool allows you to modify and visualize the geometry at different
thicknesses. This tool will be covered in more detail in the DMU Workbench
Lessons.
Ground: This tool allows you to create and modify ground representation for the
geometry in the workspace. This tool will be covered in more detail in the DMU
Workbench Lessons.
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Magnifier: This tool allows you to zoom into a specific area of the geometry. This
tool will be covered in more detail in the DMU Workbench Lessons.
Hide/Show: This tool is a duplicate of the Hide/Show tool in the View toolbar,
reference area 15 in Figure 2.2.
Full Screen: This tool allows the workspace to take the entire area of the screen, all
the tools and toolbars disappear. This option provides significantly more work area
for your geometry. To bring back all the toolbars, make sure your cursor is over an
open section of the workspace and select the right mouse
button. This will bring up a window similar to the one
Figure 2.16
shown in Figure 2.16. All you have to do is select the check
box and CATIA V5 will toggle the tools and toolbars back
onto the screen.
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Insert Menu
Most of the Insert tools are alternative tools to the
ones found in the workbench toolbars, such as
Sketched-Based Features and all the other options
listed in the same section of the pull down menu.
The other tools are alternative tools to ones found in
the bottom toolbar such as Axis System, Knowledge
Templates and the other options found in the last
section of the pull down menu.

Figure 2.17
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Body: This tool adds an additional Body onto
the Specification Tree. Compare Figure 2.25 with
one body and Figure 2.26 with two body
branches. This tool is covered in more detail in
the Part Design and Assembly Design
Workbench Lessons.
Annotations: This tool allows you to create 3D
annotations (comments and/or notes). You can
attach the notes to a specific entity. The
annotations can be hidden and edited. You can
make the annotation stay normal to the screen, so
you can read it as you rotate the part. You can
also link the annotation to a URL. This is a
helpful design review tool.
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Constraints: This tool allows you to create 3D constraints. If sketch-based
constraints control the actual profile the 3D constraint will show up as a reference
constraint (dimension). A reference constraint has a set of brackets around it ( ).
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Sketcher: This tool allows you to create a sketch. It is a duplicate of the Sketcher tool
found on the side toolbar. This tool is covered in more detail in the Sketcher
Workbench Lesson.
Axis System: This tool is a duplicate of the Axis System tool found in the Tools
Toolbar in the bottom toolbar. This tool is covered in more detail in the Surface
Workbench Lesson.
Sketch-Based Features: This toolbar is a duplicate of the Sketched-Based Features
found in the Part Design Workbench. This tool is covered in more detail in the
Sketch and Part Design Workbench Lessons.
Dress-Up Features: This toolbar is a duplicate of the toolbar found in the Part
Design Workbench. This tool is covered in more detail in the Part Design
Workbench Lessons.

Copyrighted
Material

Surface-Based Features: This toolbar is a duplicate of the toolbar found in the
Surfacing Workbenches. This tool is covered in more detail in the Wireframe and
Surface Design Workbench Lessons.
Transformation Features: This toolbar is a duplicate of the toolbar found in the
Part Design Workbench. This tool is covered in more detail in the Part Design
Workbench Lessons.
Boolean Operations: This toolbar does not by default
show up on any workbenches used in this workbook.
When a Boolean Operation between two partbodies is
required you can use this particular method of accessing
the Boolean Operations. Another method is to customize
the Part Design Workbench so the Boolean Operation
toolbar is included. This customization method is covered
in a later lesson. The tools in the Boolean Operation
Toolbar are shown in Figure 2.18.

Figure 2.18
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Knowledge Templates: This toolbar is a duplicate of the
Product Knowledge Template toolbar located in the
bottom toolbar, area 13 in Figure 2.2.
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Instantiate from Document…: This toolbar is a duplicate of the Product
Knowledge Template toolbar located in the bottom toolbar, area 13 in Figure 2.2.
Instantiate from Selection…: This toolbar is a duplicate of the Product Knowledge
Template toolbar located in the bottom toolbar, area 13 in Figure 2.2.
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Tools Menu
The Tools Menu contains some special tools not
found anywhere else in the CATIA V5 configuration.
The Customize tool is one that you will want to get
very familiar with. Note: The tools available in the
Tools Menu depend upon what Workbench is active.

Figure 2.19

Formula: This toolbar is a duplicate of the
Knowledge toolbar located in the bottom toolbar,
area 18 in Figure 2.2.
Image: This toolbar allows you to capture
images as well as videos. The toolbar also
provides an image management tool so you can
organize your album.
Figure 2.20
Reference Figure 2.20.
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Macro: The tools in this pull
down menu add limitless
possibilities for CATIA V5
users. You can create
macros similar to most other MS Windows
software. You can also convert the macro to
Visual Basic Language where you can start to
modify and customize the program. One of the
more advanced capabilities is to integrate the
customized program into your own tool.

Figure 2.21
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Utility…: This tool allows you to batch and manage numerous types of processes.
For an example of the types of batch processes available reference Figure 2.22.
Figure 2.22
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Show: This tool seems very similar to the
Hide/Show and Swap Visible Space tools located in
the View Toolbar at the bottom of the screen (area
15 in Figure 2.2). The difference with this tool is
that it allows you to show different types of entities.
It is a filtering tool. If you wanted to show just
points you could filter everything else out. Figure
2.23 displays the different types of entities you can
filter. The bottom section of the toolbar allows you
to customize the entity selection.

Figure 2.23

Hide: This tool is very similar to the Show tool
except that it allows you to hide the selected entities.
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Figure 2.24

In Work Object: This tool is a duplicate of the Scan or Define In Work Object
found in the Edit pull down menu. Using the Player tools shown in Figure 2.24 you
can step through the entire creation of the part. This is a great tool for reviewing the
design process.
Figure 2.25
Parameterization Analysis:
This is another powerful
document analysis tool. The Hide
tool allowed you to visualize
different type of entities; this tool
allows you to list all the different
type of entities. As the designer
you may know how many
sketches the document consists of
but, as a manager or design
review member or someone that is
revising an existing design, you
may not know. This tool provides
you a method of easily and
quickly obtaining that
information. The analyzed
entities can be much more
complicated than a simple sketch.
Figure 2.25 displays the Parameterization Analysis window with the many different
types of entities to select from (the pull down menu). Figure 2.25 shows that the
Sketch entity is selected. The open area of the window displays the Sketches that
were found in the example CATPart document.
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Figure 2.26
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Parent/Childern…: This tool is another powerful tool that can help you analyze a
part and find how all the features fit together. To use this tool you need to select a
branch of the Specification Tree otherwise the tool will be dimmed (un-selectable).
To get the results shown in Figure 2.26 the following steps were completed.
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1. Select Sketch1 from the example document.
2. Select Tools from the pull down menu.

3. Select the Parents/Children option. This will bring up the Parents and
Children window as shown in Figure 2.26. The window displays the selected
entity and all other entities that have either a parent or child relationship with
the selected entity (in this case Sketch1).

Customize: As stated by the name of the tool it allows you to customize CATIA V5
to user preferences. This tool allows you to customize the Start Menu, Workbenches,
Toolbars, Commands and additional Options. Area 7 of Figure 2.2 covers the Start
Menu in detail. Additional detail information will be presented in the following
lessons.
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Options…: Of all the tools covered in this pull down menu this one is the one that
cannot be avoided. The most basic of customization such as modifying Units to the
most advanced modifications are made using this toolbar. Some functions of this
toolbar have already been covered. Every lesson refers back to this tool to some
degree; the lessons will cover each individual function in more detail and apply it
directly to a particular problem and/or part.
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Standards…: This tool Figure 2.27
makes standardizing your
CATIA V5 environment
much easier than previous
releases. This tool is
particularly helpful when
defining your drafting
standards. Figure 2.27
previews some of the
standard drafting options.
This tool will be covered
in more detail in the
Drafting Workbench
Lessons.
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Conferencing: This tool allows
you to connect to conference calls
via Net meeting all within CATIA
V5, reference Figure 2.28.

Figure 2.28

Publication: This tool allows you to publish partbodies entities. Figure 2.29 is an
example of Sketch.1 being published and exported. Notice that there is a new
Publication Branch added to Specification Tree. When Sketch.1 is selected Sketch.1
in the Publication Branch highlights also.
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Figure 2.29
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Window
This Pull Down Menu is similar to the typical MS
Windows applications. The bottom section displays how
many documents are open; in Figure 2.30 there is only
one. The first section shows the different options for
displaying the different documents (when there is more
than one).

Figure 2.30
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Help
This tool is also similar to most MS Windows
applications. You can find out License and Release
information as well as accessing CATIA V5 Complete
Content, Index and search screen. You also have direct
access to CATIA User Companion. One of the most
helpful tools is the What’s This? tool. All you have to
do is select this tool and then the item you have a
question about and CATIA V5 will bring up an
information window about the selected item and a link
to the help files if one exists.

Figure 2.31
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The Specification Tree

The Specification Tree contains the history of tools
and processes used to create a part. For example, you
can look at a completed part and see that there were
fillets and holes applied to it. At what point in the part
creation were the fillets and holes added? Are there
redundant processes and extra elements? Can the
process for part creation be improved? Looking at the
resulting part will not answer any of these questions.
The Specification Tree on the other hand has all of
this information. The Specification Tree contains the
entire history of the part creation. For a complex part,
the Specification Tree could get large.

Figure 2.32
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Select the Tools, Options, General, Display, Tree option to specify what you want the
Specification Tree to show and how you want it to appear. The branches of the
Specification Tree can be expanded and contracted by selecting the – and + symbols
located on each branch. You can Zoom In and Pan the Specification Tree the same
way you would a part. You must double click on a Specification Tree branch to make
the workspace go dim. Once the workspace is dimmed (under intensified), all of the
screen manipulation tools will apply to the Specification Tree instead of the workspace.
This means you can move and zoom the Specification Tree as you do the part in the
workspace. Double clicking a Specification Tree branch will bring the part back to
normal (the active workspace). The F3 key will hide the Specification Tree from view
(a toggle key). CATIA V5 allows you to make modifications to the part by using the part
itself and/or by using the Specification Tree. The Specification Tree is used in all the
lessons. The Specification Tree is a very powerful tool, but you must know how to use
it to your advantage. The Specification Tree shown in this section represents most of the
branches and applications used in this workbook. The presentation of the tree will vary
depending on installation and customization. The tree shown below was created with
standard installation. The tree was customized to show all branches such as
Relationships, Formulas and Applications using the Tools, Options window.
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Figure 2.33
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Figure 2.33 displays a default Specification Tree, the Specification Tree has no geometry
added to it. Figure 2.34 displays all the geometrical elements that make up the part
shown in the workspace. Notice the Hole.2 branch of the Specification Tree is
highlighted, Hole.2 in the part is also highlighted. CATIA V5 allows you to select the
elements using the Specification tree or the actual geometry in the workspace.
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Figure 2.34
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You can control how and what is displayed in the Specification Tree by completing the
following steps:
2.1 Select Tools > Options. This will bring up the Options window.
2.2 Select the Display branch of the tree.
2.3 Select the Tree Appearance tab. This will bring up the window similar to
the one shown in Figure 2.34.
2.4 Make sure your options match the options selected in Figure 2.34.
2.5 Select the Tree Manipulation tab. This will bring up the window similar to
the one shown in Figure 2.35.
Figure 2.35
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2.8
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Make sure your options match the options selected in Figure 2.35.
Select the Parameters and Measure branch of the Options window.
Select the Knowledge tab.
Make sure your options match the options shown in Figure 2.36, particularly
the Parameter Tree View section.
Figure 2.36
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2.10 Expand the Infrastructure branch of the Options Tree by selecting the + sign.
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2.11 Select the Part Infrastructure branch of the tree.
2.12 Select the Display Tab.
2.13 Make sure all the options are selected under the Display In Specification
Tree section as shown in Figure 2.37.

Figure 2.37
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The selections described in the previous steps are the options that control what kind of
information is displayed in the Specification Tree and how it is displayed. You are
encouraged to try the different options, develop your own preferences. As you go
through the lessons remember these options and revise them as required and/or needed.
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Product1 created by entering the Assembly Design
Workbench.
Select Insert then Insert New Component.
Select Insert then New Product.
Select Insert then New Part.

Part1 created by inserting New Part; double clicking will
take you to the Part Design Workbench.
Planes that define the axis.
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Formula that drives a Constraint in Relation
branch.

The profile of Sketch.1 extruded (using the Pad tool).
The sketched profile (sketched based features). Sketch.1
branch is expanded out in Figure 2.14.
Material being applied to Part1.

Select Insert, Existing Component. This existing
component is a translated part using the Step (stp) translator.

Copyrighted
Material
Relations branch contains Design Table.1.

Design Table.1 is an external Excel Spread Sheet linked to
Product1 (the assembly).
Applications branch contains entities created in the DMU
Navigator and Rendering Workbench such as Simulations,
Lights, and Environments.
Turntable1 is a particular type of Simulation. Simulation
allows you to move components within the assembly (animate).
Allows you to control the lighting on Product1 (the assembly).
Allows you to create a specific look for rendering Product1.
The specific look is an environment.
Replay allows you to play the created simulation using some
player controls. You can start the player by double clicking
on this branch of the Specification Tree. You must have a
simulation to play.

Copyrighted
Material

Navigating the CATIA V5 Environment

2.21

Copyrighted
Material

Pad.1 contains the extrusion information. To modify the Pad
thickness you would have to double click on this branch.
Sketch.1 branch expanded out (from the previous page).
Axis for the sketch.

A sketch is only two-dimensional, so you have an H (Horizontal)
axis or direction and a V (Vertical) axis or direction.

Geometrical entities that define the sketch profile. These entities
can be modified in the Sketcher Workbench only (the workbench
they were created in).
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Dimensional constraints applied to the sketch entities. Length.1
constraint drives the formula shown in the previous page.
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The Compass

This tool allows you to modify the location and
orientation of a part relative to the XYZ coordinates
and/or relative to other parts if they are in an
assembly. The application of this tool is described
in the several of the lessons. You can place the
cursor over the center point of the axis and drag the
compass and drop it on a surface. Once the compass
is placed on a surface it will turn green. You can
then use the cursor to manipulate the orientation of
the part geometry by selecting the axis or direction
on the compass that you want the geometry
modified in. To restore the location and orientation
of the compass select View > Reset compass.

6
3

Figure 2.39

Select and
hold to rotate
geometry
about the Z
axis.

Select and hold to
move the compass
onto geometry.
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The Select Tool and Toolbar

This tool allows you to select entities in the workspace and
Specification Tree as well as the other areas of the CATIA V5
screen shown in Figure 2.2. The default selector is the Select
Arrow, which allows single point and left click selections. If
you select the small arrow to the right of the icon, it will reveal
the other selection tools, they are shown below.

Figure 2.40
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The Select Tool

Toolbar Tool Name Tool Definition
Select

Selection
Trap

Intersecting
Trap

This is the default tool, point and click (left mouse button)
to select the desired entity. Multiple entity selection can be
done by holding down the Ctrl key while selecting.
This allows you to draw a box around the entities that you
want to select. The box is exclusive to entities that intersect
with the selection box. This is a quick and easy multi-select
tool.
This allows you to draw a box around the entities, but will
also select the entities that are intersected with the box. The
selection box is inclusive.
This selection is similar to the box selection trap, but allows
you to sketch a more defined area of inclusion and exclusion
of entities. This selection tool is quick, and allows you to be
more exclusive in the multi-selection process.
This selection tool allows you to paint a line across the
screen and any entity that the paint stroke crosses is
selected.
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Polygon
Trap

Paint Stroke
Selection
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The Current Workbench

The side bar will be filled with toolbars and tools associated with the
current workbench. As you select a different workbench you will
notice the toolbars and tools will change (reference area 10 in Figure
2.2). Figure 2.41 shows the Part Design Workbench. This is
especially critical when you have several windows open with
different workbenches. If you have them displayed on a split screen,
the active window will be the one with the blue border. You can
customize CATIA V5 so that all
Figure 2.42
your favorite or most used
workbenches are available by
selecting the current workbench.
For example, Figure 2.41 is the
current workbench but you want to
switch to the Assembly design
Workbench. You can select the
current Part Design Workbench icon
as shown in Figure 2.41. Selecting
the tool will bring up a Welcome to
CATIA V5 window similar to what
is shown in Figure 2.42. The
workbenches that show up in the
Welcome to CATIA V5 Window
would be the ones you selected
when customizing this window. To
customize your Welcome to CATIA
V5 Window complete the following
Steps.

Figure 2.41
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2.7.1

2.7.2

2.7.3
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From the Pull Down Menu (reference area 3 in Figure 2.2) select the Tools >
Customize option. This will bring up a window similar to the one shown in
Figure 2.43.
Select the Start Menu tab. Notice the list of workbenches listed in the left
column, they are listed as available. With your mouse scroll down through the list
and find the Assembly Design Workbench, select it, so it is highlighted.
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With the Assembly Design Workbench selected, select the arrow pointing to the
right
that is located between the columns. Selecting this arrow will place
the Assembly Design Workbench in the Favorites column. Every thing that is
placed in the Favorites column will show up in the Welcome to CATIA V5
Window every time the current workbench is selected.

2.24
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Continue browsing through the workbenches and select the workbenches that are
listed as favorites in Figure 2.43. Figures 2.42 and 2.43 show the workbenches
that will be used in following lessons.

Note: You can use the MS Windows function to multi select the workbenches. Hold the
Ctrl key down while selecting individual workbenches or hold the Shift key
down to select a continuous selection of workbenches.
2.7.5

You can also create quick keys; CATIAV5 refers to them as Accelerators.
Highlight the workbench you want to create a quick key for and type in the keys
you want to be used for the quick key. Figure 2.43 shows that the quick key for
starting the Part Design Workbench is Ctrl+W. Creating quick keys is not
required for this lesson, but the option is there if you want to use it.

2.7.6

Once you have selected all the workbenches shown in figure 2.42 select the Close
key.
Figure 2.43
Now select the
current
workbench and
verify the
workbenches
you selected
show up in the
Welcome to
CATIA V5
Window.

2.7.7

2.7.8
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Now you can
select any of the
workbenches in
the window to
make it the
active
workbench.

Note: Under the Accelerator box there are keys you can select, this can be used to help
you, if you don’t know the exact syntax. You can create the quick keys by
browsing through the different options.
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Note: Using the Welcome to CATIA V5 window to select the Part Design workbench as
shown in Figure 2.43 is an alternative method to selecting the Start > Mechanical
Design > Part Design (reference area 1 Figure 2.2). Remember this method
allows you to select all the workbenches that are included in the license package.
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Window Maximize and Minimize

These options are the same as most other MS Windows programs.
The top row of tools control CATIA V5 Program as a whole. The
sign will minimize the program window. The
(last tool)
will close the program. The tools in the second row control the
active window within CATIA V5. If you have several CATIA V5
documents open you can minimize one or each of the windows
within the CATIA V5 program. You can resize
each of the
windows. The last tool
allows you to close an individual
window.
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Plane Representation (xy, yz and xz).

The intersecting planes represent the 0,0,0 point of the
workspace. Each plane is graphically represented in the
workspace and also in the Specification Tree as shown in
Figure 2.45. If you select the YZ plane from the
Specification Tree the YZ plane in the workspace will also
highlight, as shown in Figure 2.45. If you would rather have
the 0,0,0 point be represented as an axis as shown in Figure
2.46 you can customize the workspace representation by
completing the following steps.
2.9.1

2.9.2

Figure 2.44

Figure 2.45
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Select the Tools > Options from the pull down
menu (reference area 2 in Figure 2.2). This will
bring up the Options window.

Figure 2.46

Expand the Infrastructure branch of the Options
Tree by double clicking on the + sign at the
beginning of the branch.

2.9.3

Select the Part Infrastructure branch.

2.9.4

Select the Part Document tab. This will bring up the options shown in Figure
2.47.

2.9.5
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Under the new part section select the box to “Create an Axis System when
creating a new part”.
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Figure 2.47
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2.9.6

Select OK to complete the customization.

2.9.7

Create a new CATIA V5 Document. The new document will have an axis similar
to the one shown in Figure 2.19 in place of just the three planes shown in Figure
2.18.
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The Current Workbench Tools and Toolbars

This side bar will be filled with toolbars and tools
associated with the current workbench. If you select
a different workbench the tools and toolbars will
update to the newly selected workbench. Each
lesson covers a specific workbench, the tools and
toolbars specific to that workbench will be covered
in that particular lesson. The following is a list of
things you can do with the tools and toolbars.

Figure 2.48

Select this bar and
drag the toolbar to
the new location.
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 All the toolbars are tear away toolbars
meaning that you can select the top bar of
each tool as shown in figure 2.48 and drag it
to a new location.

Select this down
arrow to view the
additional tools as
shown in Figure
2.25
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 If you do not know the name of the toolbar you
can hold the cursor over the tool and the tool
name will be displayed as shown in Figure 2.49.

Figure 2.49
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 To close the toolbar you can select the red
the top of the toolbar.

at

 To re-open the toolbar you can drag the cursor
over the side toolbar area and left mouse click.
This will bring up the contextual window shown in
figure 2.50. Notice some tools are already selected
and some are not, each tool can be toggled on or off
just by selecting it. Figure 2.50 only represents a few
of the 35+ toolbars.

Hold the cursor
over the tool and
the tool name
will be displayed
as shown.

Figure 2.50
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 Another method of re-opening
or adding a toolbar that does not
currently exist in a particular
workbench is to select View >
Toolbars. This brings up the
same window as shown in
Figure 2.51. From this window
you can toggle the tools on or
off.

Figure 2.51
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 If there is a small arrow pointing down to the bottom right of a tool as indicated
in Figure 2.53 this indicates that there are additional tools available. To view the
additional tools select the down arrow. This will expand the toolbar as shown in
Figure 2.52. You can select the tool that you require; the selected tool will
become the default tool. The expanded toolbar can be torn away as its own standalone toolbar by selecting the small bar and dragging it away. The result will be
similar to what is shown in Figure 2.53.
Figure 2.52

Figure 2.53
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Select this small
bar and drag the
toolbar away.
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 You can create your own customized workbench with your own favorite tools.
To complete this you would select the Tools > Customize > Toolbars options.
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 Sometimes there are too many tools and toolbars to display on the side bar at one
time. CATIA V5 gives you an indication of this when you see the small double
chevrons at the bottom of the side bar as shown in Figure 2.54. To make all tools
visible select the small bar as shown in Figure 2.54 and drag it to an open area in
the workspace. If the double chevron symbols are still there that means you still
have additional toolbars, continue the process until the symbol disappears.

Select this bar and drag it
into the open workspace
to visualize the additional
tools.
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Figure 2.54

The double chevron
symbol indicates there
are additional tools
below this bottom bar.
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Axis Orientation

This tool shows the orientation of the Axis within the workspace. The orientation will
change as you rotate the part or workspace around.
Figure 2.55

Axis
Orientation

Copyrighted
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The Tools Toolbar

This toolbar changes depending on which workbench
you are in. The three tools that are consistently in this
toolbar are listed below.

Toolbar

Tool Name

Tool Definition

Update All

This tool will be under intensified unless there is an
entity in the document that requires updating. If the
tool is colored (not under intensified) it is signifying
that some entity requires updating. Selecting the tool
will update all of the entities. This tool is used most
when revisions/changes are made to existing constraints
whether it is part design changes and/or assembly
changes. If you make a change and the part/assembly
does not reflect the change, check this tool, it may
require you to select it to force an update.
This tool allows you to create multiple local axis
systems. The Surfacing Lesson gives detailed
instructions on how to create and orient new axis
systems.
This tool only works if you have previously defined a
tolerance to the entity. When tolerances have been
applied this tool will compute the actual (mean)
dimensions of the entity being reviewed.
This tool deactivates the history mode. The entities
used to create it will not be linked. The tool is a toggle
tool; if you select it you must unselect it to turn it off.
This tool gives you the option to display only the
current operated solid.

Copyrighted
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Axis System

Mean
Dimensions

Copyrighted
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Create Datum

Only Current
Operated
Solid
Open catalog

This tool allows access to the user-defined catalog.
Reference the Help menu for detailed instruction and
application.
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The Product Knowledge Template Toolbar

This toolbar allows you to create Power Copies and document the
places the Power copies are instantiated.

Toolbar

Tool Name

Tool Definition

Power Copy
Creation

This tool allows you to create Power Copies. The
Power Copies can be applied to similar parts or parts
with similar features. The Power Copies can also be
saved to the Catalog.
This tool allows you apply a previously saved Power
Copy.

Instantiate
From
Document
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The Analysis Toolbar

This is another toolbar that is dependant on the active workbench.

Toolbar Tool Name

Tool Definition

Copyrighted
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Draft Analysis

Curvature
Analysis

Tap - Thread
Analysis

This tool allows you to analyze draft angles and
distances. This tool is particularly helpful when the
angles and distances are too small to visually inspect.
This tool allows you to analyze the curvature of a
surface. This is particularly helpful when you have a
max and min curvature radius.
This tool provides the ability to analyze the current part
for thread and tap information.
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The View Toolbar

This toolbar contains CATIA V5
specific functions. This
workbook will have you use
most of them in one lesson or
another. Most of the tools
apply to all of the workbenches.

Toolbar Tool Name
Fly mode

Tool Definition
Sets the fly mode. This is a very powerful and fun tool.
Reference lessons covering the DMU Workbenches on
how to use this tool.
This tool will show the extent of all the graphics
currently on the screen. It is a quick way to see what
elements are on the screen and where they are in
relationship to one another.
This tool allows you to move the part around on the
screen. The part does not change its location in the
XYZ coordinate system, only in relationship to the
screen. Every time you want to Pan the part you must
select this tool first, unless you have a three-button
mouse. Quick Key: With a three-button mouse you
can press the middle mouse button down and drag the
part to the desired location on the screen.
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Fit All In

Pan

Copyrighted
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Rotate:

This tool allows you to rotate the part in threedimensional space. It will place a representation of a
space ball (sphere) in the center of the screen. There is
a three-dimensional X on the space ball, you drag the X
to where you want on the space ball and the part will
rotate accordingly. This tool is critical to part
manipulation. It is important that you get the hang of
rotating the part to the orientation you want. This tool
must be selected every time you want to rotate the part.
This process is explained and shown step-by-step in
Lesson 4, Step 7. Quick Key: A quicker method is
using the mouse. Press the middle mouse button first,
while holding the middle button down, press the left
mouse button and drag the mouse around on the sphere.
This brings up the space ball (sphere). Another method
is to press the CTRL key while pressing the middle
mouse button and dragging the mouse around the
screen.

Copyrighted
Material

2.32

CATIA V5 Workbook

Copyrighted
Material

Zoom In

Zoom Out

This is similar to other graphics programs. This allows
you to get a closer look at finer detail. Quick Key:
Press the middle mouse button, hold it down as you press
the left mouse button and release it. Now use the mouse
to drag the cursor up the screen and the part will Zoom
In. Using the mouse to Zoom In is a much smoother
zooming method; you have more control.
This is similar to other graphics programs. This allows
you to get the big picture, making the part smaller.
Quick Key: Press the middle mouse button, hold it
down as you press the left mouse button and release it.
Now drag the mouse down the screen and the part will
Zoom Out.
This tool allows you to view a particular plane/surface in
a true length view. You specify the plane/surface and
CATIA V5 will rotate the plane/surface 90 degrees to
your screen view. This will make the geometry on that
plane/surface true length. This is a very useful tool.
You could try to rotate a plane using the space ball so it
is normal to your point of view, but you could only get it
“close”. This tool gets it “exact”. This tool can also be
used to flip the direction in which you view a sketch. If
in any of the lessons you go into the Sketcher
Workbench and your view is from the wrong direction
use this tool to flip your view 180 degrees. It will switch
your point of view from looking down on a part, to
looking up from the bottom.
This tool allows you to select any entity or multiple
entities and place them in “no show space”. This
removes the selected entity/entities from the “working
space”. Sometimes there are entities that you want to
keep for future references but do not want them visually
in the way. You can pull the entities back into the
“working space” when you are ready for them.
This tool works hand in hand with the Hide/Show tool.
Selecting this tool will take you out of the “working
space” window and into the “no show space”. To pull an
element from the “no show space” you would select the
Swap Visible Space tool icon. This would show the “no
show space”. You could select the entity you want back
in the “working space”, and then select the Hide/Show
tool icon. This would take the entity back to the
“working space”. You would then need to select the
Swap Visible Space tool icon to get back to the
“working space”. This can be confusing; try bringing a
part back and forth until you get control of the two tools.
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Normal View
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Hide/Show

Swap Visible
Space
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Quick View Mode:

This tool icon has the arrow to the bottom right of
it, as explained in toolbar 5. The tool options are
all of the orthographic view options. NOTE: the
view projection is dependant on the plane the body
was created on.

Isometric View

Front View
Back View

Select this tool and CATIA V5 will rotate your part to
an isometric view.
Select this tool and CATIA V5 will rotate your part to a
front view.
Select this tool and CATIA V5 will rotate your part to a
back view.
Select this tool and CATIA V5 will rotate your part to a
left view.
Select this tool and CATIA V5 will rotate your part to a
right view.
Select this tool and CATIA V5 will rotate your part to a
top view.
Select this tool and CATIA V5 will rotate your part to a
bottom view.
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Left View

Right View
Top View

Bottom View

View Mode:

This tool icon has the arrow to the bottom right of it, as
explained in toolbar 5. There are six different options
associated with this tool; they are listed below.
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Wireframe
(NHR)

Dynamic
Hidden Line
Removal

Shading (SHD)

This shows the part as a wireframe, no solid, no
shading. The (NHR) means “No Hidden Line
Removal”. With no hidden line removed, all edges of
the part will be visible at all times. This can be
confusing at times; you could lose track of which is the
front side and which is the back side of a part.
This is very similar to the Hidden Line Removal tool
except as you rotate the part, the hidden line removal is
real time, where as the Hidden Line Removal tool will
only update the hidden line removal after the rotating
process is complete.
This tool shows the solid shaded without any edge line
representation.
This tool allows you to control how your part is going
to be represented, how it looks on the screen. This tool
shows the solid shaded and with the edge line
representation. The majority of the graphics in this
workbook are represented in this format.
This tool shows the solid shaded and the edge line
hidden.
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Shading With
Edges

Shading With
Edges And
Hidden Edges:
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Applies
Customized
View
Parameters:
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This tool will bring up a “Custom View Modes”
window that gives you many different parameters to
choose from. If you apply material to your solid you
will not see the material represented unless you select
the material option in the “Custom View Modes”
window.

The CATIA V5 Standard Toolbar

This toolbar has nine tools in it,
some offer an alternative method of
accomplishing a similar task found in
the Standard MS Windows toolbar.
The tools are listed below with a brief
description.
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Toolbar Tool Name

Tool Definition

New

Creates a new file (document).

Open

Opens an existing file (document).

Save

Saves the active file (document).

Quick Print

Prints the active file (document).
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Cut

Copy

Paste

Undo

Redo

Deletes the selected element and/or elements. This tool
has the Windows NT functionality of select, drag and
drop.
Another method of copying a selected element and/or
elements. The tool places the copied element and/or
elements onto the Windows NT clipboard.
Another method of pasting an element and/or elements
from the Windows NT clip board.
The greatest OOPS tool developed since the invention
of the computer! This tool allows you to step
backwards one mistake (function) at a time!
Make that a double OOPS! This tool allows you to
undo your undo! If your last operations weren’t so bad
and you don’t remember all of the parameters you
entered, this tool is for you.
Direct link to the help file. Select the item you have a
question about then select this tool. CATIAV5 will
search the help files for information on the selected
item.
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What’s This?
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The Prompt Zone

Figure 2.56

The Prompt Zone (bottom left of the screen) prompts the
user for the information and/or input required to
complete the process. A good rule of thumb, when in
doubt read the Prompt!
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Prompts the user for the
information required to
complete the process.

The Knowledge Toolbar
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This toolbar allows you to use formulas and spread
sheets to parameterize your sketches, parts and
assemblies.

Toolbar Tool Name

Tool Definition

Formula

This tool allows you to use a formula to drive
parameters.

Comment &
URLs

This tool provides access to the Comment and URLs
editor.

Check Analysis
Toolbox

This tool allows the user to define design standards and
check parts against the standards.

Design Table

This tool allows you to use data from an existing spread
sheet to drive assigned parameters within a design

Law

This tool allows you access the law editor.

Knowledge
Inspector

This tool allows you to preview a design change prior
to committing to the change. This is an advanced tool.

Lock Selected
Parameters

This tool allows the user to lock selected parameters.

Unlock
Selected
Parameters
Equivalent
Dimensions
Head

This tool allows the user to unlock selected parameters.
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This tool allows the user to make two parameters equal
to each other. This tool applies to most dimensional
(length) type parameters.

2.36
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The Apply Material Tool

This tool allows you to apply a material to your solid. Applying a material will give it
the properties of the material such as the density so CATIA V5 can calculate weight,
volume and other part analysis information. Applying material also gives the solid the
texture and color of the selected material. CATIA V5 has a library of material. The use
of this tool is covered in the Part Design Lesson. Remember, to see the material applied
to the solid you must select Apply Material in the Applies Customized View
Parameters.
CATIA V5 allows you to create your own material using the Material Library
Workbench found in the Infrastructure Workbench category.
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The Measure Tool

There are three analysis type tools; they are listed below.

Toolbar

Tool Name

Tool Definition

This tool allows you to measure the distance between
two different entities. You can measure the distance
between surfaces, planes, lines, points etc. Select the
Measure Between tool and then the two entities. This
will bring up the Measure Between window. This
window has more information than most designers
would want. In most cases, the dimension created
between the two selected entities is enough information.
Measure Item This tool is very similar to the Measure Between tool
except that it measures the length of an individual
entity. Select the Measure Item tool and then select
the item to be measured. This will bring up the
Measure Item window. As in 11.1, in most cases, the
dimension created on the selected entity is all that is
needed.
This measures the physical attributes of the selected
Measure
solid such as volume, mass, centroid, etc.
Inertia

Measure
Between
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The Power Input Mode

This input window is for more advanced uses. You will notice as you select a tool, the
tool command will appear in this window. In advanced uses, this window can be used
similarly to quick keys and scripting. For detailed information reference the Help menu.
This tool is not used in this workbook.
Figure 2.58
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The Double Chevron Symbols
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When the workbench toolbars show these arrows at the bottom or end of the toolbar, it
signifies there are additional tools belonging to that particular workbench. CATIA V5
gives you an indication of this when you see the small double chevrons at the bottom of
the side bar as shown in Figure 2.59. To make all tools and toolbars visible select the
small bar as shown in Figure 2.59 and drag it to an open area in the workspace. If the
double chevron symbols are still there that means you still have additional toolbars,
continue the process until the symbol disappears.
Figure 2.59
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Select this bar and drag it
into the open workspace
to visualize the additional
tools.

The double chevron
symbol indicates there
are additional tools
below this bottom bar.

Copyrighted
Material

Summary

As stated in the Introduction there is not a lot of action required in this lesson but that
does not dismiss its importance. The better these tools and concepts are remembered the
more successful the user will be in attempting the remaining lessons. Remember all the
other lessons are built around the knowledge presented in this lesson.
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Review Questions

After completing this lesson you should be able to answer the questions and explain the
concepts listed below.
1. What does the double chevron at the bottom of the side
toolbar indicate?

2. T or F The Apply Material Tool
applies the
material properties to the specific solid so the weight of the
solid can be computed.
3.
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What is the difference between the Measure Between
Measure Item

Tool and

Tool?

4. T or F You can select the XY Plane from the graphics window or the
Specification Tree.

5. T or F You can customize the workbenches that are displayed in the
Welcome to CATIA V5 window (this window is brought up by selecting the
current workbench tool).
6. List three of the five Selection tools

.
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7. Where is the Prompt Zone located within the CATIA V5 Screen?
8. What is the purpose of the Prompt Zone?

9. T or F The Standard Toolbar has many of the same tools found in the File
and Edit menus from the top pull down menus.
10. List all the views that are available in the Quick View toolbar.
11. What is the purpose of the Specification Tree?
12. What is the purpose of the Compass?
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13. Where does CATIA V5 display the current active workbench?

14. Where does CATIA V5 display the current active document/file?

15. What tool would you use to bring all the entities in a document into view on
the screen?
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16. Where is the Shading with Edges tool found?

17. List the steps required to make the Part Design Workbench the current
workbench.
18. T or F Each individual line in a sketch has it’s own individual branch in the
Specification Tree.

19. T or F The Normal View Tool
rotates the selected planner surface
normal to the screen so it can be viewed true size and shape.
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20. T or F The Rotate tool
allows the user to rotate the part (graphics
window) in a true 3D rotation.
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Practice Exercises

After completing this lesson you should be able to complete the following exercises.
1. Memorize all 22 labeled areas of the CATIA V5 Screen.
2. Review the top pull down menu tools.
3. Review the Specification Tree.
4. Review bottom toolbar and all its tools.
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5. Make the Part Design Workbench the current workbench.

6. Extra Credit: Customize the Welcome CATIA V5 window to show the
workbenches shown in Figure 2.42.
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