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Lesson 2 
Mass Elements and Mass Groups 
 
Architects usually start the design process with a conceptual idea of how the building 
model will look.  To create this concept, they often use the mass elements and mass 
group tools available inside of ADT. 
 

 
 
The conceptual idea is used to convey to the customer how the building will look. 
 
The building model can be overlaid on top of a photograph of the proposed building site, 
so you can get an idea of how the building will fit in with the surrounding environment. 
 
Once you have the basic shape of the building, you can move forward with creating the 
basic building elements: walls, doors, windows and openings. 
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The Mass Elements tools include a suite of primitive solids that can 
be used to create your conceptual design. 
 
The tools are available on the Massing Palette. 

 
 
For our building design, we will use the Cylinder, Box, and Right Triangle. 
 

 TIP:    You can control the appearance of the tools on your palette by right 
clicking on the palette and selecting View Options. 
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Exercise 2-1: 
Creating Mass Elements 
 
Drawing Name: ex1-3  
Estimated Time: 20 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Elements 
 Views 
 Shade 

 
 

 
1.     Open ex1-3.dwg. 

 
2. 

 
 

Open the Project Navigator Palette. 
Select the Sheets Tab. 
Highlight the Massing sheet under Architectural. 
Right click and select Open. 

 
  
3. 

   Select the Model tab. 
 

3. 
   Switch to a SW Isometric view. 

 
4. Press Ctl+3 to launch the Tool Palette if it is not visible. 

 
5. 

   Select the Box tool from the Massing Palette. 
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6. For Width, enter 58′-8″. 
For Depth, enter 98′-9″. 
For Height, enter 32′. 
 
Place the box in the upper left corner of the 
grid as shown. 
 
 

 
 
7. 

 

 
 
Select the Box tool again. 
For width, use 228′-5″. 
For depth, use 110′-9″. 
For Height, use 40′-0″. 
 
When prompted for rotation, press ENTER 
for zero degrees. 
 
 

 



Lesson 2 - Mass Elements and Mass Groups 

2-5 

8. 

 
 

 
 
 
Place the second box next to 
the first box.   
 
You can use the MOVE 
command later to position 
them next to each other. 
 

 
9. 

 
 

 
Add a third box. 
For width, use 143′-6″ 
For depth, use 357′-0″. 
For Height, use 40′-0″. 
 
 

 
10
. 

 

Place the box next to the second box.  
You can use the MOVE command 
later to position them next to each 
other. 
 
When prompted for rotation, press 
ENTER for zero degrees. 

 
11
. 

 

We place a fourth box. 
 
For width, use 116′-11″ 
For depth, use 290′-8″ 
For Height, use 32′-0″ 
 
 

When prompted for rotation, press ENTER for zero degrees. 
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12. 

 
 

 
 
Place the box anywhere in the drawing.  
We will use the MOVE command to 
position it later. 

 
13. For Height, enter 32′-0″ 

For Radius, enter 50′-0″. 
When prompted for insertion point, 
enter 0,0. 
 

 
For rotation, press ENTER for zero degrees. 
  

14.    Switch to a top view. 
 

15. 

 

 
 
 
Using the MOVE tool, move the fourth box so that the 
lower right corner is coincident to the lower quadrant of 
the circle. 

 
16. 

 

 
 
 
Move the third box so that its lower right corner is 
coincident with the midpoint of the bottom horizontal line of 
Box 4. 
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17.  
 
Move Box 2 so the mid-point of the left side 
of the box is coincident with the lower right 
corner of Box 3. 

 
18. 

 

 
 
 
Move Box 1 so the upper left corner is 
coincident with the upper right corner of Box 2. 

 
19.  

Our completed conceptual design. 
 
 
Use the 3D Orbit tool or the Views tools to inspect 
the building from different viewpoints. 

 
20. 

 
 
 

 

 
Switch to an isometric view. 
 

 
 
Go to View→3D Orbit to rotate your design in 
three dimensions. 

 

 

 TIP:    You may want to add the 3D Orbit tool to your View toolbar.  To add 
the 3D Orbit tool, right click in the grey area of the toolbar and select Customize. 
2-7 
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Select the 
Commands tab. 
Highlight the 
View Category, 
Select the 3D 
Orbit tool. 
 

Drag and drop onto your View toolbar. 
Press Close. 
 

 
 
21. 

 
Select the Flat Shaded tool from the View toolbar to get a better visual 
concept of the building. 
  

22. Save as ex2-1.dwg. 
  
23. 

 

 
Activate the Project Navigator 
Palette. 
Highlight Architectural. 
Right click and select Save 
Current Dwg As Sheet.  

  
24. 

 

 
Edit the Name field. 
 
Press OK. 
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We can add concrete steps leading up to our building using a series of cylinders.  All the 
cylinders are placed at 0,0, but the Z or elevation of the cylinders is different.  The first 
step is placed at an elevation of 10′ to accommodate the basement floor of our building.  
Each cylinder has a height of 6″.   
 
 
 

 
 
 
 
 
 

CYLINDER RADIUS INSERTION PT 
1 55′ 0,0,12′-6″ 
2 56′-6″ 0,0,12′-0″ 
3 58′-0″ 0,0,11′-6″ 
4 59′-6″ 0,0,11′-0″ 
5 61′-0″ 0,0,10′-6″ 
6 62′-6″ 0,0,10′-0″ 

 
All cylinders have a height of 6″. 
 
 
 
 
 
 
 

 TIP:  If you make a mistake in placing a cylinder, you can use the UNDO option 
to undo the placement and then retype it in.  Simply type ‘U’ at the command line 
when prompted for the insertion point and the previous cylinder placed will be erased.
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Exercise 2-2: 
Creating Entry Stairs 
 
Drawing Name: ex2-1.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Elements 
 
 
 

1.   Open ex2-1.dwg. 
 

2. 
  Switch to a top view. 

 
3. 

 
 

 
Select the Cylinder tool. 

 
4. 

 
 

 
Enter 6″ for the Height. 
Enter 55′-0″ for the Radius. 

 
5. At the command line, enter 0,0,12′6″ for the insertion point. 

Press ENTER for Rotation Angle. 
 

6. CYLINDER HEIGHT RADIUS INSERTION PT 
1 6″ 55′ 0,0,12′-6″ 
2 6″ 56′-6″ 0,0,12′-0″ 
3 6″ 58′-0″ 0,0,11′-6″ 
4 6″ 59′-6″ 0,0,11′-0″ 
5 6″ 61′-0″ 0,0,10′-6″ 
6 6″ 62′-6″ 0,0,10′-0″  

  
Using the table, create Cylinders 2-6 without exiting the Cylinder command. 
(You already created Cylinder 1.) 
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7. Save as ex2-2.dwg. 
 
 
 
Exercise 2-3: 
Modifying Mass Elements 
 
Drawing Name: Ex2-2.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Elements 
 Modify Mass Element 

 
The curved front of the building is very attractive, but unnecessary for the basement 
level. 
 
We can modify the cylinder by changing the height and insertion point. 
 
1.   Open ex2-2.dwg. 

 
2. 

  Switch to a top view. 
 

3. 

 

 
Select the large cylinder. 
 
Right click and select Properties. 

 
 

 TIP:  You can place these cylinders quickly by changing the radius value in the 
Properties dialog and then use the Up ↑ arrow on your keyboard to copy the previous 
insertion point.  You can then modify the insertion point and press ENTER. 
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4. 

 
 

 
Change the Height to 22′-0″. 

 
5. Select the field that shows Additional information. 

 
6. 

 
 

 
Change the Z value to 10′-0″. 
 
Press OK. 
 
Close the Properties dialog. 

 
7. 

 
 

 
Use 3D Orbit to inspect the change. 

 
9. 

  Save as ex2-3.dwg. 
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Exercise 2-4 
Adding Mass Groups 
 
Drawing Name: Ex2-3.dwg, AEC (Imperial) Massing.dwt  

(Download from the publisher’s website.) 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 New layout from Template 
 Mass Groups 
 Add Mass Group 

 
1.  Open ex2-3.dwg. 

 
2. In order to control the visibility of our mass groups, we should create a layout tab 

and configure the viewport for mass elements and mass groups. 
 

 
 

 
Place your cursor over the model tab. 
Right click and select From template. 

 
3. 

 
 

Locate the AEC (Imperial) Massing. Dwt file 
downloaded from the publisher’s website. 
 
Press Open. 

 
4. 

 

 
Select the Mass-Group layout and 
press OK. 

 
 
5. 

 
Select the Mass-Group tab. 
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6. You see two 
viewports. 
The left viewport 
uses a mass element 
display 
configuration. 
 
The right viewport 
displays mass 
groups. 
 
We see nothing in 
the left viewport 
because we don’t 
have any mass 
groups defined yet. 
  

6. 

 
 

 
 
If you click on the Display Configuration 
down arrow, you see that two display 
configurations have automatically been added 
by the template:  Concept_Group and 
Concept_Mass. 

 
7. 

   Activate the left viewport. 
 Switch to a top view. 
 

8. 

 

Select the Mass Group tool. 
You’ll be prompted for a location. 
Place the Mass Group marker anywhere in the viewport. 
Press ENTER when prompted for a rotation angle.  
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9. 

 
 

 
Go to Tools→Quick Select. 

 
10. 

 
 

Set the Object Type to Mass 
Group. 
Press OK. 

 
11. 

 

Right click and select Properties. 
 
Select the General field. 
In the Description field, enter Stair Entrance. 
Press OK. 
  

12. 

 
 

 
The Description updates. 

 
13. Save as ex2-4.dwg. 
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Exercise 2-5 
Adding Elements to Mass Groups 
 
Drawing Name: Ex2-4.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Groups 
 Add Elements to a Mass Group 

 
Open or continue working in Ex2-4.dwg. 
 
Start the Attach Elements command. 
 
You will be prompted for the Mass Group to use.  Select the blue Mass Group icon. 
 
You then will be prompted for the mass elements to attach.  Select the step cylinders. 
 
1.   Open ex2-4.dwg. 

 
2. 

 
 

 
Go to Tools→Quick Select. 

 
3. 

 
 

Set the Object Type to Mass 
Group. 
Press OK. 

 
4. 

 

 
Right click and select Attach Elements. 
 
Select the cylinders that make up the stairs. 
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5. The mass group appears in the right viewport. 
  

 

 
6. Save the file as ex2-5.dwg. 
  

 
 
ADT comes with a Model Explorer that allows you to view your conceptual model. 
Additionally, you can edit your model inside the Explorer. 
 
 

 
 

To access the Model Explorer, select a mass group. 
Right click and select Show Model Explorer. 

The Model Explorer 
is divided into three 
sections: the Menu 
and toolbars across 
the top, the graphics 
viewer on the right, 
and a browser in the 
left pane. 
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The top pane contains menus and toolbars. 

 

Tool Description Purpose 

 
Save Creates a png, jpg, bmp, or tiff file (image) 

file  

 WireFrame 

 Hidden 

 Flat Shaded 

 Gouraud Shaded 

Change the View mode of the model 

 Pan 

 Zoom Realtime 

 3D Orbit 

 Adjust Distance 

 

Predefined 3D Views 

These tools allow you to change your view 
of the model in the graphics window. 
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Tool Description Purpose 

 New Grouping Creates a Mass Group 

 New Element Add a new mass element  

 Cut Cuts or deletes a Mass Element or Group 

 
Copy Places a Mass Element or Group on the 

clipboard as a copy. 
 Paste Pastes a Mass Element or Group 

 Delete Deletes a Mass Element or Group 

 Attach Element Attach a Mass Element to a Group 

 Detach Elment Remove a Mass Element from a Group 

 
Properties Modifies the properties of a Mass Element or 

Group 

 
Display Configuration Brings up a drop down list of display 

configurations 

The graphics area displays the mass elements or groups that are selected in the tree view.  

The order of the objects and mass elements in the browser determines the result if you 
decide to combine mass elements using additive, subtractive, or intersection.  The Model 
Explorer can be used to re-order of objects and elements to control the result of Boolean 
operations.   

 

 TIP:  You can only view Mass Groups in the Model Explorer.  Mass Elements 
that are not attached to a Mass Group cannot be seen.  You can use this to control 
visibility of mass elements. 
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Exercise 2-6 
Using the Model Explorer 
 
Drawing Name: Ex2-5.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Groups 
 Model Explorer 
 Mass Elements 

 
Often, architects like to try out different design ideas.  The Model Explorer allows you to 
quickly and easily try out different conceptual ideas using Mass Groups and Elements. 
 
The Model Explorer is a powerful to tool to allow you to manage your Mass Groups and 
Elements. 
 
1.   Open the Ex2-5.dwg. 

   
2. 

 
 

 
Go to Tools→Quick Select. 

 
3. 

 
 

Set the Object Type to Mass 
Group. 
Press OK. 

 
4. 

 
 

 
Right click and select Show Model Explorer. 
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5. 

 

 
In the Browser Pane, we see the Stair Entrance 
we created in the previous lesson.  The right 
pane displays the stair entrance we defined. 
 
If you select a cylinder in the browser, only the 
selected element(s) are visible. 

 
 
6. 

 
 

 
Go to File→New Grouping. 

 
7. Your screen will switch to your ADT window. 

Place a mass group in the right viewport. 
 

8. 

 

Mass group icons appear as small blocks in your 
viewport. 
 

 
If your mass group icons are not visible, go to 
Format→Display Manager. 
  

9. Highlight the Concept Group under Concept Group. 
Select the Mass Group object line. 
Right click and select Select All. 
Press Apply and close the dialog. 
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10. 

 

Select the second mass group you placed. 
Right click and select Properties. 
Select the General tab. 
Enter Main Building in the Description field. 
 
Press OK to close.  

 
11. 

 

 
Activate the Model Explorer 
window. 
 
The name of the Main Building 
appears in the Browser. 
 
Right click and select Attach 
Elements. 

Switch to the main graphics window. 
 
Select the four boxes we placed in the previous lesson. 
 
Switch back to the Model Explorer. 
  

12. Now when we highlight the Main Building, we can see the wings for the Main 
Building. 
 
Highlight the Main Building Mass Group. 
 

13. 

 

     Select the New Grouping tool.   
 
Switch to ADT’s graphics window. 
 
Place the group icon anywhere in the graphics area. 
 
Note that you now see the main building mass group in the right 
viewport. 
 
Switch back to the Model Explorer. 
  

14. 

 

 
We see that this Mass Group is located below the 
Main Building Mass Group in the browser. 
 

 
Highlight this mass group and select Properties. 
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15. 

 

Select the 
Description field. 
In the Description 
dialog, enter 
rotunda 
entrance. 
 
Press OK. 
 
Note that this 
mass group is 
attached to the 
Main Building 
mass group. 

 
16. Switch back to the Model Explorer. 

 
Highlight the rotunda entrance in the browser. 
 

    Select Attach Element. 
 
Switch to main ADT window and select the cylinder for the building entrance. 
 
Switch back to the Model Explorer. 
  

 

 We see that the Main Building now includes the rotunda entrance. 
 

17. Activate the Model Explorer. 
 
Highlight the Stair Entrance, right click and select Cut. 
 
Highlight the Main Building, right click and select Paste. 
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 The main building has now been redefined with the stair entrance. 
 

18. Save the file as ex2-6.dwg. 
 
 
 
Exercise 2-7 
Creating a Profile 
 
Drawing Name: Ex2-6.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Groups 
 Model Explorer 
 Mass Elements 
 Profiles 
 Extrusions 
 Style Manager 

 
We are going to create an Atrium entrance that will be an alternative version of our 
building design. 
 
We see that ADT comes with several standard shapes that we can use for our Mass 
Elements:  cone, arch, cylinder, etc.  Sometimes we need a shape that does not fall in this 
list.  To create those shapes, we use a custom profile to create our mass element.  The 
entrance to our atrium will use a custom profile. 
 
ADT comes with several standard profiles. 
 
1.   Open the Ex2-6.dwg.   

 
2. Select the left viewport. 
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3. In an area away from the model, create the following sketch using LINE. 
 

 

 
ADT will not recognize the four lines as 
profile unless it is a closed figure.  The 
easiest way to do that is to use the 
PEDIT command and JOIN all the 
lines. 

 
Type PEDIT at the command line. 
 
Select one of the lines. 
 
You will be asked if you want to turn the line into a polyline.  Press Enter for Y. 
 
Right click and select the JOIN option. 
 
Window around the entire sketch to add the remaining lines. 
 
Press ENTER to exit the PEDIT command. 
 
Select the sketch and you see that the entire sketch highlights as a single profile. 

  
4. 

 
 

 
Go to Format→Style Manager. 

 
5. 

 

 
Scroll down and expand Profiles.   
 
You see the Profiles that are included in the 
Aec Arch template used to start your 
drawing. 
 
Press OK 
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6. 

 
 

Highlight Profiles. 
Right click and select New. 
 
Rename the Profile Entrance. 
 

 
7. 

 
 

 
 
 
Highlight Entrance. 
Right click and select Set From. 

 
8. 

 
 

 
Select the sketch to be used for the 
Profile. 
You’ll be asked if you want to ‘Add 
Another Ring?’ Enter N. 
Next you’ll be prompted for an insertion 
point, select the Endpoint located in the 
lower left corner of the figure. 
 
Press Apply in the Style Manager. 

 
 In the Style Manager, we see the sketch as the profile for the entrance. 

 
Check out the sketches for the other profiles. 
 
Press OK to close the Style Manager. 
 

9. Save the drawing as ex2-7.dwg. 
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Exercise 2-8 
More Mass Elements 
 
Drawing Name: Ex2-7.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Groups 
 Model Explorer 
 Mass Elements 

 
We are going to create an Atrium entrance that will be an alternative version of our 
building design. 
 
We can create Mass Elements inside the Model Explorer. 
 
1.  Open the Ex2-7.dwg.   

 
2. 

 

 
Activate the right viewport. 
Select one of the mass group icons. 
Right click and select  
Show Model Explorer. 

 
 
 
 

 
 
  
  

 TIP:   When we create new elements, we have to switch between the main 
graphics window and the Model Explorer. 
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3. 

 
 

 
Highlight the Project at the top of the 
browser tree. 
Select the New Element tool.  

4. 

 
 

 
Under Shape, select Extrusion. 
Under Profile, select Entrance. 
For Width, enter 48′-0″. 
For Depth, enter 47′-11″. 
For Height, enter 30′-0″. 
 
Switch to ADT graphics window. 
Select anywhere away from your 
model as the insertion point for the 
first mass element of our atrium. 
 
Press ENTER twice. 
 

 
5. 

 

 

 
Select the New Element tool. 
 

 
Next we place two pyramids that are 
96′W × 24′D × 12′H. 
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6. 

 
 

 
Place the pyramids in the left viewport, so you can 
see them. 

 
7. 

 
 

 

 
Place a third pyramid that is  
50′-10″ W × 84′-8″ D × 12′H. 
Place and rotate 315 degrees. 
 
 

 
8. 

 

 
 
Erase the profile outline as you don’t need it 
anymore. 
 
It will still be stored in your Style Manager. 
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9. 

 

 
 
 
 
Move the first pyramid on top of the 
extrusion.  Line up a corner of the 
pyramid with the corner of the 
extrusion. 

 
10. 

 

 
 
Place the second pyramid on top of the extrusion. 
 
In order to get your elements to look like the figure, 
you may need to rotate your view. 
You also may need to rotate one of the pyramids. 

 
11. 

 
 

 
 
Place the third pyramid on top of the extrusion. 

 
12. Save the file as ex2-8.dwg. 
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Exercise 2-9 
Using Model Explorer to Explore Alternate Designs 
 
Drawing Name: Ex2-8.dwg 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Mass Groups 
 Model Explorer 
 Mass Elements 

 
1.  Open the Ex2-8.dwg.   

  
2. 

 
 
 

Activate the right viewport. 
Select one of the mass group icons. 
Right click and select  
Show Model Explorer. 
 
We see all our models, but we don’t see 
our Atrium. 
 
We need to create a group for the Atrium 
entrance. 

 
3. 

 

Under File, select New Grouping. 
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4. 

 
 

 
 
Switch to ADT’s graphic window and place the 
Mass Group icon. 
 
Switch back to the Model Explorer. 

 
5. 

 
 

Highlight the new (MassGroup). 
Right click and select Rename. 
Rename to Atrium Entrance. 

 
6. 

 

 

   Select the Attach Items tool. 
 
Window around the atrium mass elements 
to select them. 
  

7. 

 

 
To make it easier to identify each element, we 
can use the Rename option. 
 
Rename the pyramids to Left, Right, and 
Middle. 

Rename the extrusion Base. 
 
To rename, highlight the element, right click and select Rename. 
  

8.  We need to move the Atrium Entrance elements to act as an entrance to the building. 
 

 

 
Highlight each element in the Atrium 
Entrance group. 
 
Right click and select Element Properties. 
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9. 

 

 
Select Additional information in 
the Location area. 
 
 

 
10. Assign the values in the table. 

 

Base 24′, 29′-4″, 10′ 
Left Pyramid 0′, 5′-4-1/2″, 22′ 
Right Pyramid 0′, 5′-3-1/2″, 22′ 
Middle Pyramid 10-1/2″, 5′-6-15/16″, 22′ 

 
Press OK. 
  

11. 

 

If you switch to the main ADT graphics window, 
you should see the atrium group moved to the 
entrance point of the building. 
Switch back to the Model Explorer. 

 
12.  Select the New Grouping tool. 

Place the mass group tool in the right viewport. 
  

13.  
Rename the new mass group to 
Alternate Concept. 

 
14. 

 

Copy the four boxes in the Main 
Building Mass Group and Paste them 
into the Alternate Concept group. 
 
To Paste, highlight the Alternate 
Concept and select the Paste tool or 
right click and select Paste. 
 

You have to select each element individually to copy and paste.  If you had 
assigned the boxes to their own group, you would have been able to copy and 
paste the box group. 
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15. 

 

 
 
When we highlight the Alternate 
Concept group, we see the four 
boxes. 

 
16. 

 

 
Drag and drop the Atrium Entrance 
group into the Alternate Concept 
group. 

 
17. 

 
 

 
Highlight the Alternate Concept 
Mass Group. 
 
We can see the conceptual idea of 
the building with an atrium 
entrance. 

 
18. 

 

 
Highlight the Main Building Mass 
Group. 
 
We see the conceptual idea of the 
building with the circular entry. 
 
  

19. We see that using the Model Explorer allows us to explore different conceptual 
designs. 
 
Save the file as Ex2-9.dwg. 
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 TIP:    

You can plot shaded or hidden mode from a viewport in 2004. 

Select a layout tab. 

Verify that you are in paper space mode. 

Double-click the border of the viewport you want to plot. 

In the Properties palette, under Misc., select Shade Plot, and then select an option for 
plotting.  
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