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Exercise 1: Beam Elements 

 

 

Objectives 

 

At the end of this exercise, the learner should be able to: 

  

1. Set up a model using standard cross-sections beam elements with proper orientation; 

2. Set up and run a static analysis; 

3. Understand the units used in Pro/Mechanica®; 

4. View maximum VM stress and maximum displacement results; 

5. Create shear and moment diagrams; 

6. Understand the basic solving principle of the Finite Element method. 

 

 

Introduction 

 

Beam elements are fast and efficient elements in FEA.  They are 1-D in nature but still 

represent what is called a 3-D idealization.  A 3-D idealization is a FEA modeling 

perspective of the model.  For a beam element, imagine an I-beam.  It could be 

represented as a straight line, with a cross-section the shape of an “I” assigned to it. This 

is, in essence, how a beam element is represented.   

 

From a modeling perspective, beam elements are relatively easy to create. They are 

defined by: 

- A datum curve determining the position of the end points of the beam; 

- A material; 

- A cross-sectional area (which will give an area moment of inertia and a torsional 

stiffness) 

- A defined orientation for the cross-section. 

 

Each beam element has its own internal coordinate system (let’s name it the Beam 

Section Coordinate System or BSCS). The BCSC has the following characteristics in 

Pro/Mechanica®: 

- The x-axis is along the length of the beam (the beam’s axis); 

- The y-axis defines the perpendicular orientation of the beam section with respect to 

the beam’s axis; 

- The z-axis will follow according the first two axis’ above. 

Estimated time: 1½ hours 
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The restriction of using beam elements in Pro/Mechanica®, as with any other software is 

that the section remains perpendicular and planar to the datum curve (the beam axis) 

through the entire FEA solution.  Before using beam elements, make sure that the part 

looks similar to a beam and that the aspect ratio (l/t) > 10. 

 

 

Procedure 

 

(Note: Before you start, create a directory named: beam using explorer) 

 

 

 

The problem to be solved: 

               F = 4500 lbs 

 

               2” 

 

     40”       1” 

 

              X-SECTION 

 

Objectives: Draw Shear and Moment diagrams, and find the Maximum VM stress and 

maximum deflection. 
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Flow Chart of Procedure 

 

Here is an overview of the exercise, in the form of a flow chart, showing the different 

steps involve in the analysis. 

 

  In Pro/Engineer®    In Pro/Mechanica®  

 

 

Start 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

              

 

 

 

 

 

 

 
            END 

 

Create part & 

Model 

Datum Curve 

Create Beam 

Section and 

Orientation 

Assign beam section & 

orientation & material to 

datum curve 

Assign boundary 

conditions to model 

Create and Run a 

static analysis. 

Check out results 

(stresses, 

displacements, etc…) 
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1. Start up Pro/Engineer 2001
 

 

Details on how to this is different from system to system.  For a typical windows 

platform: 

 

Start > Programs > Pro/Engineer2001
 
> Pro/Engineer  

(It takes 30 seconds approximately for Pro/Engineer to start.) 

 

Set up your working directory. (File > Set Working Directory) 

Select your working directory, then click on Accept. 

 

2. Create a part named: beam 

 

Select File>new 

 
 

Select part and type in: beam; then Click on OK. 

 

 

3. Setting up in Pro/ENGINEER for FEA modeling 

 

Before we go to Pro/Mechanica, we must understand how beam elements are created.  

Think of beam modeling as a sweep-type protrusion in Pro/Engineer.  Except in the case 

of FEA modeling, we will create a datum curve in Pro/Engineer, then assign the cross-

section (the beam element) in Pro/Mechanica.   

 

 

3.1 Creating a datum curve for beam assignment 

 

Click on the          icon. 

 

From the right menu, select: sketch > Done. 

 

Use front as your sketching plane and accept the default viewing direction; click on OK. 
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Select top from the right menu and select the  top plane as the top reference for the 

plane. 

 

Once in sketcher, Use the line sketching tool           icon and sketch a horizontal datum 

curve as shown below with the following characteristics: 

• 40 units long; 

• Aligned with the top plane, symmetric about the right plane. 

 

 
 

Figure 1:  View of sketch for datum curve 

 

 Note: To modify your dimension, select the dimension to be modified and click on this 

icon.  (or alternatively double click on the dimension) 

 

Select done out of sketcher (        icon) and click on OK off the dialog box. Turn datum 

planes off using the datum icon at the top of your screen. 
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(Pro/Mechanica portion) 

 

1. Go to Pro/Mechanica from Pro/Engineer 

 

Select Applications>Mechanica from the top pull-down menu. 

 

 (Wait a few seconds) 

 

You will see a unit info dialogue box come up on the screen as shown below: 

 

 
 

 Important: Have a look at the working units and then Click Continue to accept the units 

message. 

 

Select Structure from the right menu. 

 

 

2. Beam Assignment 

 

2.1 Beam Section 

 

Select Model>idealizations>Beams>Sections.  The following dialogue box will come 

up.   

 
Click on New. 
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The dialogue box shown below will come up.  Enter the information as seen below.   

 

STOP 

What we are doing at this time is giving the cross-sectional dimensions of the beam 

element used for the analysis. At this time you must know these dimensions.  The cross-

section is constant through the datum curve representing the beam.  The beam for our 

analysis is 1 in wide and 2 inches high. 

 

 
 

Once the information is entered, click on OK. Then close the beam section dialogue box.  

Then select Done/Return. 

 

 

Note: if the section is not in the above menu of pre-defined X-section, you can sketch it 

easily using the sketch options off the type menu. The menu picks are ‘sketch thin’ or 

sketch solid.  It will then take you to the Pro/Engineer sketcher. 

 

 

STOP 

We must now orient the vector of the cross-section.  Even though it will show up on the 

screen if we don’t, Pro/M wants to make sure that it is oriented the proper way. The 

software needs insight here as to which way to go and to make sure that we know what 

we are doing! 

A vector will be used to determine the orientation.  This vector will determine the beam 

section coordinate system orientation.  
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2.2 Beam Orientation 

 

Select Model>idealizations>Beams>Orientations 

 

Once the Beam orientation dialogue box comes up, click on New.  Enter the following 

information in the box. 

 

 

 
 

Click on Ok then close the beam orientation dialogue box. 

 

 

2.3 Beam Definition 

 

Select New off the beams menu.  The following beam definition window comes up.  

Enter and select information as shown. 

 

Under Name: Enter beam1. 

Under references: Select Edge/Curve  

Under edges, click on the arrow and select the datum curve on the screen, then click on 

done sel. 

(pay attention, selecting it more than once reverses the selection here.) 

Material: Select Steel. 

Under type: select More…, the following window will come up: 
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Select steel off the left column and move it to the right column by clicking on the triple 

arrows box in the center. Then click on OK. 

 

Defined by: Y direction of vector in WCS Vector (0, 0, 1) (this defines the orientation of 

the cross-section, as explained on the precious page in the stop note.) 

Select section and orientation as shown.  There are no beam releases for this analysis. 

 

 
 

Select OK – Done/Return and note that cyan rectangles appear along the datum curve.  

Zoom in on one of the rectangles and look! You can see a vector inside the beam.  This 

vector is oriented in the coordinates given above (0, 0, 1).  You could easily change the 

orientation of that vector simply by changing the coordinates of the vector. 

 

Our beam idealization is fully defined.  Good job! 
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3. Constraints 

 

Select Model > Constraints > New > Point from the right side menu. 

 

The following dialogue box will come up. Enter and select the following information: 

 

Name: End_constr_1 

Member of set: ConstraintSet1 

Under points, click on the arrow icon.           

From the datum points menu that comes up, Select Create > On vertex and click on the 

positive X-axis end of the beam.   

 

Click on Done select and then Done off the right menu. (or middle mouse click twice) 

 

 A point should then show up at the positive x-axis end of the beam.   

 

Nothing further is needed for this box.  We accept the defaults for the WCS and keep all 

degrees of freedom fixed. 

 

 
  

Select OK off the constraint dialog box. Select Done/Return off the right side menu. 

 

All translation 

DOF fixed 

All rotation 

DOF fixed 
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4. Loads 

 

Select Loads > New > Point 

 

The following dialogue box will appear.  Fill out the information as seen below.  

 

Under reference-points, click on the arrow icon.          

From the datum points menu that comes up, Select Create>On vertex and select the 

negative X-axis end of the beam. 

 

Click on Done select and then Done off the right menu. (or middle mouse button click 

twice) 

 

Under Force-components, enter 4500 in the Z direction box. 

 

 
 

Select OK off the constraint dialog box. Select Done/Return off the right side menu. 

 

In order to properly show the load, from the top pull-down menu, select 

View>Simulation display>Settings and click on tails touching under load arrows.  

Also, click on value under Load/Constraint display.  

 

Click on OK to close the window. 
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The resulting window should look like the following: 

 

 
 

 

5. Set up and run Analysis 

 

5.1 Static analysis 

 

Select Analyses from the right menu and select Static > New from the analysis form.  

The following dialogue box will come up.  Enter the following information: 

 

Name: Static1 

Description: Analysis of cantilever beam. 

Constraints and Loads as shown below. 

Method: Multi-Pass Adaptive with 1 percent convergence (since beams are fast and 

accurate) 

Converge on local displacement and strain energy. 
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Click on OK and then Close. 

 

 

5.2 Run Analysis 

 

Select Run > Start.  The analysis will now be running.  

 

The software will ask you if you want error detection (yes / no)? Answer yes. 

 

To check things as the calculations are performed, click on Summary. 

 (Note how fast the solution converged) 
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From the summary file, the following information is important to consider. 

 

 
 

We are getting a maximum bending stress of 2.7 e+05 psi or 270 ksi. Which is the same 

value as the exact solution.   

 

What you should look for from the results of this analysis: 

 

 

Item 

 

 

Description 

 

Where to find it 

 

What it should be 

 

Convergence 

The convergence will let us 

know if all elements 

converged and if they all 

converged to a solution. 

 

Click on Summary 

under the Run menu 

and scroll down 

 

For beams, less 

than 1% 

(0% for this 

analysis) 

270 ksi 

(max_stress_vm) 

 

 

Maximum 

VM stress or 

displacement 

of Model 

 

Gives the maximum Von 

Mises Stress or 

displacement for the 

analysis 

 

Click on Summary 

under the Run menu 

and scroll down .012885 (*) 

(max_displ_z) 

 

VM stress or 

displacement 

over entire 

model 

 

Gives the Von Mises Stress 

for the analysis for the entire 

model 

 

See procedure below 

Depends on 

boundary 

conditions and 

geometry 

 

Vm stress 

Displacements (*) 
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Note: (*) Be careful with the units of displacement in the results given by 

Pro/Mechanica®.  This is discussed later in the exercise. (See p. 23) 

 

Select Close and Done. 

 

 

6. Analysis results   

 

Select Results.  The following box will come up.  Answer yes. 

 

 
 

 

Once the empty window comes up, Click on this icon named ‘insert a new definition’. 

 

 
 

 

The following box will come up. Type in vm_stress (for Von Mises stress) 

 

 
 

 

Select static1 for the analysis. Then click on Accept.  The following contents definition 

box will come up.  Select and type in all information as shown below. 
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Click on Accept. From pull-down menu, select view > display.  The following window 

will come up: 

 

 
 

Select vm_stress then OK.  Then the following results window will come up: 
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The results from a beam analysis are not the most impressive to look at.  But they are 

accurate, providing your geometry and boundary conditions are precise.  The only colors 

that we see are along the beam axis.  We can see that the maximum stresses are at the 

fixed end of the beam.  Note that the maximum value is the same as the one given in the 

summary file. 

 

Note: you can save this window by simply selecting the save or save as icon on the top of 

the window. 

 

Select File/Exit Results and answer no to the question: Do you want to save the current 

window?  

 

As an exercise, create the following result window in order to look at the maximum 

displacement from the model.  Simply follow procedure 6 above, the only changes being 

under quantity on the definition form.  
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Approximate Finite Element Analysis Solution (Theory) 

 

(Don’t skip this, as there is some more Pro/Mechanica® procedures included with it 

to make it more fun) 

 

Solving the beam analysis with FEA theory, the problem can be seen as follows: 

 

 

 

 

       F = 4,500 lbs 

 

 Miz 

      

      y     L = 40 in. 

 x    Fyi 

  z  vi   , θzi                   vj   , θzj  

 

 

 

Symbol Definition: 

 

Symbol Definition 

L Length of beam 

Miz Bending moment at the fixed end of the beam 

Fyi  

E E is the young’s modulus of elasticity of the 

material. 

I the 2
nd
 moment of Area 

d
2
v/dx

2
 the curvature of the beam 

vi 

 

The vertical deflection at x = 0. 

θzi The beam slope at x = 0. 

vj 

 

The vertical deflection at x = L. 

θzj The beam slope at x = L. 
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The general equation for beam deflection is from beam theory: 

ziyiz

zz

MxFM

where

dx

vd
EIM

+=

=

;

2

2

 

 

Consequently; 

 

ziyiz
MxF

dx

vd
EI +=

2

2

               (1-1) 

 

Let’s get the moment diagrams from Pro/Mechanica®, this will be fun: 

 

From your beam model, where you are in Applications > Mechanica > Structure, select 

Results > then click on the insert a new definition icon. 

 

 
 

 The following box will come up.   

 

 
Answer yes. 

 

Select create and then the following box will come up. Type in shr_moments (we will 

show both diagrams on the same window.) 

 

 
 

Click on Accept. 
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Select static1 for the analysis. Then click on Accept.  The following contents definition 

box will come up.  Select and type in all information as shown below. 

 

 
 

Enter and select the following information as indicated: 

 

• Title: Shear and Moment Diagrams 

 

• Quantity: Select shear and moment (and de-select P, Vz, Mx and My as they are 

not necessary for this problem).  Refer to the coordinate system on the beam 

model for those.  We only need The shear along the z-axis and the moment with 

respect to the y-axis.  (if you are not sure that you followed the modeling properly 

for this exercise, you can keep all shear and moment selected, it is not  going to 

change the answer.) 

 

• Location: Make sure that beams is selected.  Click on Select and select the 

beam off the screen.  You will then be prompted the following message as 

Pro/Mechanica® highlights one of the ends of the beam. 

 

 
 

Make sure that you look at the coordinate system presented to you when you get this 

message as it affect the de-selection of the 2
nd
 bullet point above, 
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We have no choice to accept this message, we must note where the point is though as it 

will help us interpret the diagrams below.  Click on OK, then Accept then Show. 

 

The result window should look as follows, where: 

• The maximum shear is 4,500 lbs and; 

•  The maximum bending moment is 180,000 in.lbs. 

 

 
 

Figure 2: Shear and moment diagrams 

 

Select File > Exit Results. 

 

From the diagrams above, it looks like Pro/Mechanica® has taken the point where the 

load was applied as the reference point.  We must understand where the reference point 

is, as it affects the shape (not the actual values) of the diagrams. 

 

Let’s integrate twice  (Yahoo!) equation 1-1 above.  This will give the following: 

 

21

23

2

26

1
2

AxA
xMxF

vEI

AxM
xF

dx

dv
EI

ziyi

z

zi

yi

z

+++=

++=

 

 

 

1
st
 integration 

2
nd
 integration 
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From our problem definition, we have the following boundary conditions: 

 

At x = 0 At x = L 

vi = 0 

 

θzi = 0 

vj 

θzj  

Where v is the deflection (vertical) and θ is the slope at the respective locations. 

 

Which will give the following 2 equations for the bending moment and the reaction force 

at the fixed end of the beam (i): 

 

zj

z

j

z

yi

zj

z

j

z

i

l

EI
v

l

EI
F

l

EI
v

l

EI
M

θ

θ

23

2

612

26

+=

+=

  (1-2) 

 

Which can be written under the following matrix form: {K} {D} = {F} as follows: 

 









=












zi

yi

zj

j

M

Fv

ll

ll
EI

θ2
    

6
  

6
    

12
 

2

23

 

 

Where {K} is the stiffness matrix for our beam deflection problem: 

 

From our diagrams and figure above, we have the following data: 

 

- Fyi = 4,500 lbs and; 

- Mzi = 180,000 in. lbs 

- E = 29 X 10
6
 psi 

- I = bh
3
/12 = (1) (2)

3
 / 12 = .667 in.

3
 

 

What we are looking for here is the value of vj, solving the matrices above using the 

Gauss elimination method for vj gives a maximum displacement of 4.95 in. 

 

Do you remember how to solve matrices? 
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Let’s bring back those bad memories: 

 

We have from equation (1-2): 

 



















180,000         
2

      
6

4,500       
6

       
12

2

23

l

EI

l

EI

l

EI

l

EI

 

 

 

We need to bring the matrix to a form as follows: 

 










C2               1                0

C1              1               1 A
 

 

 

So let’s perform the following operations on the matrix: 

 

- Divide line 1 by EI12 / l
3
 and; 

- Divide line 2 by EI6 / l
2
. 

 

 

Which gives the following matrix: 

 



















,00003             /3        1

753               /2         1

2

3

EI

l
l

EI

l
l

 

 

 

Let’s now subtract line 1 from line 2. 

 



















− 753-,00003            /6       0

753                     /2         1

32

3

EI

l

EI

l
l

EI

l
l

 

 

 

Line 1 

Line 2 
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Finally, let’s divide line 2 by –l/6 

 



















+ 500,4180000-            1       0

753                     /2         1

2

3

EI

l

EI

l

EI

l
l

 

 

Which gives the following solution, when all proper values are put in the matrix: 

 

θzj = -.186 rd and 

 

vj = 4.95 in. 

 

 Comparing the deflections: 

 

FEA approximate solution Pro/Mechanica® solution Exact Solution (PL
3 
/ 3EI) 

 

4.95 in. 

 

.0129 (sec
2
) 

 

4.96 in. 

 

The above results do not concur.  Well, the software ones anyway. What went wrong 

here?  Pro/Mechanica® actually gives a deflection value much smaller that the exact and 

FEA approximation solutions.  But the maximum Von Mises stress calculated by 

Pro/Mechanica® was accurate? 

 

The problem is with the system of units that Pro/Mechanica® uses.  We need to multiply 

the answer we got for deflection by the gravitational (386.4 in/sec
2
), so the final 

Pro/Mechanica® solution answer will be 4.98 in. 

 

 

Conclusion 

 

Beam elements are fast and accurate elements.  They are mainly used by analysis for 

getting an idea of the big picture of an assembly of different cross-section.  The frame rail 

of a trailer for instance.  They are also useful to get the shear and moment diagrams of 

structures.   

 

The modeling is fast (datum curves) and the beam assignment is also fast.  Remember: If 

it looks and smells like a beam, then use beam elements for the analysis.  On the other 

hand, you will not be able to study stress concentrations around holes for instance, shell 

elements should then be used for this type of analysis. 
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Be careful with the units of displacement in the results given by Pro/Mechanica®, 

multiply your answer by the gravitational constant in order to get to the units that you are 

looking for (inches in this case). 

 

 

Project 1 

 

Problem Definition 

 

Determine the location and magnitudes of the maximum VM stress and the maximum 

displacement (in y) of the following application (diving board). 

 

      F= 250 lbs. 

          (8 X 1) in.
2
 

 

 

                 Beam section 

          25 in. 

 

     50 in. 

 

          y 

                x 

       z 

 

 

Notes and Hints: 

 

      Fixes the location in all 6 DOFs. 

 

      Fixes the y direction DOF and the rotation with respect to x axis.  

 

Material: Use Aluminum 2024 
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Results 

 

 

 
 

Figure 3: Summary file results for project1 

 

 
 

Figure 4: Von Mises Stress fringe plot for project1 
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End of Exercise 
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NOTES: 


