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Lesson 1

Pro/E Customization Tools
and
Project Introduction

Synopsis:

Configuration settings; customizing the screen toolbars and menus; mapkeys; part templates;

introduction to the project

Overview

This lesson will introduce tools for customizing your Pro/E configuration and working

environment and show you how to create some useful shortcuts for accessing Pro/E commands. 

The major customization tool is the use of one or more configuration files (default file:

config.pro).  The lesson also includes managing and creating your own custom toolbars and

mapkeys.  We’ll also see how you can create your own part templates.

The major project used in this tutorial is introduced and the first four parts are presented.

Configuration Files (config.pro)

By now, you should be familiar with the commands for environment settings that are available in

Utilities > Environment

These aspects of the Pro/Engineer working environment (and much more!) can also be controlled

using settings stored in configuration files (config files for short).  Pro/E has several hundred

individual configuration settings.  All settings have default values that will be used if not

specifically set in a config file.

The most important config file is a special file called config.pro that is automatically read when

Pro/E starts up a new session.  You can also read in (and/or change) additional configuration

settings at any time during a session.  For example, you may want to have one group of settings

for one project you are working on, and another group for a different project that you switch to

during a single session.  In this tutorial, we will deal only with the use of the single configuration

file, config.pro, loaded at start-up.



1 - 2 Pro/E Customization and Project Intro

1 In Windows, right click on the Pro/E icon on the desktop (if it exists), select Properties

> ShortCut and examine the Start In text entry field.

Several copies of config.pro might exist on your system, and they are read in the following order

when Pro/E is launched:

‚ config.sup - this is a protected system file which is read by all users but is not available for

modification by users.  Your system administrator has control of this file.

‚ Pro/E loadpoint - this is read by all users and would usually contain common settings

determined by the system administrator such as search paths, formats, libraries, and so on.

This file cannot normally be altered by individual users.

‚ user home directory - unique for each user (Unix)

‚ startup directory - the current or working directory when Pro/E starts up.  To find where

this directory is, select File > Open and observe the directory name in the top box1

Settings made in the first copy (config.sup) cannot be overridden by users.  This is handy for

making configuration settings to be applied universally across all users at a Pro/E installation

(search paths for part libraries, for instance).  An individual user can modify entries in the last

two copies of config.pro to suit their own requirements.  If the same entry appears more than

once, the last entry encountered in the start-up sequence is the one the system will use.  After

start-up, additional configuration settings can be read in at any time.  These might be used to

create a configuration unique to a special project, or perhaps a special type of modeling.  Be

aware that when a new configuration file is read in, some options may not take effect until Pro/E

is restarted.  This is discussed more a bit later.

Settings in config.pro are composed of two entries in the following form:

config_option_name config_option_value

Option values can be composed either of text, single numbers, or series of numbers.  A complete

listing and description of all config options is contained in the on-line help.  With the Help page

visible in your browser, select

Contents > Pro/ENGINEER Foundation > Using Configuration File Options

This gives a (very long) list of all the options, with a short description of each.  Note that the

default value is indicated in italics.  You will have a hard time remembering the meaning of all

these options, let alone their names!  Fortunately, the dialog window for working with

configuration files contains a one line description of any selected option.  There is also a new

search capability for finding option names.  Although this makes finding the options much easier,

you are encouraged to explore the on-line help - you might find just the setting you need to make

your life easier!

Your system may have a standard configuration file available for you to use as a basis for your

own work.  Look for the config.pro file in the pro_stds (“standards”) directory in the Pro/E

installation.
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Figure 1 The Options window for setting and

editing configuration files

Before we proceed, if you have access to this file, copy it to your start-up directory, along with

the file config.win (this is a file containing customized screen layout settings which are discussed

later).  Now launch Pro/E, or if it is already up erase everything currently in session and set your

working directory to your normal start-up directory.

The Configuration File Editor

You can access your current configuration file using

Utilities > Options

This brings up the Options window. If your
system has options set already, these will

appear in the window.  If not, the central

area of the window will be blank, as in

Figure 1.  We’ll discuss the operation of

this dialog window from the top down.

The Showing pull-down list at the top will
let you choose from a number of

configuration groups (Current Session, your

start-up config.pro, or elsewhere)

Deselect the check box just below the

Showing pull-down box.  After a couple of
seconds, a complete list of all the Pro/E

configuration options will appear.  The first

column shows its name, and the second

column shows its current value.  An entry with an asterisk indicates a default value.

Browse down through the list. There are a lot of options here! Note that the options are arranged

alphabetically.  This is because of the setting in the Sort pull-down menu in the top-right corner. 

Change this to By Category.  This rearranges the list of options to group them by function.  For

example, check out the settings available in the Environment and Sketcher groups. Fortunately,

there are a couple of tools to help you find the option name you’re looking for.  Let’s see how

they work.

Check the box beside “Show only options loaded from file” and select Sort(Alphabetical).  Note

that the options listed here are only those that are different from the default settings.

Adding Settings to config.pro

Assuming you have a blank config.pro, let’s create a couple of useful settings.  At the bottom of

the Preferences window are two text boxes for entering option names and values.  If you know

the name of the option, you can just type it in to the first box.  One of the most common settings
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Figure 2 Finding a

configuration file

option

is to turn off the (annoying!) beep that Pro/E emits from time to time.  In the text box below

Option, enter the option name bell.  In the pull-down list under Value, select No. Note that the

option name is not case sensitive and the default value is indicated by an asterisk in the pull-

down list.  Now select the Add/Change button on the right.  The entry now appears in the data

area.  A bright green star in the Status column indicates that the option has been defined but has

not yet taken effect.

Now enter a display option.  The default part display mode in the graphics window is Shaded. 

Many people prefer to work in hidden line mode - let’s make it the default on start-up.  Once

again, we will enter the configuration option name.  As you type this in, notice that Pro/E

anticipates the rest of the text box based on the letters you have typed in.  After typing the “dis”

characters, the rest of the option will appear; just hit the Enter key.  The option name and value

we want are

display hiddenvis

Now select Add/Change as before (or just hit the Enter key after typing the “h”).

Another common setting is the location of the Pro/E trail file.  As you recall, the trail file

contains a record of every command and mouse click during a Pro/E session.  The default

location for this is the start-up directory.  Theoretically, trail files can be used to recover from

disastrous crashes of Pro/E, but this is a tricky operation.  Most people just delete them.  It is

handy, therefore, to collect trail files for each session in a single directory, where they can be

easily removed later.  There is an option for setting the location of this directory.  Suppose we

don’t know its specific name.  Here is where a search function will come in handy.

At the bottom of the Preferences window, click the Find button.  This

brings up the Find Option window (Figure 2).  Type in the keyword trail
and select

All Categories > Find Now

Several possibilities come up. The option we want is listed as trail_dir. 
Select this option and Browse to a suitable location on your system for

the value.  Perhaps something like c:\temp.  Then select Add/Change. 

The new entry appears in the Preferences window.  In the Find Option

window, select Close.

For some options, the value is numeric (eg setting a default tolerance, number of digits, or the

color of entities on the screen). In these cases, you can enter the relevant number (or numbers

separated by either spaces or commas).  For example, under Option, enter the name

system_hidden_color.  Then under Value, enter the numbers 60 60 60 (separated by spaces). 

These give the values of red, green, and blue (out of 100).  Equal values yield gray; this setting

will brighten the hidden lines a bit from the default value.  Select Add/Change.
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Figure 3 Settings in config.pro

We have now specified four options.  To have them take effect, select the Apply button at the

bottom.  The green stars change to small green circles in the Status column.

Note that you can resize the column widths by dragging on the short vertical column separator

bars at the top of the display area.  At the far right is a long (scrollable) one-line description of

the option.

For practice, enter the options

shown in Figure 3.  The order that

the configuration options are

declared does not matter (the

exception is mapkeys, discussed

below). Check the on-line help for a

description of these configuration

settings and feel free to add new

settings to your file.  Investigate

settings for search paths, libraries,

default editors, default decimal

places, import/export settings, and

so on.

Notice the icons in the first column

beside the option names.  These mean the following:

  (lightning) - option takes effect immediately

  (wand) - option will take effect for the next object created

  (screen) - option will take effect the next time Pro/E is started

If you are using a config file from a previous version of Pro/E you may see a “stop sign” (actually

a red circle with a line through it), which means that the option is no longer used.

Try to add an illegal option name.  For example, in Release 2000i there was an option

sketcher_readme_alert.  Type that in to the Option field.  When you try to set a value for this,

it will not be accepted (the Add/Change button stays gray).  Pro/E only recognizes valid option

names!  Thus, if you mistype or enter an invalid name, this is indicated by not being able to enter

a value for it.

We will be making more changes to this config.pro a bit later in this lesson when we discuss

mapkeys.
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Saving Your config.pro Settings

To store the settings we have just created, select the Save As button  at the top of the Options

window.  At the bottom of the new window, type in the desired name for the file - in this case

config.pro and select OK.

Deleting Configuration Options

With the configuration file name visible in the Showing field at the top, highlight one of the

options and select Delete.  Selecting Apply automatically saves the new settings.  Close the

window.

Loading a Configuration File

To load a new configuration file, select the Open File button beside the Showing list.  Select the

desired file and then Open. Note that these settings will be read in but not activated immediately

(note the green star).  Select the Apply button and observe the green star.

Now select Close in the Options window.

Checking Your Configuration Options

Because some settings will not activate until Pro/E is restarted, many users will exit Pro/E after

making changes to their config.pro file and then restart, just to make sure the settings are doing

what they are supposed to.  Do that now.  This is not quite so critical since the window shows

you with the lightning/wand/screen icons whether an option is active.  However be aware of

where Pro/E will look for the config.pro file on start-up, as discussed above.  If you have saved

config.pro in another working directory than the one you normally start in, then move it before

starting Pro/E.  On the other hand, if you have settings that you only want active when you are in

a certain directory, keep a copy of config.pro there and load it once Pro/E has started up and you

have changed to the desired directory.  To keep things simple, and until you have plenty of

experience with changing the configuration settings, it is usually better to have only one copy of

config.pro in your startup directory.

Note that it is probably easier to make some changes to the environment for a single session

using Utilities > Environment.  Also, as is often the case when learning to use new computer

tools, don’t try anything too adventurous with config.pro in the middle of a part or assembly

creation session - you never know when an unanticipated effect might clobber your work!
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Message Window

Toolbars

 

   

 

Menu Font

(customized buttons;
top, right, and/or left)

(size; top or bottom)

Figure 4 A customized screen layout

Figure 5 Toolbar

toggle menu

Figure 6 The Toolbars tab in the Customize

window

Customizing the Interface

In addition to the environment settings, there

are several ways of customizing the Pro/E

interface: using config.pro, toolbars, menus,

and mapkeys.  An example of a customized

interface is shown in the figure at the right. 

When you modify the interface layout, your

changes will be saved in a config.win file in a

directory of your choice (usually the current

working directory).  It is possible and

permissible to have several different config.win

files in different directories, each with a

different customization of the screen to suit the

work you may be doing on files in that

directory.

In this section, we will introduce methods to

customize the toolbars and menus.

Toolbars

With the cursor on the top toolbar, hold down the right mouse button.  This brings up the menu

shown in Figure 5.  This shows the toolbar groups currently displayed (see check marks); the

groups can be toggled to include/exclude them from the display.  Each group contains a set of

functionally-related shortcut buttons.
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Figure 7 Choosing short-cut buttons for toolbars

At the bottom of this pop-up menu, select Toolbars.  This brings up the Customize menu which

contains a list of all available toolbars, and their location (see Figure 6).  At the bottom of this

window you can specify whether or not, and where, to automatically save the current layout

settings.  The default is config.win in the current working directory.  As mentioned above, you

can create multiple config.win files, and use File > Save Settings and File > Open Settings in the

Customize window to store and recall previous files.  Note that in addition to the eleven standard

toolbar groups there are three initially empty groups (Toolbars 1 through 3), which you can

populate with short-cut buttons using methods described below.  The pull-down lists at the right

allow you to place the selected toolbars at different places on the screen (left, right, top of

graphics window).

Changing Toolbar Buttons

In the Customize window, select the Commands tab.  (This is also available by selecting

Commands... in the menu shown in Figure 5 or using Utilities > Customize Screen in the pull-

down menu.) The window shown in Figure 7 will open.  Groups of toolbar commands are listed

in a tree structure in the Categories area on the left.  Click on any of the group names and the

available short-cut buttons will appear in the Commands area on the right. As you move the

mouse over these buttons, a  tool tip will display.

To add a button to a toolbar, just drag and

drop it onto an existing toolbar at the top,

right, or left.  The button will be added

wherever you drop it on the toolbar.  To

remove it, drag it off the toolbar and drop it

somewhere else (on the graphics window,

for example).  Note that it is possible to

mix and match the short-cut buttons: any

button can be placed on any toolbar.  For

example, a button listed under the File

category can also be added to the View
toolbar.  Buttons can also be present on

more than one toolbar. The possibilities are

endless!

While we are here, notice that at the bottom

of the Categories list is Mapkeys.  We will
be discussing mapkeys a bit later. You can

add a button representing any of your defined mapkeys to any of the toolbars.  It is helpful to

keep your mapkey descriptive names short for this.

At the bottom of the Categories list is New Menu.  You can drag this up to the menu area at the

top of the screen to create your own pull-down menus.

If you turn on one of the user toolbars (select Toolbar 1, 2, or 3 under the Toolbars tab), an

initially empty button will appear in the designated location (top, left, or right).  You can use the
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Helpful Hint

It is tempting, especially if you are blessed with a lot of screen space, to over-

populate the toolbars by trying to arrange every commonly used command on the

screen at once.  This is reminiscent of many other Windows-based CAD programs. 

Before you do that, you should work with Pro/E for a while.  You will find that Pro/E

will generally bring up the appropriate toolbars for your current program status

automatically.  For example, if you are in Sketcher, the Sketcher short-cut buttons

will appear.  Furthermore, many commands are readily available in the right-mouse

pop-up menus.  Thus, adding these buttons permanently to any toolbar is unnecessary

and the buttons will be grayed out when you are not in Sketcher anyway - you are

introducing screen clutter with no benefit.

Commands selector to drag any button to define your own toolbar.

Notice that the final tab in the Customize window is Options.  This lets you set the position of

the Command/Message window (above or below the graphics area) and some other settings.

When you leave the Customize dialog box, your new settings can be written to the file

designated in the bottom text entry box.  Each new config.win file is numbered sequentially

(config.win.2, config.win.3, and so on).

Keyboard Shortcuts - Mapkeys

A mapkey is a short sequence of keyboard key strokes or a function key that will launch one or a

series of Pro/E commands.  Mapkeys are very similar to macros that can be defined in other

software packages. Mapkey definitions are contained/included in your config.pro file, so they are

loaded at start-up.

The mapkey key stroke sequence can be as long as you want; most users restrict mapkeys to only

2, or sometimes 3, characters.  This gives several hundred possible mapkey sequences - more

than you can probably remember effectively.  Pro/E constantly monitors the keyboard for input

and will immediately execute a defined command sequence when its mapkey is detected.  Single

character mapkeys should be avoided due to the way that Pro/E processes keyboard input.  If you

have two mapkeys “v” and “vd”, for example, the second mapkey would never execute since

Pro/E will trap and execute the first one as soon as the “v” is pressed.  For the same reason, a 3-

character mapkey can never have the same two first letters as a 2-character mapkey.

Ideally, you would like to have mapkey sequences that are very easy to remember, like “vd”

(view default), or “rg” (regenerate).  Because it is common to only use two characters, it will take

some planning to decide how you want to set up your definitions to use only a couple of easy-to-

remember key strokes!  The mapkey should be mnemonic, but can’t collide with other

definitions. You don’t want to have to remember that “qy” means “repaint the screen.” 
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Figure 8 Accessing Mapkeys

currently in session

A practical limit on usable mapkeys is perhaps in the range of 20 to 30, although some “power

users” can use over a hundred.

For this exercise, clear your session and load any single simple part file.  We will not be

modifying the part.

Listing Current Mapkeys

To see a list of your current mapkeys (some are defined in the

config.pro contained in the pro_stds directory) select

Utilities > Mapkeys

This dialog window (Figure 8) allows you to define and record,

modify, delete, run, and save mapkeys.  Note that each mapkey

has a short Name and Description.  The Name will be used on

any short-cut button (described below), and the Description will

appear at the bottom of the main graphics window.  Mapkeys

that start with a “$” are function keys.

Note that mapkeys created using a previous release may differ in

command syntax and it is likely that some mapkey definitions

from previous releases will not function properly.  However,

mapkeys are easy enough to record.  Before you do that, you

might try to get hold of the config.pro file in the pro_stds
directory mentioned above.  A list of these mapkeys is in the file

usually stored in

/ptc/pro_stds/mapkeys.htm

In the following, it is assumed that you have no mapkeys defined

as yet.  If any of these tutorial mapkeys collide with existing

mapkeys shown in the mapkeys list (Figure 8), you can modify the keyboard sequence (for

example, use “dv” instead of “vd”) for the new mapkey.

Creating Mapkeys

New mapkeys are created as follows.  We will create a mapkey sequence “vd” that will reorient

the view to the default orientation. To set this up, you will have to bring in one of your

previously created parts. We will not be modifying the part.

Select the New button in the menu of Figure 8.  The Record Mapkey dialog box shown in

Figure 9 will open.  Enter the data shown in the figure: key sequence, name, description.  Now

we  record the command sequence:
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Figure 9 Creating a mapkey

Record

View > Default Orientation (in the top pull-down menus)

Stop > OK

It’s that easy!  Spin the model with CTRL-middle.  In the Mapkeys window, highlight the new

mapkey “vd” and select the Run button.  It’s a good idea to check your mapkey definitions now

when it is easy to modify them.

As mentioned above, mapkey definitions are saved in a

configuration file (as in config.pro).  New mapkey definitions are

appended to the end of the file.  If you redefine a mapkey (or use a

duplicate keystroke sequence), the definition closest to the bottom

of the config file is the one that will be used.  When saving a

mapkey you can choose either config.pro or current_session.pro. 

There are three ways to save the mapkeys using the buttons in the

Mapkeys window:

Save - saves only the highlighted mapkey

Changed - saves any mapkeys changed this session

All - saves all mapkeys defined for session

Remember that if you save the mapkey in the current_session.pro

or elsewhere, it will not be loaded automatically the next time you

start Pro/E.  To do that, you must explicitly save the mapkey

definitions into the config.pro file.

Close the Mapkeys window.

Minimize Pro/E and open config.pro using your system text editor. Scroll down to the bottom of

the file to see the new line(s) that describe the mapkey.  Obviously, these lines should never be

separated since they are a continuation of the same sequence. It is possible, but probably not

advisable, to try to edit the mapkey definitions manually - leave that to the power users!  Exit

your text editor and restore the Pro/E window.

Some final points about mapkeys: it is possible to set up the mapkey so that execution will pause

to allow user input during the command sequence, either by picking on the screen or through the

keyboard.  Mapkeys can also call other mapkeys.  You might like to experiment with these ideas

on your own.  The possibilities for customization are almost limitless!

As mentioned above, the config.pro file provided in the pro_stds directory contains several

dozen mapkeys.  Some of these are listed in Table 1-1 on the next page.

We will return to mapkeys after the next section.
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Table 1-1 Some commonly used mapkeys

General Mapkeys Feature Creation Mapkeys

wc Window Close ct Create Cut

wa Window Activate cp Create Protrusion

rg Regenerate ch Create Hole

dd Done cr Create Round

qq Quit cc Create datum Curve

View Mapkeys cd Create Datum plane

rr Repaint Utility Mapkeys

sd Shade fr Feature Redefine

vd View Default fs Feature Suppress

vr View Refit fd Feature Delete

vf View Front fe Feature Resume

vb View Back fm Feature Modify

vt View Top fi Feature Information

vl View Left

vg View Right

Working with Part Templates

Most part files that you create contain many common elements such as datums, defined views,

coordinate systems, parameters, and so on.  Creating these from scratch for every new part that

you start is tedious and inefficient. Prior to Release 2000i2 a very handy model creation tool used

the notion of a “start part” which contain these common elements. Users would then create a

mapkey that would bring the part into session and then rename it.  This made the creation of new

parts very quick and efficient, with the added bonus that standard part setups could be employed.

This “start part” functionality has been built into the program using part templates. Several part

templates are included with a standard Pro/E installation for solid and sheet metal parts in

different systems of units.  You may have a reason at some point to create your own template,

which we will do here.  We’ll also define a mapkey to quickly bring it in session and allow you

to change its name.  Then you can immediately get on with the job of creating features.  We will
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Figure 10 Saved views in

mytemplate.prt

create the part template from scratch, although you could use any of the existing templates as a

basis for this.

Select File > New.  Make sure the Part and Solid radio buttons are selected.  Deselect the Use

Default Template box, and enter a name mytemplate.  Select OK and in the next window, select

the Empty template and OK.

Create the default datums and use Part > Set Up > Name to rename the datums SIDE (DTM1),

TOP (DTM2), and FRONT (DTM3). Now set up some named views.

View > Orientation

and create the following three named views:

View

Name

Reference 1 Reference 2

Direction Pick Datum Direction Pick Datum

FRONT Front FRONT Top TOP

TOP Front TOP Right SIDE

RIGHT Front SIDE Top TOP

The completed list of saved views should appear as shown in

Figure 10. Feel free to add additional standard views (Left,

Back, Bottom, Iso_Right, ...). Select OK to leave the

Orientation dialog.

Check out our previously defined mapkey for setting the

default view (“vd”). 

Set the part units using

Set Up > Units

and picking “millimeter-Newton-Second”, then

Set > OK > Close

We are finished with creating the start part, so save it with the

name mytemplate.prt.  If you have write access, move the part
file to the Pro/E installation directory, something like

\ptc\proe2001\templates

This is the default directory where Pro/E will look for part

templates.  If you do not have write access to this directory,
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2 The mapkey “vr”, which is more logical for the right view, is usually used for “View

Refit”

3 If you have stored your template part in the templates directory you must close Pro/E

and restart it.

leave the part file in your working directory.  You can rename the file to remove the version

number if you want, so that it appears as as mytemplate.prt rather than mytemplate.prt.1.

Creating More Mapkeys

Before we leave this new part template, let’s create some more mapkeys to go directly to the

named views.  Select

Utilities > Mapkeys > New

Use the key sequence “vt” and enter a short name like “View Top” and description “Orientation

Top View”.  Now record the mapkey using

Record

Saved View List (a toolbar button) > TOP

Stop > OK

Spin the datum planes, and select Run to try out the mapkey. Similarly, create and test two more

mapkeys to go to the front view (“vf”) and the right side view (“vg”)2.  Don’t forget to save all

the changed/new mapkeys in your config.pro file.  Open up your config.pro to confirm that they

are there.

Using the New Part Template

Erase the current part from the session3.  Select

File > New

Deselect the Use Default Template box, enter a name (like test), and select OK.  In the New File

Options window, scroll to and highlight the template mytemplate.  This is the copy in the

default templates directory.  If you weren’t able to put your file there, use the Browse button to

find it in the working directory.  Once the template is located, select OK.  A copy of the template

is now brought into session and given the name you specified.

Setting the Default Part Template

We can tell Pro/E to use our new template as the default by setting an option in config.pro. 
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Select

Utilities > Options

and enter the Option template_solidpart.  Set the value for the option by browsing to the

template directory (or use the current working directory, wherever you have saved the template

file) and selecting the part file mytemplate.prt we created above.  Select Add/Change and then 

Apply the new setting (remember that this automatically saves the config file).

Creating a Mapkey to Start a New Part

Erase the current part from the session.  Select

Utilities > Mapkeys > New

Enter the key sequence “cp” (“create part”), name “Create Part”, and description “Create a New

Part and Rename”.  Now select

Record

File > New

Choose Part | Solid | OK.  Leave the default part name as prt0001, and the check beside Use

Default Template.  Now select

File > Rename

This is where we want the mapkey to stop, so select STOP > OK in the Record Mapkey dialog. 

In the Rename window, enter a new name for the part, like test, then select OK twice.  We have

a new mapkey called “cp”, so highlight this in the Mapkeys dialog and save it.  Close the

Mapkeys dialog window.  Open the config.pro file to see the listing added for this new mapkey.

To try out the mapkey, erase the new file with File > Erase > Current. Type “cp”.  Several

windows will quickly open and close, and you will be left with the dialog box for renaming the

part.  You can now enter the desired name for a new part, which will contain the default datums,

units, and named views set up above to work with the view mapkeys we created earlier.  Pretty

slick!

We have created a very simple part template here.  You can make this as elaborate as you like

with parameters, units, materials, layers, datum features and so on - even solid features.  For

example, if you often create parts whose base feature is a cylindrical solid, consider including

this in a special template, perhaps called cylinder.prt.  You can include as many features as you

want in a template and, of course, use any of the provided part templates as a starting point for

any new ones.
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Figure 11 Adding mapkeys to menus and toolbars

Figure 12 Create Part

mapkey added to a pull-down

menu

Adding Mapkeys to Menus and Toolbars

Mapkeys can be added to any of the existing toolbars and pull-down menus.  You might like to

do this for mapkeys that you do not use frequently, and are likely to forget.

To see how this is done, select the

Commands tab in the Customize window
(see Figure 11).  At the bottom of the

Categories list, you will find an entry

called Mapkeys. Select this. This shows
the tree structure of the pull-down menus

on the left, and your currently defined

mapkeys on the right.  In the Mapkeys pane

on the right, select the mapkey Create

Part.  The two buttons Description and
Modify Selection are now active.  Selecting

the former shows you the description you

entered when defining the mapkey. 

Selecting the latter allows you to modify

the mapkey button image (currently a

“happy face”) and display.  You might like to get rid of the “happy face”, since all mapkeys use

this same icon.  You can select from a large collection of Pro/E icons, or design your own.

Drag the Create Part mapkey in the right pane up to the File pull-down menu and drop it in a

convenient location, as in Figure 12. Selecting this will launch the mapkey.

Another way to utilize mapkeys is to create shortcut buttons on

the toolbars.  Again select the Create Part mapkey in the right

pane and drag it to a toolbar.

We now have three different ways to launch the Create Part

mapkey:

‚ from the keyboard, with “cp”

‚ from the pull-down File menu

‚ from the toolbar

Experiment with these to find out which one is most suitable for

you.  Again, remember the cautionary note about cluttering up

your screen.

Introduction to the Project

The assembly project to be completed in this tutorial involves the modeling and assembly of the

three-wheeled utility cart shown in Figure 12.  The cart contains 26 or so parts, many of which
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Figure 13 The assembly project - a three-wheeled utility cart

are repeated in the assembly.  The total assembly has about 75 parts (mostly bolts!).  We will use

the techniques introduced in the lessons to model various parts of the cart as exercises at the end

of each lesson.  We will average about 4 parts per lesson, so you should get lots of practice!  In

the final lesson, we will assemble the cart, using a number of advanced functions for dealing with

assemblies.  Try not to “jump the gun” on this assembly task, since the functions to be covered in

the last lesson can really speed up your job of putting the cart together.

For your modeling exercises, the parts shown at the end of each lesson will illustrate the critical

dimensions.  A figure will also be provided to show where the parts fit into the overall assembly. 

Not all dimensions are shown on each part - you can use your judgement and creativity to

determine the remaining dimensions.  In this regard, please take note of the following:

‚ ALL UNITS ARE IN MILLIMETERS!  You might set up your default part template

with this setting.

‚ Dimensions are usually multiples of 5mm.  For instance, all the plate material and the

wall of the cargo box are 5mm thick.  The tubing is 25mm square.

‚ All holes and cylinders, unless otherwise dimensioned, are φ10.  This applies to bolt

holes, pins, rods, and so on.

‚ All holes, unless otherwise dimensioned, are coaxial with cylindrical surfaces or

located on symmetry planes.

‚ For some of the trickier parts, in addition to the figures showing the dimensions, there

will be some discussion and hints to help you get going.

When we get to the final assembly in Lesson 8, remember that it is an easy matter to modify

dimensions of the various parts so that the assembly fits together.  Don’t be too concerned when

you are modeling the parts if you have to guess at one or two dimensions.  These can be modified

later if the need arises.
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4 You might like to look ahead to the last lesson to see what assembly constraints are used

for each part.

When you are creating the parts, try to be aware of the design intent for the part and how it might

eventually be placed in the assembly4.  For example, if the part has one or more planes of

symmetry, it is common practice to use the default datum planes for these.  In the assembly, the

Align constraint using these datum planes is an easy way to position the part (usually with

another symmetric part).

Although a suggested part name is given, feel free to make up your own part names (although

this might cause confusion in Lesson 8!).  Remember that Pro/E is fussy about files that get

renamed in isolation, or moved to another directory.  If a part has been used in an assembly (or

sub-assembly) or drawing, make sure the assembly or drawing is in session if you rename or

move the part so that the related files can also be updated.

For the entire project, you will require about 10 Megabytes of disk space to store all the parts and

assemblies.  This does not include parts we will make during the lessons themselves, just the cart

project parts.  If you are not particularly careful about disk housekeeping (like deleting older

version of the part files), you will require more space.

This lesson should have given you enough ideas and ammunition to allow you to customize the

interface so that it will be most efficient for the type of work that you do.  There are a surprising

number of users who are unaware of many options available in config.pro.  Check them out!

In the next lesson we will look at functions directly involved in model creation.  These are for the

creation of sweeps.

Questions for Review

1. What is the name of the file containing your configuration settings?

2. What is the name of the file containing your screen layout settings?

3. When, and from where, are your configuration settings loaded?  Why is there more than

one location?

4. What happens if your configuration file contains multiple entries for the same option, each

with different values?

5. How can you find out where your start-up directory is?

6. How can you create/edit/delete configuration settings?

7. When do configuration settings become active?

8. Is it possible to have more than one customized screen layout?

9. How do you place toolbars on the top/left/right edge of the graphics window?

10. How do you add/delete shortcut buttons on the toolbars?

11. How many empty toolbars are there?

12. Where are the toolbar definitions saved?

13. What is a mapkey?
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14. Why do you usually want to keep mapkey names short?

15. How is the mapkey name different from the mapkey sequence?

16. How do you create a new mapkey?

17. Are new mapkeys stored automatically?  Where?

18. What is the purpose of a part template?  Where are they stored and how do you access

them?

Exercises

1. Create an assembly template.  This should have named datums and named views to match

your view selection mapkeys and default units to match your default part template.  Make

this the default template for assemblies.

2. Set up a mapkey to create a new assembly using the default assembly template.

3. Put the Create Assembly mapkey on the pull-down File menu.
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Figure 14 Project parts in Lesson #1

Part: handle_pin Part: front_spr_plate

Project Exercises

We’re going to start off with some of the easier parts in the cart.  These should give you some

time to experiment with your configuration file, mapkeys, and part template.  The project parts

are shown in the figures below.  Their location in the cart is also shown for reference in the

Figure here:
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Part: arm_vbrack

Part: arm_brack


